Bug 228931 - lack of printer functionality in general
Summary: lack of printer functionality in general
Status: RESOLVED DUPLICATE of bug 198172
Alias: None
Product: kdelibs
Classification: Unclassified
Component: print-dialog (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-28 18:30 UTC by Attila
Modified: 2010-03-03 22:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Attila 2010-02-28 18:30:28 UTC
Version:            (using KDE 4.4.0)
OS:                Linux
Installed from:    Fedora RPMs

When i want to print, i have to set the printer margins manually. After each print i have to set the margins again and again. I print quite often, so this is annoying not only just me. Please try to imagine if you are using a hole puncher. You don't want the two holes in your output.
Please bring the basic printing functionality back to kde 4.
Thank you!
Comment 1 John Layt 2010-03-01 20:25:58 UTC
Printer settings in Qt are planned to be improved in Qt 4.8.

Note if you want to have the same print margins most times you print from most apps, you can set these as the default setting for that printer in CUPS.
Comment 2 Christoph Feck 2010-03-02 01:22:33 UTC

*** This bug has been marked as a duplicate of bug 198172 ***
Comment 3 Attila 2010-03-03 22:33:41 UTC
(In reply to comment #1)
> Printer settings in Qt are planned to be improved in Qt 4.8.
> 
> Note if you want to have the same print margins most times you print from most
> apps, you can set these as the default setting for that printer in CUPS.

Hello!
Don't get me wrong but i guess that this is not a question of Qt 4.8 or other versions. Under KDE 3x (Qt 3x) the printer dialog was excellent! I was able to set the margins and save the settings. All i would like to do is to save my settings (like the printer dialog under KDE 3x).
Every time i am trying to print, i have to click on "Properties", then set the margins, after that i have to click on "Options >>", select the tab "HTML settings" uncheck "printer friendly mode", uncheck "print header" and so on.
I hate to say that, but this is so stupid! Isn't it? You can't tell in every office all the user: Hey guys! Remember if you print, don't forget to click here, click there ..... and do this on every single print. This is not user-optimized.
Thank you for listening to me.