Bug 228790 - Typing on Search collection and it crashes
Summary: Typing on Search collection and it crashes
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-27 18:47 UTC by jatic89
Modified: 2010-02-28 10:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jatic89 2010-02-27 18:47:03 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Typing just a few characters on Search collection and it crashes

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f52c77307a0 (LWP 2784))]

Thread 11 (Thread 0x7f52a66c1910 (LWP 2972)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f52af684c91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f52a5178910 (LWP 2979)):
#0  IA__g_main_context_prepare (context=0xcb5570, priority=<value optimized out>) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2280
#1  0x00007f52bdf83191 in g_main_context_iterate (context=0xcb5570, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2571
#2  0x00007f52bdf836c0 in IA__g_main_context_iteration (context=0xcb5570, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#3  0x00007f52c54dc1fe in QEventDispatcherGlib::processEvents (this=0xcb53d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:329
#4  0x00007f52c54b2532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f52c54b2904 in QEventLoop::exec (this=0x7f52a5177fb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f52c53ca6cb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f52af8df56e in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#8  0x00007f52c53cd445 in QThreadPrivate::start (arg=0xcb6b60) at thread/qthread_unix.cpp:188
#9  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 9 (Thread 0x7f52a4977910 (LWP 2980)):
#0  0x00007f52c4dc33c3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f52a5aa720f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f52a5a975e6 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f52a5a98eb9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f52a5a98f70 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f52a5aa712b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f52a5868050 in ?? () from /usr/lib/libpulsecommon-0.9.19.so
#7  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()
The current source language is "auto; currently c".

Thread 8 (Thread 0x7f52a0175910 (LWP 2981)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f52af695983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f529f76c910 (LWP 2982)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f52af695983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 6 (Thread 0x7f529ef6b910 (LWP 2983)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f52af695983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f529d87d910 (LWP 3006)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f52c53ce4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1a01400, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1a01400, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f52c2081326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1a01020, th=0x1a019a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f52c208345b in ThreadWeaver::WorkingHardState::applyForWork (this=0x19ff590, th=0x1a019a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f52c2081a5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f529d87d000, parent=0x1a01020, th=0x1a019a0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f52c2081eb8 in ThreadWeaver::Thread::run (this=0x1a019a0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f52c53cd445 in QThreadPrivate::start (arg=0x1a019a0) at thread/qthread_unix.cpp:188
#8  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f5292863910 (LWP 3013)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f52c53ce4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1a01400, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1a01400, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f52c2081326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1a01020, th=0x1836960) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f52c208345b in ThreadWeaver::WorkingHardState::applyForWork (this=0x19ff590, th=0x1836960) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f52c2081a5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5292863000, parent=0x1a01020, th=0x1836960) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f52c2081eb8 in ThreadWeaver::Thread::run (this=0x1836960) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f52c53cd445 in QThreadPrivate::start (arg=0x1836960) at thread/qthread_unix.cpp:188
#8  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5291198910 (LWP 3386)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f52c53ce4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1a01400, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1a01400, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f52c2081326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1a01020, th=0xa5a7a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f52c208345b in ThreadWeaver::WorkingHardState::applyForWork (this=0x19ff590, th=0xa5a7a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f52c2081a5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5291198000, parent=0x1a01020, th=0xa5a7a0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f52c2081eb8 in ThreadWeaver::Thread::run (this=0xa5a7a0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f52c53cd445 in QThreadPrivate::start (arg=0xa5a7a0) at thread/qthread_unix.cpp:188
#8  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5291999910 (LWP 3387)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f52c53ce4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1a01400, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1a01400, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f52c2081326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1a01020, th=0x1955900) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f52c208345b in ThreadWeaver::WorkingHardState::applyForWork (this=0x19ff590, th=0x1955900) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f52c2081a5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5291999000, parent=0x1a01020, th=0x1955900) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f52c2081eb8 in ThreadWeaver::Thread::run (this=0x1955900) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f52c53cd445 in QThreadPrivate::start (arg=0x1955900) at thread/qthread_unix.cpp:188
#8  0x00007f52bf647a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f52c4dcf80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f52c77307a0 (LWP 2784)):
[KCrash Handler]
#5  0x00007f52c6962fb8 in CollectionTreeItemModelBase::handleCompilationQueryResult (this=0x17f7620, qm=0x19d7e50, dataList=...)
    at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:702
#6  0x00007f52c69693a3 in CollectionTreeItemModelBase::newResultReady (this=0x17f7620, collectionId=<value optimized out>, data=)
    at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:681
#7  0x00007f52c6965160 in CollectionTreeItemModelBase::qt_metacall (this=0x17f7620, _c=<value optimized out>, _id=<value optimized out>, _a=0x19b4200)
    at /build/buildd/amarok-2.2.0/obj-x86_64-linux-gnu/src/CollectionTreeItemModelBase.moc:87
#8  0x00007f52c54c30f9 in QObject::event (this=0x17f7620, e=0x1912ee0) at kernel/qobject.cpp:1111
#9  0x00007f52c5dd3efc in QApplicationPrivate::notify_helper (this=0xa60e80, receiver=0x17f7620, e=0x1912ee0) at kernel/qapplication.cpp:4056
#10 0x00007f52c5ddb1ce in QApplication::notify (this=0x7fff9e0f69d0, receiver=0x17f7620, e=0x1912ee0) at kernel/qapplication.cpp:4021
#11 0x00007f52c7265ab6 in KApplication::notify (this=0x7fff9e0f69d0, receiver=0x17f7620, event=0x1912ee0) at ../../kdeui/kernel/kapplication.cpp:302
#12 0x00007f52c54b3c2c in QCoreApplication::notifyInternal (this=0x7fff9e0f69d0, receiver=0x17f7620, event=0x1912ee0) at kernel/qcoreapplication.cpp:610
#13 0x00007f52c54b480a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x936810) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#14 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x936810) at kernel/qcoreapplication.cpp:1247
#15 0x00007f52c54dc533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#16 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#17 0x00007f52bdf7fbce in g_main_dispatch (context=0xa48520) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#18 IA__g_main_context_dispatch (context=0xa48520) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#19 0x00007f52bdf83598 in g_main_context_iterate (context=0xa48520, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#20 0x00007f52bdf836c0 in IA__g_main_context_iteration (context=0xa48520, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#21 0x00007f52c54dc1a6 in QEventDispatcherGlib::processEvents (this=0x936470, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#22 0x00007f52c5e684be in QGuiEventDispatcherGlib::processEvents (this=0x1682e30, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#23 0x00007f52c54b2532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#24 0x00007f52c54b2904 in QEventLoop::exec (this=0x7fff9e0f6960, flags=) at kernel/qeventloop.cpp:201
#25 0x00007f52c54b4ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#26 0x0000000000409ec6 in main (argc=<value optimized out>, argv=0x7fff9e0f8778) at /build/buildd/amarok-2.2.0/src/main.cpp:225
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2010-02-28 10:21:36 UTC
Please upgrade to Amarok 2.2.2: http://kubuntu.org/news/amarok-2.2.2

*** This bug has been marked as a duplicate of bug 206579 ***