Bug 228484 - K3b crashs if click on bookmarks with no existing path
Summary: K3b crashs if click on bookmarks with no existing path
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: k3b
Classification: Applications
Component: general (show other bugs)
Version: 1.68.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-25 17:01 UTC by sobik2
Modified: 2010-02-25 17:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot in PNG with dialog (85.33 KB, image/png)
2010-02-25 17:02 UTC, sobik2
Details
screenshot in PNG with bookmarks to non existing path (103.86 KB, image/png)
2010-02-25 17:02 UTC, sobik2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sobik2 2010-02-25 17:01:40 UTC
Version:           1.68 (using KDE 4.4.0)
OS:                Linux
Installed from:    Ubuntu Packages

K3b crashs if click on bookmarks with no existing path

how to reproduce
================
1) i added the bookmarks to dolphin (see screenshot)
2) after that, i have changed the volume labels, so it is mounted with another path than the old one
3) open k3b -> dialog 'The file or folder .. does not exist' ! -> click OK
4) when i click in K3b window on this old bookmarks with no existing path, k3b crashs
(interesting think is, that dolphin opens it without crash)


Application: K3b (k3b), signal: Segmentation fault
[Current thread is 1 (Thread 0xb3789760 (LWP 17556))]

Thread 2 (Thread 0xb06f4b70 (LWP 17573)):
#0  0xb7816430 in __kernel_vsyscall ()
#1  0xb42a5142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb45078d4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb5188c1e in ?? () from /usr/lib/libQtCore.so.4
#4  0xb5188dc0 in QThread::sleep(unsigned long) () from /usr/lib/libQtCore.so.4
#5  0xb769f2e9 in K3b::MediaCache::PollThread::run() () from /usr/lib/libk3b.so.6
#6  0xb518932e in ?? () from /usr/lib/libQtCore.so.4
#7  0xb42a080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0xb44fa8de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb3789760 (LWP 17556)):
[KCrash Handler]
#6  0xb5239fb9 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0xb54f97f9 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0xb73c9c5e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0x0816cf0f in _start ()
Comment 1 sobik2 2010-02-25 17:02:14 UTC
Created attachment 41099 [details]
screenshot in PNG with dialog
Comment 2 sobik2 2010-02-25 17:02:46 UTC
Created attachment 41100 [details]
screenshot in PNG with bookmarks to non existing path
Comment 3 Michał Małek 2010-02-25 17:57:26 UTC
This is a bug in kdelibs

*** This bug has been marked as a duplicate of bug 211525 ***