Bug 228358 - Amarok fails to encode CDs / make use of kio_audiocd
Summary: Amarok fails to encode CDs / make use of kio_audiocd
Status: RESOLVED DUPLICATE of bug 224437
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.2
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-24 20:20 UTC by quazgar
Modified: 2010-02-24 21:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description quazgar 2010-02-24 20:20:33 UTC
Version:           2.2.2 (using KDE 4.3.5)
Compiler:          gcc-4.3.4 
OS:                Linux
Installed from:    Gentoo Packages

Trying to encode tracks from audio cds via right-click in Amarok and choosing "Copy to collection" fails; Amarok doesn't show anything at all, just a progress bar for a fraction of a second.  When starting Amarok with "-d --nofork" though, its output has this interesting part in it:

===
.....
amarok: BEGIN: void AudioCdCollectionLocation::onFormatSelected(int)
amarok:   BEGIN: QStringList MountPointManager::collectionFolders()
amarok:   END__: QStringList MountPointManager::collectionFolders() - Took 0.00012s
amarok:   BEGIN: void FilenameLayoutDialog::inferScheme(const QString&)
amarok:      infering scheme:  ""
amarok:   END__: void FilenameLayoutDialog::inferScheme(const QString&) - Took 0.00012s
amarok:   BEGIN: void FilenameLayoutDialog::inferScheme(const QString&)
amarok:      infering scheme:  "%initial/%artist/%album/%track_%title.%filetype"
amarok:   END__: void FilenameLayoutDialog::inferScheme(const QString&) - Took 0.0027s
amarok:   BEGIN: virtual bool Meta::AudioCdAlbum::isCompilation() const
amarok:   END__: virtual bool Meta::AudioCdAlbum::isCompilation() const - Took 9.8e-05s
amarok:    I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-"
amarok:    I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-"
amarok:    I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-"
amarok:    I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-"
amarok:    I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-_Fields_Of_Gold"
amarok:    I'm about to do Amarok::vfatPath( result ), this is result:  ""
amarok:    I'm about to do Amarok::vfatPath( result ), this is result:  "Ten_Summoners's_Tales"
amarok:    I'm about to do Amarok::vfatPath( result ), this is result:  "New_Age"
amarok:    I'm about to do Amarok::vfatPath( result ), this is result:  ""
amarok: END__: void AudioCdCollectionLocation::onFormatSelected(int) - Took 0.059s
amarok: BEGIN: virtual bool Meta::AudioCdAlbum::isCompilation() const
amarok: END__: virtual bool Meta::AudioCdAlbum::isCompilation() const - Took 9.3e-05s
amarok:  I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-"
amarok:  I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-"
amarok:  I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-"
amarok:  I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-"
amarok:  I'm about to do Amarok::vfatPath( result ), this is result:  "Sting_-_Fields_Of_Gold"
amarok:  I'm about to do Amarok::vfatPath( result ), this is result:  ""
amarok:  I'm about to do Amarok::vfatPath( result ), this is result:  "Ten_Summoners's_Tales"
amarok:  I'm about to do Amarok::vfatPath( result ), this is result:  "New_Age"
amarok:  I'm about to do Amarok::vfatPath( result ), this is result:  ""
amarok: BEGIN: virtual void AudioCdCollectionLocation::getKIOCopyableUrls(const Meta::TrackList&)
amarok:   BEGIN: bool SqlCollectionLocation::startNextJob()
amarok:      copying from  KUrl("audiocd:/Ogg Vorbis/-03-Sting - Fields Of Gold.ogg")  to  KUrl("file:///data/musik/S/Sting_-/Ten_Summoners's_Tales/03_Sting_-_Fi\
elds_Of_Gold.ogg")
amarok:     BEGIN: void ProgressBar::setDescription(const QString&)
amarok:     END__: void ProgressBar::setDescription(const QString&) - Took 7.7e-05s
amarok:     BEGIN: void CompoundProgressBar::addProgressBar(ProgressBar*, QObject*)
amarok:       BEGIN: void ProgressBar::setDescription(const QString&)
amarok:       END__: void ProgressBar::setDescription(const QString&) - Took 5.2e-05s
amarok:     END__: void CompoundProgressBar::addProgressBar(ProgressBar*, QObject*) - Took 0.00038s
amarok:   END__: bool SqlCollectionLocation::startNextJob() - Took 0.0014s
amarok: END__: virtual void AudioCdCollectionLocation::getKIOCopyableUrls(const Meta::TrackList&) - Took 0.0015s
amarok: BEGIN: virtual OrganizeCollectionDialog::~OrganizeCollectionDialog()
amarok: END__: virtual OrganizeCollectionDialog::~OrganizeCollectionDialog() - Took 5e-05s
amarok:  [WARNING!] An error occurred when copying a file:  "The file or folder /Ogg Vorbis/-03-Sting - Fields Of Gold.ogg does not exist."
amarok: BEGIN: bool SqlCollectionLocation::startNextJob()
amarok: END__: bool SqlCollectionLocation::startNextJob() - Took 4.7e-05s
.....
===

Encoding via drag&drop from the "audiocd:///Ogg Vorbis/" Dolphin works fine, so I don't think it's (purely) kio_audiocd's fault.
Comment 1 Myriam Schweingruber 2010-02-24 21:21:58 UTC

*** This bug has been marked as a duplicate of bug 224437 ***