Bug 228345 - Too many simultaneous connection in Dolphin using sftp://
Summary: Too many simultaneous connection in Dolphin using sftp://
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.4
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-24 18:16 UTC by Manuel Schmid
Modified: 2011-03-23 19:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Schmid 2010-02-24 18:16:56 UTC
Version:            (using KDE 4.4.0)
OS:                Linux
Installed from:    Ubuntu Packages

I am not really sure if this should be treated as a bug or a wishlist item. My problem is the following:

When I try to connect to my Webfaction webspace using sftp:// in Dolphin, I get asked for the password several times. Then, when I am lucky, I can browse the webspace normally. However, most of the times, I lose the connection soon and I am not able to connect anymore for quite some time, both with Dolphin and via the console. Webfaction pointed out that they only allow 30 simultaneous ssh connections, so I believe that the problem is related to this.

I don’t really know what is the solution to this problem, but I reported it anyway because it makes sftp:// in Dolphin useless for me and other users might be affected as well. Thanks for looking into this.
Comment 1 Dario Cambié 2010-03-07 15:39:25 UTC
Same for me over ftp.
Disabling preview or use a non-icon view halps a little but still, when the cursor is over an element, a connection is open in order to fill the 'Information' panel, wich is annoying if connection limit for IP is 8 as with my provider. (as shown by "lsof -i | grep kio_ftp")

Maybe an option to choose when show previws could help.
Nautilus default, p.es, is to show previews for local filesystems only but also an option Always show is provided.
Comment 2 Peter Penz 2011-03-23 19:10:18 UTC
Git commit c75f00df21d127b24a0e243eeeeaa075a8408cf9 by Peter Penz.
Committed on 23/03/2011 at 19:07.
Pushed by ppenz into branch 'master'.

KUrlNavigator: Don't use KIO::stat() for all non-local URLs

Doing a text-resolving with KIO::stat() for all non-local
URLs leads to problems for protocols where a limit is given for
the number of parallel connections.

BUG: 179237
BUG: 228345
BUG: 202097
FIXED-IN: 4.7.0

M  +16   -3    kfile/kurlnavigatorbutton.cpp     

http://commits.kde.org/kdelibs/c75f00df21d127b24a0e243eeeeaa075a8408cf9
Comment 3 Manuel Schmid 2011-03-23 19:44:34 UTC
Thanks for fixing this!