Bug 228099 - Amarok crashes during entering search string
Summary: Amarok crashes during entering search string
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-22 20:48 UTC by John Berkhout
Modified: 2010-02-22 21:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Berkhout 2010-02-22 20:48:58 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-19-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When entering a search string for the Jamendo db, ie "Bach", Amarok crashes after second or third character. This is reproducible at will.

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0xb666d950 (LWP 8027))]

Thread 11 (Thread 0xb453cb70 (LWP 8028)):
#0  0x00830422 in __kernel_vsyscall ()
#1  0x01834142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x02aad8d4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x058fc9ff in ?? () from /usr/lib/libxine.so.1
#4  0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 10 (Thread 0xb3d3bb70 (LWP 8029)):
#0  0x01833144 in __pthread_mutex_unlock_usercnt () from /lib/tls/i686/cmov/libpthread.so.0
#1  0x02aada86 in pthread_mutex_unlock () from /lib/tls/i686/cmov/libc.so.6
#2  0x052d75df in ?? () from /lib/libglib-2.0.so.0
#3  0x052d7863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x077aa067 in QEventDispatcherGlib::processEvents (this=0x8507f88, flags=...) at kernel/qeventdispatcher_glib.cpp:329
#5  0x0777dc79 in QEventLoop::processEvents (this=0xb3d3b284, flags=) at kernel/qeventloop.cpp:149
#6  0x0777e0ca in QEventLoop::exec (this=0xb3d3b284, flags=...) at kernel/qeventloop.cpp:201
#7  0x0768bb73 in QThread::exec (this=0x8507f30) at thread/qthread.cpp:487
#8  0x021c320a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#9  0x0768ee32 in QThreadPrivate::start (arg=0x8507f30) at thread/qthread_unix.cpp:188
#10 0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#11 0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 9 (Thread 0xb353ab70 (LWP 8032)):
#0  0x02a92c98 in poll () from /lib/tls/i686/cmov/libc.so.6
#1  0x023b9c3b in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#2  0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#3  0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 8 (Thread 0xb2d39b70 (LWP 8033)):
#0  0x00830422 in __kernel_vsyscall ()
#1  0x01833e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x02aad87d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0590d5ee in ?? () from /usr/lib/libxine.so.1
#4  0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 7 (Thread 0xb23ffb70 (LWP 8034)):
#0  0x00830422 in __kernel_vsyscall ()
#1  0x01833e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x02aad87d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0590d5ee in ?? () from /usr/lib/libxine.so.1
#4  0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xb1bfeb70 (LWP 8035)):
#0  0x00830422 in __kernel_vsyscall ()
#1  0x01833e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x02aad87d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0590d5ee in ?? () from /usr/lib/libxine.so.1
#4  0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xb0d07b70 (LWP 8037)):
#0  0x00830422 in __kernel_vsyscall ()
#1  0x01833e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x02aad87d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0768fe67 in QWaitConditionPrivate::wait (this=0x873ee18, mutex=0x8aed380, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x873ee18, mutex=0x8aed380, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x0704fb30 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x873ee00, th=0x8cb3ee8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x0705219c in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8479888, th=0x8cb3ee8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x0704e1fb in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x873ee00, th=0x8cb3ee8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x07052292 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8479888, th=0x8cb3ee8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x0704fdb3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x873ee00, th=0x8cb3ee8, previous=0x86090b0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x070503be in ThreadWeaver::ThreadRunHelper::run (this=0xb0d072d4, parent=0x873ee00, th=0x8cb3ee8) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x070509db in ThreadWeaver::Thread::run (this=0x8cb3ee8) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x0768ee32 in QThreadPrivate::start (arg=0x8cb3ee8) at thread/qthread_unix.cpp:188
#13 0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xafc7ab70 (LWP 8038)):
#0  0x00830422 in __kernel_vsyscall ()
#1  0x01833e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x02aad87d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0768fe67 in QWaitConditionPrivate::wait (this=0x873ee18, mutex=0x8aed380, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x873ee18, mutex=0x8aed380, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x0704fb30 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x873ee00, th=0x8d34838) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x0705219c in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8479888, th=0x8d34838) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x0704e1fb in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x873ee00, th=0x8d34838) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x07052292 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8479888, th=0x8d34838) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x0704fdb3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x873ee00, th=0x8d34838, previous=0xb23f3f8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x070503be in ThreadWeaver::ThreadRunHelper::run (this=0xafc7a2d4, parent=0x873ee00, th=0x8d34838) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x070509db in ThreadWeaver::Thread::run (this=0x8d34838) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x0768ee32 in QThreadPrivate::start (arg=0x8d34838) at thread/qthread_unix.cpp:188
#13 0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xad47bb70 (LWP 8042)):
#0  0x00830422 in __kernel_vsyscall ()
#1  0x01833e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x02aad87d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0768fe67 in QWaitConditionPrivate::wait (this=0x873ee18, mutex=0x8aed380, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x873ee18, mutex=0x8aed380, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x0704fb30 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x873ee00, th=0x8478720) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x0705219c in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8479888, th=0x8478720) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x0704e1fb in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x873ee00, th=0x8478720) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x07052292 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8479888, th=0x8478720) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x0704fdb3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x873ee00, th=0x8478720, previous=0xb2614c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x070503be in ThreadWeaver::ThreadRunHelper::run (this=0xad47b2d4, parent=0x873ee00, th=0x8478720) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x070509db in ThreadWeaver::Thread::run (this=0x8478720) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x0768ee32 in QThreadPrivate::start (arg=0x8478720) at thread/qthread_unix.cpp:188
#13 0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa2d1bb70 (LWP 8043)):
#0  0x00830422 in __kernel_vsyscall ()
#1  0x01833e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x02aad87d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0768fe67 in QWaitConditionPrivate::wait (this=0x873ee18, mutex=0x8aed380, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x873ee18, mutex=0x8aed380, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x0704fb30 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x873ee00, th=0xb24c518) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x0705219c in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8479888, th=0xb24c518) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x0704e1fb in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x873ee00, th=0xb24c518) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x07052292 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8479888, th=0xb24c518) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x0704fdb3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x873ee00, th=0xb24c518, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x070522b1 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8479888, th=0xb24c518) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#11 0x0704fdb3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x873ee00, th=0xb24c518, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#12 0x070522b1 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8479888, th=0xb24c518) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#13 0x0704fdb3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x873ee00, th=0xb24c518, previous=0xb24c500) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#14 0x070503be in ThreadWeaver::ThreadRunHelper::run (this=0xa2d1b2d4, parent=0x873ee00, th=0xb24c518) at ../../../threadweaver/Weaver/Thread.cpp:87
#15 0x070509db in ThreadWeaver::Thread::run (this=0xb24c518) at ../../../threadweaver/Weaver/Thread.cpp:142
#16 0x0768ee32 in QThreadPrivate::start (arg=0xb24c518) at thread/qthread_unix.cpp:188
#17 0x0182f80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#18 0x02aa08de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb666d950 (LWP 8027)):
[KCrash Handler]
#6  QListData::size (this=0xb24a058) at /usr/include/qt4/QtCore/qlist.h:87
#7  QList<CollectionTreeItem*>::indexOf (this=0xb24a058) at /usr/include/qt4/QtCore/qlist.h:633
#8  CollectionTreeItem::row (this=0xb24a058) at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItem.cpp:292
#9  0x0093fef7 in CollectionTreeItemModelBase::handleNormalQueryResult (this=0xb247868, qm=0xb24a898, dataList=...) at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:798
#10 0x0094032e in CollectionTreeItemModelBase::newResultReady (this=0xb247868, collectionId=..., data=...) at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:677
#11 0x0093bb1c in CollectionTreeItemModelBase::qt_metacall (this=0xb247868, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xb2395b0)
    at /build/buildd/amarok-2.2.0/obj-i486-linux-gnu/src/CollectionTreeItemModelBase.moc:87
#12 0x00952b62 in SingleCollectionTreeItemModel::qt_metacall (this=0xb247868, _c=QMetaObject::InvokeMetaMethod, _id=23, _a=0xb2395b0)
    at /build/buildd/amarok-2.2.0/obj-i486-linux-gnu/src/SingleCollectionTreeItemModel.moc:58
#13 0x0778df0b in QMetaCallEvent::placeMetaCall (this=0xb2ad2a8, object=0xb247868) at kernel/qobject.cpp:477
#14 0x0778f5fe in QObject::event (this=0xb247868, e=0xb2ad2a8) at kernel/qobject.cpp:1111
#15 0x00f0ff54 in QApplicationPrivate::notify_helper (this=0x8476290, receiver=0xb247868, e=0xb2ad2a8) at kernel/qapplication.cpp:4056
#16 0x00f1767c in QApplication::notify (this=0xbf93c9cc, receiver=0xb247868, e=0xb2ad2a8) at kernel/qapplication.cpp:3603
#17 0x002e2bfa in KApplication::notify (this=0xbf93c9cc, receiver=0xb247868, event=0xb2ad2a8) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x0777f6cb in QCoreApplication::notifyInternal (this=0xbf93c9cc, receiver=0xb247868, event=0xb2ad2a8) at kernel/qcoreapplication.cpp:610
#19 0x077802b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x83b8b58) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x83b8b58) at kernel/qcoreapplication.cpp:1247
#21 0x0778047d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x077aa3ff in QCoreApplication::sendPostedEvents (s=0x846f100) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x846f100) at kernel/qeventdispatcher_glib.cpp:210
#24 0x052d3e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x052d7730 in ?? () from /lib/libglib-2.0.so.0
#26 0x052d7863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x077aa02c in QEventDispatcherGlib::processEvents (this=0x83b8d30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x00fb0be5 in QGuiEventDispatcherGlib::processEvents (this=0x83b8d30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x0777dc79 in QEventLoop::processEvents (this=0xbf93c934, flags=) at kernel/qeventloop.cpp:149
#30 0x0777e0ca in QEventLoop::exec (this=0xbf93c934, flags=...) at kernel/qeventloop.cpp:201
#31 0x0778053f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x00f0fdd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x08051e49 in main (argc=1, argv=0xbf93d1d4) at /build/buildd/amarok-2.2.0/src/main.cpp:225

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2010-02-22 21:35:24 UTC
Please upgrade your Amarok version, the current stable one is Amarok 2.2.2

*** This bug has been marked as a duplicate of bug 206579 ***