Bug 228085 - Plasma crash on resume from hibernation
Summary: Plasma crash on resume from hibernation
Status: RESOLVED DUPLICATE of bug 210769
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-clock (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-22 17:35 UTC by Per Ångström
Modified: 2010-06-08 23:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Per Ångström 2010-02-22 17:35:50 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.00 (KDE 4.4.0)
Qt Version: 4.6.1
Operating System: Linux 2.6.32-14-generic x86_64
Distribution: Ubuntu lucid (development branch)

-- Information about the crash:
This is the second time today that I have tried to resume from hibernation, and both times I have had Plasma crash on me instantly after unlocking the screen. Now my panel is gone.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently asm".
[Current thread is 1 (Thread 0x7ffcebc5f800 (LWP 1716))]

Thread 4 (Thread 0x7ffcc6978710 (LWP 1717)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007ffce8bfe4e9 in _L_lock_11708 () from /lib/libc.so.6
#2  0x00007ffce8bfcce1 in *__GI___libc_free (mem=0x7ffce8ef9e40) at malloc.c:3736
#3  0x00007ffcea25b5b1 in socketNotifierSourceCheck (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:92
#4  0x00007ffce541b12a in g_main_context_check () from /lib/libglib-2.0.so.0
#5  0x00007ffce541ba5b in ?? () from /lib/libglib-2.0.so.0
#6  0x00007ffce541bf0c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#7  0x00007ffcea25b196 in QEventDispatcherGlib::processEvents (this=0x21b3f60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#8  0x00007ffcea230582 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#9  0x00007ffcea23095c in QEventLoop::exec (this=0x7ffcc6977d40, flags=) at kernel/qeventloop.cpp:201
#10 0x00007ffcea13ad39 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#11 0x00007ffcea210dc8 in QInotifyFileSystemWatcherEngine::run (this=0x1834270) at io/qfilesystemwatcher_inotify.cpp:248
#12 0x00007ffcea13d755 in QThreadPrivate::start (arg=0x1834270) at thread/qthread_unix.cpp:248
#13 0x00007ffce9eadb14 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#14 0x00007ffce8c6407d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#15 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ffcbf9ca710 (LWP 1719)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007ffce8bfe4e9 in _L_lock_11708 () from /lib/libc.so.6
#2  0x00007ffce8bfcce1 in *__GI___libc_free (mem=0x7ffce8ef9e40) at malloc.c:3736
#3  0x00007ffcea13d344 in QThreadPrivate::finish (arg=<value optimized out>) at thread/qthread_unix.cpp:284
#4  0x00007ffcea13d75d in ~__pthread_cleanup_class (arg=0x7ffcea545f20) at /usr/include/pthread.h:535
#5  QThreadPrivate::start (arg=0x7ffcea545f20) at thread/qthread_unix.cpp:253
#6  0x00007ffce9eadb14 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#7  0x00007ffce8c6407d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ffcc52e5710 (LWP 2484)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007ffce8bfe4e9 in _L_lock_11708 () from /lib/libc.so.6
#2  0x00007ffce8bfcce1 in *__GI___libc_free (mem=0x7ffce8ef9e40) at malloc.c:3736
#3  0x00007ffce54177db in ?? () from /lib/libglib-2.0.so.0
#4  0x00007ffcea25bc43 in ~QEventDispatcherGlib (this=0x2349b10, __in_chrg=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:366
#5  0x00007ffcea13d344 in QThreadPrivate::finish (arg=<value optimized out>) at thread/qthread_unix.cpp:284
#6  0x00007ffcea13d75d in ~__pthread_cleanup_class (arg=0x21b7b10) at /usr/include/pthread.h:535
#7  QThreadPrivate::start (arg=0x21b7b10) at thread/qthread_unix.cpp:253
#8  0x00007ffce9eadb14 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007ffce8c6407d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffcebc5f800 (LWP 1716)):
[KCrash Handler]
#5  0x00007ffce8bf6c1c in malloc_consolidate (av=0x7ffce8ef9e40) at malloc.c:5142
#6  0x00007ffce8bfa34d in _int_malloc (av=0x7ffce8ef9e40, bytes=1227) at malloc.c:4370
#7  0x00007ffce8bfb90e in *__GI___libc_malloc (bytes=1227) at malloc.c:3660
#8  0x00007ffce8c1afca in __tzfile_read (file=<value optimized out>, extra=0, extrap=<value optimized out>) at tzfile.c:257
#9  0x00007ffce8c1a0d2 in tzset_internal (always=<value optimized out>, explicit=<value optimized out>) at tzset.c:439
#10 0x00007ffce8c1a3c0 in __tzset () at tzset.c:592
#11 0x00007ffceb6c074e in KSystemTimeZoneBackend::offset (this=<value optimized out>, caller=<value optimized out>, t=1266856187) at ../../kdecore/date/ksystemtimezone.cpp:625
#12 0x00007ffceb6bd482 in KTimeZone::toZoneTime (this=0x7fffbd6edd60, utcDateTime=..., secondOccurrence=0x7fffbd6edcbf) at ../../kdecore/date/ktimezone.cpp:768
#13 0x00007ffceb6adf14 in KDateTimePrivate::toZone (this=0x1877440, zone=..., local=<value optimized out>) at ../../kdecore/date/kdatetime.cpp:726
#14 0x00007ffceb6adfee in KDateTimePrivate::newToZone (this=0x1877440, newd=0x21aec30, zone=..., local=...) at ../../kdecore/date/kdatetime.cpp:742
#15 0x00007ffceb6b6eb6 in KDateTime::toTimeSpec (this=0x7fffbd6eddf0, spec=...) at ../../kdecore/date/kdatetime.cpp:994
#16 0x00007ffceb6b6f0f in KDateTime::currentDateTime (spec=...) at ../../kdecore/date/kdatetime.cpp:1263
#17 0x00007ffcc44c84a6 in ?? () from /usr/lib/kde4/plasma_engine_time.so
#18 0x00007ffcc44c57b7 in ?? () from /usr/lib/kde4/plasma_engine_time.so
#19 0x00007ffce187f7b6 in Plasma::DataEnginePrivate::internalUpdateSource (this=0x239f130, source=0x2439fc0) at ../../plasma/dataengine.cpp:563
#20 0x00007ffce1881f48 in Plasma::DataEngine::qt_metacall (this=0x2426e80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffbd6ee1e0) at ./dataengine.moc:127
#21 0x00007ffcc44c5aa8 in ?? () from /usr/lib/kde4/plasma_engine_time.so
#22 0x00007ffcea244a5f in QMetaObject::activate (sender=0x2439fc0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x31) at kernel/qobject.cpp:3275
#23 0x00007ffce187d582 in Plasma::DataContainer::updateRequested (this=0x7ffce8ef9e40, _t1=0x2439fc0) at ./datacontainer.moc:115
#24 0x00007ffce18b5493 in Plasma::SignalRelay::timerEvent (this=0x243b4a0, event=<value optimized out>) at ../../plasma/private/datacontainer_p.cpp:155
#25 0x00007ffcea2416b3 in QObject::event (this=0x243b4a0, e=0x7fffbd6ee930) at kernel/qobject.cpp:1212
#26 0x00007ffce93d007c in QApplicationPrivate::notify_helper (this=0x1802650, receiver=0x243b4a0, e=0x7fffbd6ee930) at kernel/qapplication.cpp:4298
#27 0x00007ffce93d666b in QApplication::notify (this=0x17ec6f0, receiver=0x243b4a0, e=0x7fffbd6ee930) at kernel/qapplication.cpp:4181
#28 0x00007ffcea7791d6 in KApplication::notify (this=0x17ec6f0, receiver=0x243b4a0, event=0x7fffbd6ee930) at ../../kdeui/kernel/kapplication.cpp:302
#29 0x00007ffcea231c5c in QCoreApplication::notifyInternal (this=0x17ec6f0, receiver=0x243b4a0, event=0x7fffbd6ee930) at kernel/qcoreapplication.cpp:704
#30 0x00007ffcea25e982 in QCoreApplication::sendEvent (this=0x1805ce0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QTimerInfoList::activateTimers (this=0x1805ce0) at kernel/qeventdispatcher_unix.cpp:603
#32 0x00007ffcea25b478 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#33 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#34 0x00007ffce5417ef0 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007ffce541bd28 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007ffce541bf0c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007ffcea25b143 in QEventDispatcherGlib::processEvents (this=0x18024c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#38 0x00007ffce947f88e in QGuiEventDispatcherGlib::processEvents (this=0x7ffce8ef9e40, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007ffcea230582 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007ffcea23095c in QEventLoop::exec (this=0x7fffbd6eebd0, flags=) at kernel/qeventloop.cpp:201
#41 0x00007ffcea23469b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#42 0x00007ffcdde720c2 in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#43 0x0000000000406fe8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4d9 "0") at ../../kinit/kinit.cpp:717
#44 0x0000000000407ca0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#45 0x000000000040822f in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#46 0x0000000000408e42 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1841

Reported using DrKonqi
Comment 1 Beat Wolf 2010-02-25 10:44:27 UTC
seems like the crash is somewhere in the time engine
Comment 2 Dario Andres 2010-03-21 02:57:36 UTC
If wonder if this could be related to bug 210769
Comment 3 Beat Wolf 2010-06-08 23:07:30 UTC
indeed, seems to be the same bug.

*** This bug has been marked as a duplicate of bug 210769 ***