Bug 227903 - digiKam crashes on every second image I edit
Summary: digiKam crashes on every second image I edit
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Database-Scan (show other bugs)
Version: 1.2.0
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-21 09:07 UTC by Andi Clemens
Modified: 2017-08-08 11:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andi Clemens 2010-02-21 09:07:21 UTC
Application: digikam (1.2.0)
KDE Platform Version: 4.4.00 (KDE 4.4.0)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-ARCH i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
I do simple things, at the moment I only crop images for a screenshot database at work. On every second crop & save (CTRL+X, simple crop) digiKam IE crashes. This is NOT true for showFoto, so it must be digikam related.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2727740 (LWP 17006))]

Thread 18 (Thread 0xb0ed3b70 (LWP 17007)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfde55 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4c961b7 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0x082e17f8 in Digikam::ScanController::run (this=0x8debac8) at /home/andi/Programmieren/KDE/digikam/digikam/scancontroller.cpp:502
#4  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#6  0xb49cd01e in clone () from /lib/libc.so.6

Thread 17 (Thread 0xb02ffb70 (LWP 17008)):
#0  0xb2f59de6 in clock_gettime () from /lib/librt.so.1
#1  0xb4dbf70b in ?? () from /usr/lib/libQtCore.so.4
#2  0xb4dc4905 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb4dc494a in ?? () from /usr/lib/libQtCore.so.4
#4  0xb4dc2818 in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4dc28ad in ?? () from /usr/lib/libQtCore.so.4
#6  0xb3270470 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#7  0xb3270811 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#8  0xb3270d23 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#9  0xb4dc260f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb4d952f9 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb4d9574a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#12 0xb4c92558 in QThread::exec() () from /usr/lib/libQtCore.so.4
#13 0xb6701325 in Digikam::ImageFilterModelWorker::Thread::run (this=0x8eb2d40) at /home/andi/Programmieren/KDE/digikam/digikam/../libs/models/imagefiltermodelthreads.h:66
#14 0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#15 0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#16 0xb49cd01e in clone () from /lib/libc.so.6

Thread 16 (Thread 0xafafeb70 (LWP 17009)):
#0  0xb4bfd18f in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb326ece6 in g_main_context_release () from /usr/lib/libglib-2.0.so.0
#2  0xb3270951 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#3  0xb3270d23 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb4dc260f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb4d952f9 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb4d9574a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb4c92558 in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0xb6701325 in Digikam::ImageFilterModelWorker::Thread::run (this=0x8e8a958) at /home/andi/Programmieren/KDE/digikam/digikam/../libs/models/imagefiltermodelthreads.h:66
#9  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#10 0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#11 0xb49cd01e in clone () from /lib/libc.so.6

Thread 15 (Thread 0xaf2fdb70 (LWP 17010)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfde55 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4c961b7 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb699608b in Digikam::LoadSaveThread::run (this=0x8ea5638) at /home/andi/Programmieren/KDE/digikam/libs/threadimageio/loadsavethread.cpp:131
#4  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#6  0xb49cd01e in clone () from /lib/libc.so.6

Thread 14 (Thread 0xaeafcb70 (LWP 17011)):
#0  0xb2f59de6 in clock_gettime () from /lib/librt.so.1
#1  0xb4dbf70b in ?? () from /usr/lib/libQtCore.so.4
#2  0xb4dc4905 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb4dc494a in ?? () from /usr/lib/libQtCore.so.4
#4  0xb4dc2818 in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4dc28ad in ?? () from /usr/lib/libQtCore.so.4
#6  0xb3270470 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#7  0xb3270811 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#8  0xb3270d23 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#9  0xb4dc260f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb4d952f9 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb4d9574a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#12 0xb4c92558 in QThread::exec() () from /usr/lib/libQtCore.so.4
#13 0x082d8bf1 in Digikam::MetadataManagerWorker::Thread::run (this=0x8e97000) at /home/andi/Programmieren/KDE/digikam/digikam/metadatamanager_p.h:143
#14 0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#15 0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#16 0xb49cd01e in clone () from /lib/libc.so.6

Thread 13 (Thread 0xae2fbb70 (LWP 17012)):
#0  0xb4bfbda4 in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb326edbf in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#2  0xb3270785 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#3  0xb3270d23 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb4dc260f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb4d952f9 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb4d9574a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb4c92558 in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0x082d8bf1 in Digikam::MetadataManagerWorker::Thread::run (this=0x8efd838) at /home/andi/Programmieren/KDE/digikam/digikam/metadatamanager_p.h:143
#9  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#10 0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#11 0xb49cd01e in clone () from /lib/libc.so.6

Thread 12 (Thread 0xab4b4b70 (LWP 17013)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfe182 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xac494ba5 in metronom_sync_loop () from /usr/lib/libxine.so.1
#3  0x00000000 in ?? ()

Thread 11 (Thread 0xaa859b70 (LWP 17015)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb49c5f41 in select () from /lib/libc.so.6
#2  0xac4bee78 in xine_usec_sleep () from /usr/lib/libxine.so.1
#3  0x00000000 in ?? ()

Thread 10 (Thread 0xaa058b70 (LWP 17016)):
#0  0xb4bf8320 in __i686.get_pc_thunk.bx () from /lib/libpthread.so.0
#1  0xb4bfd159 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#2  0xb326edf9 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#3  0xb3270785 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#4  0xb3270d23 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb4dc260f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb4d952f9 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb4d9574a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb4c92558 in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb046cc29 in Phonon::Xine::XineThread::run() () from /usr/lib/kde4/plugins/phonon_backend/phonon_xine.so
#10 0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#11 0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#12 0xb49cd01e in clone () from /lib/libc.so.6

Thread 9 (Thread 0xa9857b70 (LWP 17019)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb49c2eb6 in poll () from /lib/libc.so.6
#2  0xaaca4d91 in ao_alsa_handle_event_thread () from /usr/lib/xine/plugins/1.27/xineplug_ao_out_alsa.so
#3  0x00000000 in ?? ()

Thread 8 (Thread 0xa9056b70 (LWP 17020)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfde55 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xac4a68ec in ao_loop () from /usr/lib/libxine.so.1
#3  0xa9056300 in ?? ()

Thread 7 (Thread 0xa8753b70 (LWP 17021)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfde55 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4c961b7 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb699608b in Digikam::LoadSaveThread::run (this=0x97d9158) at /home/andi/Programmieren/KDE/digikam/libs/threadimageio/loadsavethread.cpp:131
#4  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#6  0xb49cd01e in clone () from /lib/libc.so.6

Thread 6 (Thread 0xa7751b70 (LWP 17027)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfde55 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4c961b7 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb699608b in Digikam::LoadSaveThread::run (this=0x9989c20) at /home/andi/Programmieren/KDE/digikam/libs/threadimageio/loadsavethread.cpp:131
#4  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#6  0xb49cd01e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xa7f52b70 (LWP 17028)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfde55 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4c961b7 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb699608b in Digikam::LoadSaveThread::run (this=0x99cdb38) at /home/andi/Programmieren/KDE/digikam/libs/threadimageio/loadsavethread.cpp:131
#4  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#6  0xb49cd01e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xa674fb70 (LWP 17085)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfde55 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4c961b7 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb699608b in Digikam::LoadSaveThread::run (this=0xb2e4cc0) at /home/andi/Programmieren/KDE/digikam/libs/threadimageio/loadsavethread.cpp:131
#4  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#6  0xb49cd01e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa41feb70 (LWP 17086)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfde55 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4c961b7 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb699608b in Digikam::LoadSaveThread::run (this=0xb714420) at /home/andi/Programmieren/KDE/digikam/libs/threadimageio/loadsavethread.cpp:131
#4  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#6  0xb49cd01e in clone () from /lib/libc.so.6

Thread 2 (Thread 0x9dcfcb70 (LWP 17092)):
#0  0xb7882424 in __kernel_vsyscall ()
#1  0xb4bfde55 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4c961b7 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb699608b in Digikam::LoadSaveThread::run (this=0xb89d7e8) at /home/andi/Programmieren/KDE/digikam/libs/threadimageio/loadsavethread.cpp:131
#4  0xb4c9527e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb4bf98ac in start_thread () from /lib/libpthread.so.0
#6  0xb49cd01e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb2727740 (LWP 17006)):
[KCrash Handler]
#6  0xb61ae590 in KDirWatchPrivate::Entry::propagate_dirty() () from /usr/lib/libkio.so.5
#7  0xb61ae5e1 in KDirWatchPrivate::Entry::propagate_dirty() () from /usr/lib/libkio.so.5
#8  0xb61b7e31 in KDirWatchPrivate::slotRescan() () from /usr/lib/libkio.so.5
#9  0xb61b8a43 in KDirWatchPrivate::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#10 0xb4d9beba in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#11 0xb4daa47f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#12 0xb4dfbb67 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#13 0xb4db259e in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#14 0xb4da7334 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#15 0xb53805dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb53871ee in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0xb5ed9e1a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0xb4d96cbb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb4dc5c06 in ?? () from /usr/lib/libQtCore.so.4
#20 0xb4dc28e4 in ?? () from /usr/lib/libQtCore.so.4
#21 0xb326d378 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0xb3270bf0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#23 0xb3270d23 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#24 0xb4dc25d5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0xb543cae5 in ?? () from /usr/lib/libQtGui.so.4
#26 0xb4d952f9 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0xb4d9574a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0xb4d998bf in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0xb5380677 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#30 0x0836c3aa in main (argc=5, argv=0xbfd9b044) at /home/andi/Programmieren/KDE/digikam/digikam/main.cpp:195

Possible duplicates by query: bug 227902, bug 227253, bug 227220, bug 226418, bug 225849.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-02-21 10:50:20 UTC
Andy,

This is KDElibs relevant. A lots of report have be seen about KDirWatch

Gilles
Comment 2 caulier.gilles 2010-02-21 10:53:01 UTC

*** This bug has been marked as a duplicate of bug 222974 ***
Comment 3 caulier.gilles 2017-08-08 11:02:41 UTC
Since digiKam 5.0.0, KDirWatch was been replaced by QFileSytemWatcher. It will not reproducible.

Gilles Caulier