Bug 227860 - Crash on ejecting SD card
Summary: Crash on ejecting SD card
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-20 22:30 UTC by Sylvain Garsault
Modified: 2010-02-20 22:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvain Garsault 2010-02-20 22:30:04 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Upon ejecting an SD card (transfer had finished a while ago), Dolphin crashed.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8bbd7d4750 (LWP 21704))]

Thread 2 (Thread 0x7f8b9e456910 (LWP 30322)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f8ba36b7c91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f8bb5a88a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f8bb9ad780d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8bbd7d4750 (LWP 21704)):
[KCrash Handler]
#5  QUrl (this=0x7fffb2aa5710, other=...) at io/qurl.cpp:3936
#6  0x00007f8bbb3c0fc9 in KUrl (this=0x7fffb2aa5710, _u=...) at ../../kdecore/io/kurl.cpp:468
#7  0x00007f8bbd269ec0 in KFileItem::url (this=<value optimized out>) at ../../kio/kio/kfileitem.cpp:1271
#8  0x00007f8bbd25a6e4 in KDirModel::indexForItem (this=0x3351ec0, item=...) at ../../kio/kio/kdirmodel.cpp:919
#9  0x00007f8bbcefe920 in KFilePreviewGenerator::Private::orderItems (this=0x336e850, items=...) at ../../kfile/kfilepreviewgenerator.cpp:1023
#10 0x00007f8bbcf02622 in KFilePreviewGenerator::Private::updateIcons (this=0x336e850, items=...) at ../../kfile/kfilepreviewgenerator.cpp:508
#11 0x00007f8bbcf0287f in KFilePreviewGenerator::Private::delayedIconUpdate (this=0x336e850) at ../../kfile/kfilepreviewgenerator.cpp:1088
#12 0x00007f8bbcf038f5 in KFilePreviewGenerator::qt_metacall (this=0x336e650, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb2aa59f0) at ./kfilepreviewgenerator.moc:95
#13 0x00007f8bba1d0ddc in QMetaObject::activate (sender=0x336e820, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x37d) at kernel/qobject.cpp:3113
#14 0x00007f8bba1cad83 in QObject::event (this=0x336e820, e=0x10) at kernel/qobject.cpp:1075
#15 0x00007f8bba64eefc in QApplicationPrivate::notify_helper (this=0x2088360, receiver=0x336e820, e=0x7fffb2aa5ff0) at kernel/qapplication.cpp:4056
#16 0x00007f8bba6561ce in QApplication::notify (this=0x7fffb2aa6340, receiver=0x336e820, e=0x7fffb2aa5ff0) at kernel/qapplication.cpp:4021
#17 0x00007f8bbb983ab6 in KApplication::notify (this=0x7fffb2aa6340, receiver=0x336e820, event=0x7fffb2aa5ff0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f8bba1bbc2c in QCoreApplication::notifyInternal (this=0x7fffb2aa6340, receiver=0x336e820, event=0x7fffb2aa5ff0) at kernel/qcoreapplication.cpp:610
#19 0x00007f8bba1e6862 in QCoreApplication::sendEvent (this=0x2093180) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QTimerInfoList::activateTimers (this=0x2093180) at kernel/qeventdispatcher_unix.cpp:572
#21 0x00007f8bba1e425d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#22 0x00007f8bb5cd9bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f8bb5cdd598 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f8bb5cdd6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f8bba1e41a6 in QEventDispatcherGlib::processEvents (this=0x2061d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007f8bba6e34be in QGuiEventDispatcherGlib::processEvents (this=0x7fffb2aa5710, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007f8bba1ba532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f8bba1ba904 in QEventLoop::exec (this=0x7fffb2aa6290, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f8bba1bcab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x0000000000439555 in _start ()
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-20 22:36:11 UTC
This is fixed in KDE SC 4.3.5 and 4.4.0+ 
Regards

*** This bug has been marked as a duplicate of bug 211525 ***