Bug 227432 - dolphin crash after quick click on JPG
Summary: dolphin crash after quick click on JPG
Status: RESOLVED DUPLICATE of bug 222324
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-17 22:15 UTC by Johannes Schwall
Modified: 2010-02-21 23:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Schwall 2010-02-17 22:15:50 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.00 (KDE 4.4.0)
Qt Version: 4.6.1
Operating System: Linux 2.6.31-19-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
I opened dolphin to display the contents of a folder containing JPGs just downloaded from my camera and immediately clicked on the first JPG file to have it opened in gwenview. The action was successful (gwenview started and displayed the image) but dolphin crashed.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f952d17e7f0 (LWP 7096))]

Thread 2 (Thread 0x7f951bbf7910 (LWP 7109)):
[KCrash Handler]
#5  QThreadData::get2 (arg=0x1631100) at thread/qthread_p.h:192
#6  QThreadPrivate::start (arg=0x1631100) at thread/qthread_unix.cpp:222
#7  0x00007f952636fa04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007f9528e0a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f952d17e7f0 (LWP 7096)):
#0  0x00007f9528dfe3db in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=0) at ../sysdeps/unix/sysv/linux/poll.c:89
#1  0x00007f9523aab29a in ?? () from /usr/lib/libxcb.so.1
#2  0x00007f9523aab7d7 in ?? () from /usr/lib/libxcb.so.1
#3  0x00007f9523aaba85 in xcb_writev () from /usr/lib/libxcb.so.1
#4  0x00007f9527d39d4a in _XSend () from /usr/lib/libX11.so.6
#5  0x00007f9527d39e89 in _XReply () from /usr/lib/libX11.so.6
#6  0x00007f9527d167f5 in XGetImage () from /usr/lib/libX11.so.6
#7  0x00007f952a206f53 in QX11PixmapData::toImage (this=0x19009d0) at image/qpixmap_x11.cpp:1480
#8  0x00007f952a1eeee0 in QPixmap::toImage (this=0x7fffef876b20) at image/qpixmap.cpp:488
#9  0x00007f952add5efd in KIconEffect::apply (this=0x144dc08, pixmap=<value optimized out>, effect=1, value=<value optimized out>, col=..., col2=<value optimized out>, trans=false)
    at ../../kdeui/icons/kiconeffect.cpp:287
#10 0x00007f952add61ff in KIconEffect::apply (this=0x1, pixmap=..., group=0, state=<value optimized out>) at ../../kdeui/icons/kiconeffect.cpp:259
#11 0x00007f952b37fe26 in KFileItemDelegate::Private::applyHoverEffect (this=<value optimized out>, icon=...) at ../../kio/kio/kfileitemdelegate.cpp:540
#12 0x00007f952b38542e in KFileItemDelegate::paint (this=0x17b03f0, painter=<value optimized out>, option=..., index=<value optimized out>) at ../../kio/kio/kfileitemdelegate.cpp:1315
#13 0x00007f952c616028 in DolphinFileItemDelegate::paint (this=0x17b03f0, painter=0x7fffef8775a0, option=<value optimized out>, index=...)
    at ../../../../apps/dolphin/src/dolphinfileitemdelegate.cpp:77
#14 0x00007f952a67a579 in QTreeView::drawRow (this=<value optimized out>, painter=<value optimized out>, option=<value optimized out>, index=<value optimized out>) at itemviews/qtreeview.cpp:1679
#15 0x00007f952a673fe6 in QTreeView::drawTree (this=0x178b2f0, painter=<value optimized out>, region=<value optimized out>) at itemviews/qtreeview.cpp:1442
#16 0x00007f952a674a83 in QTreeView::paintEvent (this=0x178b2f0, event=0x7fffef8782e0) at itemviews/qtreeview.cpp:1275
#17 0x00007f952c60ca9b in DolphinDetailsView::paintEvent (this=0x7f952d17e7f0, event=0x1) at ../../../../apps/dolphin/src/dolphindetailsview.cpp:396
#18 0x00007f952a162f32 in QWidget::event (this=0x178b2f0, event=0x7fffef8782e0) at kernel/qwidget.cpp:8124
#19 0x00007f952a5090d6 in QFrame::event (this=0x178b2f0, e=0x7fffef8782e0) at widgets/qframe.cpp:557
#20 0x00007f952a63843b in QAbstractItemView::viewportEvent (this=0x178b2f0, event=0x7fffef8782e0) at itemviews/qabstractitemview.cpp:1603
#21 0x00007f952a6731f3 in QTreeView::viewportEvent (this=0x178b2f0, event=0x7fffef8782e0) at itemviews/qtreeview.cpp:1257
#22 0x00007f9529517357 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x178a730, event=0x7fffef8782e0) at kernel/qcoreapplication.cpp:819
#23 0x00007f952a10cf7c in QApplicationPrivate::notify_helper (this=0x1363fc0, receiver=0x178a730, e=0x7fffef8782e0) at kernel/qapplication.cpp:4294
#24 0x00007f952a11359b in QApplication::notify (this=0x7fffef87afd0, receiver=0x178a730, e=0x7fffef8782e0) at kernel/qapplication.cpp:4181
#25 0x00007f952ae16d16 in KApplication::notify (this=0x7fffef87afd0, receiver=0x178a730, event=0x7fffef8782e0) at ../../kdeui/kernel/kapplication.cpp:302
#26 0x00007f9529517f3c in QCoreApplication::notifyInternal (this=0x7fffef87afd0, receiver=0x178a730, event=0x7fffef8782e0) at kernel/qcoreapplication.cpp:704
#27 0x00007f952a16b48d in QCoreApplication::sendSpontaneousEvent (this=0x17a1670, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x164bc60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#28 QWidgetPrivate::drawWidget (this=0x17a1670, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x164bc60)
    at kernel/qwidget.cpp:5321
#29 0x00007f952a16c128 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=0, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x164bc60) at kernel/qwidget.cpp:5434
#30 0x00007f952a16b1ea in QWidgetPrivate::drawWidget (this=0x17a11f0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x164bc60) at kernel/qwidget.cpp:5370
#31 0x00007f952a16c128 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=3, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x164bc60) at kernel/qwidget.cpp:5434
#32 0x00007f952a16b1ea in QWidgetPrivate::drawWidget (this=0x1786910, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x164bc60) at kernel/qwidget.cpp:5370
#33 0x00007f952a16c128 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=4, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x164bc60) at kernel/qwidget.cpp:5434
#34 0x00007f952a16b1ea in QWidgetPrivate::drawWidget (this=0x15d0b60, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x164bc60) at kernel/qwidget.cpp:5370
#35 0x00007f952a16c128 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=0, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x164bc60) at kernel/qwidget.cpp:5434
#36 0x00007f952a16b1ea in QWidgetPrivate::drawWidget (this=0x15d0890, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x164bc60) at kernel/qwidget.cpp:5370
#37 0x00007f952a16c128 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=3, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x164bc60) at kernel/qwidget.cpp:5434
#38 0x00007f952a16b1ea in QWidgetPrivate::drawWidget (this=0x1674c80, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x164bc60) at kernel/qwidget.cpp:5370
#39 0x00007f952a16c128 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=11, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x164bc60) at kernel/qwidget.cpp:5434
#40 0x00007f952a16bf59 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=13, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x164bc60) at kernel/qwidget.cpp:5421
#41 0x00007f952a16b1ea in QWidgetPrivate::drawWidget (this=0x147f3e0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x164bc60) at kernel/qwidget.cpp:5370
#42 0x00007f952a324545 in QWidgetBackingStore::sync (this=0x164bc60) at painting/qbackingstore.cpp:1291
#43 0x00007f952a15cee0 in QWidgetPrivate::syncBackingStore (this=0x147f3e0) at kernel/qwidget.cpp:1663
#44 0x00007f952a163635 in QWidget::event (this=0x136dbc0, event=0x16668f0) at kernel/qwidget.cpp:8271
#45 0x00007f952a52485b in QMainWindow::event (this=0x136dbc0, event=0x16668f0) at widgets/qmainwindow.cpp:1435
#46 0x00007f952af2e373 in KXmlGuiWindow::event (this=0x7f952d17e7f0, ev=0x1) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:131
#47 0x00007f952a10cfac in QApplicationPrivate::notify_helper (this=0x1363fc0, receiver=0x136dbc0, e=0x16668f0) at kernel/qapplication.cpp:4298
#48 0x00007f952a11359b in QApplication::notify (this=0x7fffef87afd0, receiver=0x136dbc0, e=0x16668f0) at kernel/qapplication.cpp:4181
#49 0x00007f952ae16d16 in KApplication::notify (this=0x7fffef87afd0, receiver=0x136dbc0, event=0x16668f0) at ../../kdeui/kernel/kapplication.cpp:302
#50 0x00007f9529517f3c in QCoreApplication::notifyInternal (this=0x7fffef87afd0, receiver=0x136dbc0, event=0x16668f0) at kernel/qcoreapplication.cpp:704
#51 0x00007f952951a6b7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x133c6d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x133c6d0) at kernel/qcoreapplication.cpp:1345
#53 0x00007f9529541923 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#54 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#55 0x00007f9525241bce in g_main_dispatch (context=0x1367120) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#56 IA__g_main_context_dispatch (context=0x1367120) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#57 0x00007f9525245598 in g_main_context_iterate (context=0x1367120, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#58 0x00007f95252456c0 in IA__g_main_context_iteration (context=0x1367120, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#59 0x00007f9529541463 in QEventDispatcherGlib::processEvents (this=0x133be20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#60 0x00007f952a1bc7ee in QGuiEventDispatcherGlib::processEvents (this=0x7f952d17e7f0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x00007f9529516862 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#62 0x00007f9529516c3c in QEventLoop::exec (this=0x7fffef87af20, flags=) at kernel/qeventloop.cpp:201
#63 0x00007f952951a97b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#64 0x000000000043ac95 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../../apps/dolphin/src/main.cpp:101

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-18 18:53:41 UTC
This could be related to bug 224848 / bug 220814...
Regards
Comment 2 Dario Andres 2010-02-21 23:56:46 UTC
Merging with bug 222324. Thanks

*** This bug has been marked as a duplicate of bug 222324 ***