Bug 227405 - Kopete crashes when I drag a contact from the contact list and drop it into the tabbar in the chat window [KTabBar::selectTab, KopeteChatWindow::testCanDecode]
Summary: Kopete crashes when I drag a contact from the contact list and drop it into t...
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 233630 240523 249222 255783 256163 265306 268489 268617 272548 275218 280438 281177 283944 284873 305563 316578 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-17 17:51 UTC by Alexander
Modified: 2013-03-12 10:37 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.2


Attachments
New crash information added by DrKonqi (13.30 KB, text/plain)
2011-06-06 22:08 UTC, Artem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2010-02-17 17:51:18 UTC
Application: kopete (1.0.0)
KDE Platform Version: 4.4.00 (KDE 4.4.0)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
1. Open chat, conference etc.
2. Drag any contact from the contact-list and drop it near an existing tab in the chat window.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kopete (kopete), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5b317e0760 (LWP 2584))]

Thread 4 (Thread 0x7f5b1ac3a710 (LWP 2587)):
#0  0x00007f5b2d7c23e9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f5b2f1f5082 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f5b2f1ea559 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f5b2f1f4155 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f5b2d7bd81a in start_thread () from /lib/libpthread.so.0
#5  0x00007f5b2dcf2c7d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5b19fe4710 (LWP 2588)):
#0  0x00007fffaec938f4 in clock_gettime ()
#1  0x00007f5b295cee5f in clock_gettime () from /lib/librt.so.1
#2  0x00007f5b2f30f09f in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f5b2f313edd in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f5b2f313f05 in ?? () from /usr/lib/libQtCore.so.4
#5  0x00007f5b2f311e5d in ?? () from /usr/lib/libQtCore.so.4
#6  0x00007f5b2f311f05 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f5b2934444a in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0x00007f5b29344821 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#9  0x00007f5b29344d50 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0x00007f5b2f311c66 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0x00007f5b2f2e70c2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#12 0x00007f5b2f2e749c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#13 0x00007f5b1b0e2de3 in QCA::SyncThread::run() () from /usr/lib/libqca.so.2
#14 0x00007f5b2f1f4155 in ?? () from /usr/lib/libQtCore.so.4
#15 0x00007f5b2d7bd81a in start_thread () from /lib/libpthread.so.0
#16 0x00007f5b2dcf2c7d in clone () from /lib/libc.so.6
#17 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5b197e3710 (LWP 2589)):
#0  0x00007fffaec938f4 in clock_gettime ()
#1  0x00007f5b295cee5f in clock_gettime () from /lib/librt.so.1
#2  0x00007f5b2f30f09f in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f5b2f313edd in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f5b2f311d83 in ?? () from /usr/lib/libQtCore.so.4
#5  0x00007f5b2934413a in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#6  0x00007f5b29344920 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#7  0x00007f5b29344d50 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#8  0x00007f5b2f311c66 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0x00007f5b2f2e70c2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0x00007f5b2f2e749c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0x00007f5b1b529712 in XMPP::SyncThread::run() () from /usr/lib/kde4/kopete_jabber.so
#12 0x00007f5b2f1f4155 in ?? () from /usr/lib/libQtCore.so.4
#13 0x00007f5b2d7bd81a in start_thread () from /lib/libpthread.so.0
#14 0x00007f5b2dcf2c7d in clone () from /lib/libc.so.6
#15 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5b317e0760 (LWP 2584)):
[KCrash Handler]
#5  0x00007f5b2e894510 in QTabBar::count() const () from /usr/lib/libQtGui.so.4
#6  0x00007f5b2fdae8e7 in KTabBar::selectTab(QPoint const&) const () from /usr/lib/libkdeui.so.5
#7  0x00007f5b1fb0123c in KopeteChatWindow::testCanDecode(QDragMoveEvent const*, bool&) () from /usr/lib/kde4/kopete_chatwindow.so
#8  0x00007f5b1fb06cd8 in KopeteChatWindow::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/kopete_chatwindow.so
#9  0x00007f5b2f2fb4df in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#10 0x00007f5b2fdaf8c4 in KTabWidget::testCanDecode(QDragMoveEvent const*, bool&) () from /usr/lib/libkdeui.so.5
#11 0x00007f5b2fdb0215 in KTabWidget::dragEnterEvent(QDragEnterEvent*) () from /usr/lib/libkdeui.so.5
#12 0x00007f5b2e48b935 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#13 0x00007f5b2e4355ec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#14 0x00007f5b2e43bf14 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0x00007f5b2fcb5cd6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#16 0x00007f5b2f2e879c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#17 0x00007f5b2e4c8e20 in ?? () from /usr/lib/libQtGui.so.4
#18 0x00007f5b2e4ca457 in ?? () from /usr/lib/libQtGui.so.4
#19 0x00007f5b2e4ca839 in ?? () from /usr/lib/libQtGui.so.4
#20 0x00007f5b2f2e7c7b in QCoreApplicationPrivate::sendThroughApplicationEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#21 0x00007f5b2e435566 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#22 0x00007f5b2e43c3bb in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#23 0x00007f5b2fcb5cd6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#24 0x00007f5b2f2e879c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#25 0x00007f5b2e43b58e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#26 0x00007f5b2e4bafab in ?? () from /usr/lib/libQtGui.so.4
#27 0x00007f5b2e4b9cba in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#28 0x00007f5b2e4e4172 in ?? () from /usr/lib/libQtGui.so.4
#29 0x00007f5b2934126e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0x00007f5b29344c28 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#31 0x00007f5b29344d50 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0x00007f5b2f311c13 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0x00007f5b2e4e3d6e in ?? () from /usr/lib/libQtGui.so.4
#34 0x00007f5b2f2e70c2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#35 0x00007f5b2f2e749c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0x00007f5b2e4cd399 in ?? () from /usr/lib/libQtGui.so.4
#37 0x00007f5b2e44bdc8 in QDrag::exec(QFlags<Qt::DropAction>, Qt::DropAction) () from /usr/lib/libQtGui.so.4
#38 0x00007f5b307c11ff in KopeteContactListView::startDrag(QFlags<Qt::DropAction>) () from /usr/lib/libkopetecontactlist.so.1
#39 0x00007f5b2e95b0ae in QAbstractItemView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#40 0x00007f5b2e48b60f in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#41 0x00007f5b2e82ff86 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#42 0x00007f5b2e95f8ab in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#43 0x00007f5b2e99a8e2 in QTreeView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#44 0x00007f5b2f2e7bb7 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#45 0x00007f5b2e4355bc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#46 0x00007f5b2e43c3bb in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#47 0x00007f5b2fcb5cd6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#48 0x00007f5b2f2e879c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#49 0x00007f5b2e43b58e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#50 0x00007f5b2e4bafab in ?? () from /usr/lib/libQtGui.so.4
#51 0x00007f5b2e4b9cba in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#52 0x00007f5b2e4e4172 in ?? () from /usr/lib/libQtGui.so.4
#53 0x00007f5b2934126e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#54 0x00007f5b29344c28 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#55 0x00007f5b29344d50 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#56 0x00007f5b2f311c13 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#57 0x00007f5b2e4e3d6e in ?? () from /usr/lib/libQtGui.so.4
#58 0x00007f5b2f2e70c2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#59 0x00007f5b2f2e749c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#60 0x00007f5b2f2eb1db in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#61 0x0000000000414142 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-04-11 01:24:00 UTC
From bug 233630 (KDE SC 4.4.2):
-- Information about the crash:
I was trying to send an image to a contact, and when I was about to drop the
image into the chat window, kopete crashed. I'm not sure, but I think I was
using a google talk contact.

-- Complete bactrace:
#6  0x020474c9 in QList<QTabBarPrivate::Tab>::Node::t (this=0x9073438, index=0)
at ../../include/QtCore/../../src/corelib/tools/qlist.h:106
#7  QList<QTabBarPrivate::Tab>::operator[] (this=0x9073438, index=0) at
../../include/QtCore/../../src/corelib/tools/qlist.h:444
#8  QTabBarPrivate::at (this=0x9073438, index=0) at widgets/qtabbar.cpp:363
#9  QTabBar::tabRect (this=0x9073438, index=0) at widgets/qtabbar.cpp:1109
#10 0x00ac81fb in KTabBar::selectTab (this=0x9073438, pos=...) at
../../kdeui/widgets/ktabbar.cpp:390
#11 0x07b1e8d4 in KopeteChatWindow::testCanDecode (this=0xa05db88,
event=0xbffd140c, accept=@0xbffd0dff) at
../../../../kopete/kopete/chatwindow/kopetechatwindow.cpp:635
#12 0x07b252f2 in KopeteChatWindow::qt_metacall (this=0xa05db88,
_c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbffd0c94) at
./kopetechatwindow.moc:157
#13 0x01933e5a in QMetaObject::metacall (object=0xa05db88, cl=165832698,
idx=51, argv=0xbffd0c94) at kernel/qmetaobject.cpp:237
#14 0x019425f5 in QMetaObject::activate (sender=0xa0a3518, m=0xb7de7c,
local_signal_index=0, argv=0xbffd0c94) at kernel/qobject.cpp:3293
#15 0x00ac9559 in KTabWidget::testCanDecode (this=0xa0a3518, _t1=0xbffd140c,
_t2=@0xbffd0dff) at ./ktabwidget.moc:209
#16 0x00acb1ec in KTabWidget::qt_metacall (this=0xa0a3518,
_c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbffd0db4) at ./ktabwidget.moc:133
Comment 2 Dario Andres 2010-04-11 01:38:50 UTC
*** Bug 233630 has been marked as a duplicate of this bug. ***
Comment 3 Nicolas L. 2010-06-17 11:09:07 UTC
*** Bug 240523 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2010-09-28 23:36:27 UTC
*** Bug 249222 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2010-11-16 00:28:56 UTC
[Comment from a bug triager]
From bug 256163 (KDE SC 4.5.3):
-- Information about the crash:
I had a cat window with multiple tabs and contacts open. Now I want to chat
with a other contact and open kopete main window. then I dragged the contact to
the chat window (i hope that kopete will open a new tab in the existing chat
window) and copete crashed.

[KCrash Handler]
#7  size (this=0x0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:94
#8  count (this=0x0) at
../../include/QtCore/../../src/corelib/tools/qlist.h:267
#9  QTabBar::count (this=0x0) at widgets/qtabbar.cpp:1266
#10 0x01acef18 in KopeteChatWindow::testCanDecode (this=0x9295a68,
event=0xbf82c67c, accept=@0xbf82c09f) at
../../../../kopete/kopete/chatwindow/kopetechatwindow.cpp:635
#11 0x01ad5242 in KopeteChatWindow::qt_metacall (this=0x9295a68,
_c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbf82c064) at
./kopetechatwindow.moc:157
Comment 6 Dario Andres 2010-11-16 00:29:14 UTC
*** Bug 256163 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2010-11-16 00:31:58 UTC
*** Bug 255783 has been marked as a duplicate of this bug. ***
Comment 8 Vincent de Phily 2011-01-25 16:20:12 UTC
Still happens with KDE SC4.5.5, 64bits, Gentoo ebuild



Application: Kopete (kopete), signal: Segmentation fault
[Current thread is 1 (Thread 0x29470377760 (LWP 27545))]

Thread 4 (Thread 0x29452f8c710 (LWP 27688)):
#0  0x000002946c52ef03 in poll () from /lib/libc.so.6
#1  0x0000029467d88ba9 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#2  0x0000029467d89010 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x000002946dcdcb5e in QEventDispatcherGlib::processEvents (this=0x54728d1340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x000002946dca7e22 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x000002946dca8304 in QEventLoop::exec (this=0x54728d28b0, flags=) at kernel/qeventloop.cpp:201
#6  0x000002945b4d89f6 in QCA::SyncThread::run() () from /usr/lib64/qca2/libqca.so.2
#7  0x000002946db97b6e in QThreadPrivate::start (arg=0x54728d0b20) at thread/qthread_unix.cpp:285
#8  0x000002946bfd69ca in start_thread () from /lib/libpthread.so.0
#9  0x000002946c538aed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x2945278b710 (LWP 27689)):
#0  0x000002946bfdaa5d in pthread_mutex_unlock () from /lib/libpthread.so.0
#1  0x0000029467d88574 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#2  0x0000029467d88a20 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#3  0x0000029467d89010 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0x000002946dcdcb5e in QEventDispatcherGlib::processEvents (this=0x5472ab6210, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x000002946dca7e22 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x000002946dca8304 in QEventLoop::exec (this=0x5472ab6be0, flags=) at kernel/qeventloop.cpp:201
#7  0x000002945b9a2785 in XMPP::SyncThread::run() () from /usr/lib64/kde4/kopete_jabber.so
#8  0x000002946db97b6e in QThreadPrivate::start (arg=0x5472ab5c70) at thread/qthread_unix.cpp:285
#9  0x000002946bfd69ca in start_thread () from /lib/libpthread.so.0
#10 0x000002946c538aed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x29450f88710 (LWP 27750)):
#0  0x000002946c5313f3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x000002945b2546b3 in posix_timer_do () from /usr/lib/libortp.so.8
#2  0x000002945b25589e in rtp_scheduler_schedule () from /usr/lib/libortp.so.8
#3  0x000002946bfd69ca in start_thread () from /lib/libpthread.so.0
#4  0x000002946c538aed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x29470377760 (LWP 27545)):
[KCrash Handler]
#6  0x000002946d1a8964 in QTabBar::count() const () from /usr/lib64/qt4/libQtGui.so.4
#7  0x000002946e8aab97 in KTabBar::selectTab (this=0x0, pos=...) at /home/portagetmp/portage/kde-base/kdelibs-4.5.5/work/kdelibs-4.5.5/kdeui/widgets/ktabbar.cpp:388
#8  0x000002945bc89fd1 in KopeteChatWindow::testCanDecode(QDragMoveEvent const*, bool&) () from /usr/lib64/kde4/kopete_chatwindow.so
#9  0x000002945bc8f9ef in KopeteChatWindow::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/kde4/kopete_chatwindow.so
#10 0x000002946dcc4e3f in QMetaObject::activate (sender=0x54730ce180, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x54730cc760) at kernel/qobject.cpp:3272
#11 0x000002946e8ac234 in KTabWidget::testCanDecode (this=0x0, _t1=0x3a8f547acc0, _t2=<value optimized out>) at /home/portagetmp/portage/kde-base/kdelibs-4.5.5/work/kdelibs-4.5.5_build/kdeui/ktabwidget.moc:209
#12 0x000002946e8ad065 in KTabWidget::dragEnterEvent (this=0x54730ce180, event=0x3a8f547acc0) at /home/portagetmp/portage/kde-base/kdelibs-4.5.5/work/kdelibs-4.5.5/kdeui/widgets/ktabwidget.cpp:414
#13 0x000002946cd2dc6b in QWidget::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#14 0x000002946ccc74ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#15 0x000002946cccd645 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#16 0x000002946e77f0a6 in KApplication::notify (this=0x3a8f547e2f0, receiver=0x54730ce180, event=0x3a8f547acc0) at /home/portagetmp/portage/kde-base/kdelibs-4.5.5/work/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#17 0x000002946dca97eb in QCoreApplication::notifyInternal (this=0x3a8f547e2f0, receiver=0x54730ce180, event=0x3a8f547acc0) at kernel/qcoreapplication.cpp:732
#18 0x000002946cd74edd in handle_xdnd_position(QWidget*, _XEvent const*, bool) () from /usr/lib64/qt4/libQtGui.so.4
#19 0x000002946cd7662b in QDragManager::move(QPoint const&) () from /usr/lib64/qt4/libQtGui.so.4
#20 0x000002946cd79419 in QDragManager::eventFilter(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#21 0x000002946dca8e42 in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x547230e4c0, receiver=0x5473422270, event=0x3a8f547b840) at kernel/qcoreapplication.cpp:828
#22 0x000002946ccc7406 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#23 0x000002946cccd9c8 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#24 0x000002946e77f0a6 in KApplication::notify (this=0x3a8f547e2f0, receiver=0x5473422270, event=0x3a8f547b840) at /home/portagetmp/portage/kde-base/kdelibs-4.5.5/work/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#25 0x000002946dca97eb in QCoreApplication::notifyInternal (this=0x3a8f547e2f0, receiver=0x5473422270, event=0x3a8f547b840) at kernel/qcoreapplication.cpp:732
#26 0x000002946cccbea2 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/qt4/libQtGui.so.4
#27 0x000002946cd66ad4 in QETWidget::translateMouseEvent(_XEvent const*) () from /usr/lib64/qt4/libQtGui.so.4
#28 0x000002946cd656ca in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#29 0x000002946cd93f52 in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtGui.so.4
#30 0x0000029467d84509 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0x0000029467d88e48 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#32 0x0000029467d89010 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0x000002946dcdcaf3 in QEventDispatcherGlib::processEvents (this=0x5472302220, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#34 0x000002946cd93756 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#35 0x000002946dca7e22 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x000002946dca8304 in QEventLoop::exec (this=0x5472fddd60, flags=) at kernel/qeventloop.cpp:201
#37 0x000002946cd79b4b in QDragManager::drag(QDrag*) () from /usr/lib64/qt4/libQtGui.so.4
#38 0x000002946cce02a8 in QDrag::exec(QFlags<Qt::DropAction>, Qt::DropAction) () from /usr/lib64/qt4/libQtGui.so.4
#39 0x000002946f313d7d in KopeteContactListView::startDrag(QFlags<Qt::DropAction>) () from /usr/lib/libkopetecontactlist.so.1
#40 0x000002946d29345e in QAbstractItemView::mouseMoveEvent(QMouseEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#41 0x000002946cd2d98a in QWidget::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#42 0x000002946d133546 in QFrame::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#43 0x000002946d2985eb in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#44 0x000002946d2dbd35 in QTreeView::viewportEvent(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#45 0x000002946dca8d46 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x54724fd540, event=0x3a8f547d5c0) at kernel/qcoreapplication.cpp:847
#46 0x000002946ccc7465 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#47 0x000002946cccd9c8 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#48 0x000002946e77f0a6 in KApplication::notify (this=0x3a8f547e2f0, receiver=0x54724fd540, event=0x3a8f547d5c0) at /home/portagetmp/portage/kde-base/kdelibs-4.5.5/work/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#49 0x000002946dca97eb in QCoreApplication::notifyInternal (this=0x3a8f547e2f0, receiver=0x54724fd540, event=0x3a8f547d5c0) at kernel/qcoreapplication.cpp:732
#50 0x000002946cccbea2 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/qt4/libQtGui.so.4
#51 0x000002946cd66ad4 in QETWidget::translateMouseEvent(_XEvent const*) () from /usr/lib64/qt4/libQtGui.so.4
#52 0x000002946cd656ca in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#53 0x000002946cd93f52 in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtGui.so.4
#54 0x0000029467d84509 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#55 0x0000029467d88e48 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#56 0x0000029467d89010 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#57 0x000002946dcdcaf3 in QEventDispatcherGlib::processEvents (this=0x5472302220, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#58 0x000002946cd93756 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#59 0x000002946dca7e22 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#60 0x000002946dca8304 in QEventLoop::exec (this=0x3a8f547e240, flags=) at kernel/qeventloop.cpp:201
#61 0x000002946dcacfeb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#62 0x000000547208f875 in main ()
Comment 9 Christoph Feck 2011-05-15 12:33:27 UTC
*** Bug 265306 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2011-05-15 12:33:55 UTC
*** Bug 268489 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2011-05-15 12:34:15 UTC
*** Bug 268617 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2011-05-15 12:34:35 UTC
*** Bug 272548 has been marked as a duplicate of this bug. ***
Comment 13 Artem 2011-06-06 22:08:52 UTC
Created attachment 60712 [details]
New crash information added by DrKonqi

kopete (1.0.80) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

using integration of skype to kopete i tried to dtag a contact to the chat window hoping to have a multiuser conversation. After reaching the tab panel I've got this crash report

-- Backtrace (Reduced):
#6  size (this=0x0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:94
#7  count (this=0x0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:267
#8  QTabBar::count (this=0x0) at widgets/qtabbar.cpp:1272
#9  0x00007ff50805c90a in KTabBar::selectTab (this=0x0, pos=...) at ../../kdeui/widgets/ktabbar.cpp:435
#10 0x00007ff4e9889491 in KopeteChatWindow::testCanDecode (this=0x22ca860, event=0x7fff42e5bef0, accept=@0x7fff42e5b72f) at ../../../../kopete/kopete/chatwindow/kopetechatwindow.cpp:635
Comment 14 Jekyll Wu 2012-10-04 21:53:18 UTC
*** Bug 275218 has been marked as a duplicate of this bug. ***
Comment 15 Jekyll Wu 2012-10-04 21:53:47 UTC
*** Bug 305563 has been marked as a duplicate of this bug. ***
Comment 16 Jekyll Wu 2012-10-04 21:53:50 UTC
*** Bug 281177 has been marked as a duplicate of this bug. ***
Comment 17 Jekyll Wu 2012-10-05 13:17:33 UTC
*** Bug 284873 has been marked as a duplicate of this bug. ***
Comment 18 Jekyll Wu 2012-10-05 13:17:37 UTC
*** Bug 283944 has been marked as a duplicate of this bug. ***
Comment 19 Christoph Feck 2013-03-12 09:56:33 UTC
*** Bug 280438 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Feck 2013-03-12 09:56:53 UTC
*** Bug 316578 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2013-03-12 10:35:34 UTC
SVN commit 1343844 by cfeck:

Fix crash when dragging outside of tabbar

FIXED-IN: 4.10.2


 M  +1 -1      kopetechatwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1343844
Comment 22 Christoph Feck 2013-03-12 10:37:48 UTC
SVN commit 1343845 by cfeck:

Fix crash when dragging outside of tabbar (backport r1343844)



 M  +1 -1      kopetechatwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1343845