Bug 227344 - Switch windows directly when using alt+tab without list shown
Summary: Switch windows directly when using alt+tab without list shown
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: LO wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-17 12:11 UTC by Ivan Andrianov
Modified: 2010-10-17 21:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Andrianov 2010-02-17 12:11:41 UTC
Version:            (using KDE 4.4.0)
OS:                Linux
Installed from:    openSUSE RPMs

Kwin waits Alt key release and switch windows after this. This is normal behaviour with enabled window list but absolutely bad with disabled. In 4.3 series Kwin switched windows immediately after Tab key release not Alt key.
Comment 1 Martin Flöser 2010-02-17 13:24:12 UTC
The variant in 4.3 was a workaround for unreasonable focus policies. This implies that it was not possible to switch to all windows. There were windows which were unreachable. As well in 4.3 alt+tab did not enter the mode. So holding alt is useless. Each tab press event was like pressing once alt+tab.

I see that this is a regression for you, but I do not know if I can enable this "legacy" mode, although it is still available in case that an unreasonable focus policy is used. If at all, there will be a hidden option as we really received quite some bug reports about the broken state before.
Comment 2 Martin Flöser 2010-03-14 10:51:09 UTC
Changing to whishlist as it is a change to the now intended behaviour.
Comment 3 Thomas Lübking 2010-10-17 21:47:45 UTC
SVN commit 1186871 by luebking:

raise alt+tab selected window w/o compositing (requires highlight windows option to be checked)
unlink composited window highlighting from the tabbox
-> results in semi-legacy behaviour w/o activating the selected window

BUG: 227344


 M  +5 -2      effects/highlightwindow/highlightwindow.cpp  
 M  +82 -42    kcmkwin/kwintabbox/main.ui  
 M  +26 -21    layers.cpp  
 M  +3 -1      tabbox.h  
 M  +60 -14    tabbox/tabboxhandler.cpp  
 M  +13 -1     tabbox/tabboxhandler.h  
 M  +2 -1      workspace.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1186871