Bug 227150 - KNS3 download dialog strange behaviour (Get New Widgets)
Summary: KNS3 download dialog strange behaviour (Get New Widgets)
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: knewstuff (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 227358 227369 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-16 10:15 UTC by Szakál Dániel
Modified: 2010-02-18 13:46 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Adding the above as an attachment... (536.51 KB, image/png)
2010-02-16 13:22 UTC, Anne-Marie Mahfouf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Szakál Dániel 2010-02-16 10:15:23 UTC
Version:           unknown (using 4.4.00 (KDE 4.4.0), Arch Linux)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.32-ARCH

I have strigi/nepomuk disabled (I don't know if it effects the bug)
When I click the toolbox/add widgets button, then go to download new widgets, there are 2 strange issues:
1. I type something in the search box (for example facebook), but no filter works, only entries with the word facebook duplicates.
2. clicking enter closes even the add widgets window (I think it uses the close button, which even closes not only the search box, but even the add widgets window)
Comment 1 Anne-Marie Mahfouf 2010-02-16 12:11:21 UTC
You write:
"1. I type something in the search box (for example facebook), but no filter
works, only entries with the word facebook duplicates."

Is that in the "Get New Widgets" dialog search box or in plasma? 
Can you include a screenshot in order to see exactly what you mean here? I cannot reproduce.
(the screenshot should be added in the bug report, not linked to some web host)

Thanks in advance.
Comment 2 Szakál Dániel 2010-02-16 12:17:24 UTC
It's in the "get new widgets"/"download new plasma widgets" menu:
http://img10.imageshack.us/img10/1117/plasmabug.png
(Sorry I couldn't find how to edit the bug report, and add pic normally)
Comment 3 Anne-Marie Mahfouf 2010-02-16 13:22:14 UTC
Created attachment 40846 [details]
Adding the above as an attachment...
Comment 4 Anne-Marie Mahfouf 2010-02-16 13:27:51 UTC
Resized the pic which was too big.

Reassigning to KNS3 in kdelibs
Comment 5 Frederik Gladhorn 2010-02-16 14:13:07 UTC
SVN commit 1090976 by gladhorn:

Do not close the ghns dialog when pressing enter in the search label.
CCBUG: 227150


 M  +6 -2      downloaddialog.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1090976
Comment 6 Frederik Gladhorn 2010-02-16 14:13:58 UTC
SVN commit 1090977 by gladhorn:

backport r1090976 for kde 4.4.1

Do not close the ghns dialog when pressing enter in the search label.
CCBUG: 227150



 M  +6 -2      downloaddialog.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1090977
Comment 7 Frederik Gladhorn 2010-02-16 15:53:20 UTC
SVN commit 1091020 by gladhorn:

for static provider, only return entries that are included in the current search instead of everything twice
BUG: 227150



 M  +0 -1      staticxmlprovider.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1091020
Comment 8 Frederik Gladhorn 2010-02-16 15:54:07 UTC
SVN commit 1091021 by gladhorn:

backport r1091020 for KDE SC 4.4.1

for static provider, only return entries that are included in the current search instead of everything twice
CCBUG: 227150



 M  +0 -1      staticxmlprovider.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1091021
Comment 9 Anne-Marie Mahfouf 2010-02-16 16:43:22 UTC
Thanks Szakál Dániel for the report and prompt answers.

Thanks Frederik for the quick fixes, awesome!
Comment 10 Frederik Gladhorn 2010-02-17 19:12:44 UTC
*** Bug 227358 has been marked as a duplicate of this bug. ***
Comment 11 Frederik Gladhorn 2010-02-18 13:46:33 UTC
*** Bug 227369 has been marked as a duplicate of this bug. ***