Bug 227140 - 'Apply' button in some cases doesn't become active in wallpaper setup dialog
Summary: 'Apply' button in some cases doesn't become active in wallpaper setup dialog
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-16 08:42 UTC by Vovochka
Modified: 2010-02-16 11:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vovochka 2010-02-16 08:42:58 UTC
Version:            (using KDE 4.4.0)
Installed from:    openSUSE RPMs

When selecting a desktop wallpaper (type|engine) as virus, apply button doesn't become active if u select another background picture.

How to reproduce:

1) Open wallpaper setup dialog.
2) Select engine type: virus. Press apply.
3) Try to change background image, apply button won't become active.
Comment 1 Anne-Marie Mahfouf 2010-02-16 10:04:29 UTC
confirmed
Comment 2 Anne-Marie Mahfouf 2010-02-16 10:48:38 UTC
SVN commit 1090866 by annma:

Allow the Apply button to be enabled and highlight selected wallpaper correctly
BUG=227140


 M  +4 -1      backgrounddelegate.cpp  
 M  +1 -0      virus.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1090866
Comment 3 Anne-Marie Mahfouf 2010-02-16 10:58:32 UTC
SVN commit 1090868 by annma:

forward port
CCBUG=227140


 M  +2 -0      backgrounddelegate.cpp  
 M  +1 -0      virus.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1090868
Comment 4 Anne-Marie Mahfouf 2010-02-16 11:18:26 UTC
SVN commit 1090870 by annma:

this is more elegant. it did not work just because the slot was not declared as a slot! will forward port to trunk.
CCBUG=227140


 M  +0 -1      virus.cpp  
 M  +2 -2      virus.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1090870