Bug 227120 - After window minimization, new active window doesn't become active in taskbar
Summary: After window minimization, new active window doesn't become active in taskbar
Status: RESOLVED DUPLICATE of bug 189435
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: OpenSUSE Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-16 03:39 UTC by Vovochka
Modified: 2012-04-09 07:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vovochka 2010-02-16 03:39:08 UTC
Version:            (using KDE 4.4.0)
Installed from:    openSUSE RPMs

Steps to reproduce:
1) Minimize current active window.
2) Try to minimize new active window via clicking it in taskbar. After this click it will become active in taskbar and only on second click it will be minimized.
Comment 1 Aaron J. Seigo 2010-02-16 03:57:57 UTC
are you using focus-follows-mouse or some other similar focus policy?
Comment 2 Vovochka 2010-02-16 04:04:31 UTC
Default kde preference, nothing more.
I don't even see where such policy can be enabled.
Comment 3 Alexander 2010-05-08 21:52:18 UTC
(In reply to comment #2)
> Default kde preference, nothing more.
> I don't even see where such policy can be enabled.

Go to Desktop effects in systemsettings, on tab advanced and change the "keep window thumbnails" option to only for shown windows.

I think it's a kwin bug and there is already long time.
Comment 4 Aaron J. Seigo 2010-06-08 02:16:01 UTC
@Vovochka: can you try the suggestion in comment #3 and provide a follow up to this report? thanks.
Comment 5 Vovochka 2010-06-08 02:20:21 UTC
After follow that instructions everything works fine.
Comment 6 Alexander 2010-07-28 22:32:55 UTC
This bug is still present in KDE 4.4.95.
Comment 7 Martin Flöser 2012-04-09 07:19:14 UTC

*** This bug has been marked as a duplicate of bug 189435 ***