Bug 227090 - NetworkManager widget crashed when NetworkManager restarted
Summary: NetworkManager widget crashed when NetworkManager restarted
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-16 00:02 UTC by Sasa Kara
Modified: 2010-02-16 01:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sasa Kara 2010-02-16 00:02:48 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-18-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
This is 100% reproducible - steps to reproduce:

1. stop network-manager
2. start network-manager
3. the widget crashes

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0x00000058 in ?? ()
#7  0x0015f25e in qobject_cast<Knm::InterfaceConnection const*> (first=0x80697e0, second=0x9b8f770) at /usr/include/qt4/QtCore/qobject.h:456
#8  activatableLessThan (first=0x80697e0, second=0x9b8f770) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:184
#9  0x0015f49d in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:379
#10 0x0015f454 in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:413
#11 0x0015f697 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x9b452e8, activatable=0x9cd39a0)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#12 SortedActivatableList::handleAdd (this=0x9b452e8, activatable=0x9cd39a0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#13 0x0014dd03 in ActivatableList::addActivatableInternal (this=0x9b47ff8, activatable=0x9cd39a0)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#14 0x0014dd9c in ActivatableList::addActivatable (this=0x9b47ff8, activatable=0x80697e0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:82
#15 0x00151767 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x9b71298, addedConnection=0x9b97d38)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#16 0x0014f2fe in NetworkInterfaceActivatableProvider::init (this=0x9b71298)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfaceactivatableprovider.cpp:64
#17 0x0014e520 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x9b96d08, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:79
#18 0x00147a9b in NetworkInterfaceMonitor::qt_metacall (this=0x9b96d08, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf8fdbe8)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-i486-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#19 0x00aa9263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#20 0x00aa9ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#21 0x005548b3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#22 0x00555346 in ?? () from /usr/lib/libsolidcontrol.so.4
#23 0x005553c7 in ?? () from /usr/lib/libsolidcontrol.so.4
#24 0x00aa9263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#25 0x00aa9ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#26 0x018fc143 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x018fd6a8 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#28 0x0190087d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#29 0x00aa9263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#30 0x00aa9ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#31 0x0190ce53 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#32 0x0190d385 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#33 0x005907b4 in ?? () from /usr/lib/libQtDBus.so.4
#34 0x00598197 in ?? () from /usr/lib/libQtDBus.so.4
#35 0x00aa35fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#36 0x01041f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#37 0x0104967c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#38 0x00344bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#39 0x00a936cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#40 0x00a942b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#41 0x00a9447d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#42 0x00abe3ff in ?? () from /usr/lib/libQtCore.so.4
#43 0x0777ce88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#44 0x07780730 in ?? () from /lib/libglib-2.0.so.0
#45 0x07780863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#46 0x00abe02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#47 0x010e2be5 in ?? () from /usr/lib/libQtGui.so.4
#48 0x00a91c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#49 0x00a920ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#50 0x00a9453f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#51 0x01041dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#52 0x08052905 in main (argc=1, argv=0xbf8feaa4) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-16 01:21:25 UTC
Reported at bug 210878. Thanks

*** This bug has been marked as a duplicate of bug 210878 ***