Bug 226969 - analog clock's time stands still on 12
Summary: analog clock's time stands still on 12
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-clock (show other bugs)
Version: unspecified
Platform: OpenSUSE Unspecified
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 208478 225824 227420 228259 228581 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-15 12:03 UTC by Silver Salonen
Modified: 2010-03-01 13:06 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silver Salonen 2010-02-15 12:03:59 UTC
Version:            (using KDE 4.4.0)
Installed from:    openSUSE RPMs

I have added analog clock as widget onto my desktop. I've configured it to show second's hand too. It works OK, but after I logout-login, it shows time 12:00 and second's hand is gone. When I re-enable it, clock starts working aka showing correct time again. Verified on 2 different computers (32-bit and 64-bit).
Comment 1 Kristjan Ugrin 2010-02-15 12:31:45 UTC
I can confirm this, analog clock widget is stuck at 12:00
Comment 2 Anne-Marie Mahfouf 2010-02-15 13:22:16 UTC
confirmed
Comment 3 Anne-Marie Mahfouf 2010-02-15 13:31:13 UTC
SVN commit 1090526 by annma:

maybe my clock being stuck is due to this code error which was introduced after the 4.4.0 tag
CCBUG=226969
CCMAIL=riccardo@kde.org


 M  +2 -2      clock.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1090526
Comment 4 Anne-Marie Mahfouf 2010-02-15 13:49:45 UTC
I can't reproduce in current 4.4 branch now that I fixed the above ;)

Can you retry and instead of login out please do
- kquitapp plasma-desktop
- plasma-desktop
in a terminal.

There have been a few changes in post 4.4.0 code so I need the exact steps. Is it triggered by the second hand added? Silver, you say "when I reenable it", what do you mean?
Kristjan: exact steps? use kquitapp plasma-desktop please

What about other clocks like digital clock?

Does it happen on the desktop? in a panel? both?

Thanks in advance!
Comment 5 Silver Salonen 2010-02-15 13:58:36 UTC
I have only digital clock on panel and analog on desktop. I meant re-enabling second's hand (that was not set in configuration, when I opened settings).
Comment 6 Kristjan Ugrin 2010-02-15 14:01:34 UTC
Restarting plasma doesn't do anything.
Steps:
- Start plasma
- add analog clock widget to desktop or panel, if not already

Clock should be stuck, until you toggle "show seconds hand" option
Comment 7 Silver Salonen 2010-02-15 14:09:13 UTC
Actually it starts working when you just open settings and click OK, without changing anything.
Comment 8 Isaac 2010-02-15 17:33:17 UTC
Confirmed. I also thought toggling the "Show seconds hand" was the only way to get the clock working, but simply going into the settings and clicking "Ok" starts the clock.
Comment 9 Anne-Marie Mahfouf 2010-02-18 11:10:57 UTC
*** Bug 225824 has been marked as a duplicate of this bug. ***
Comment 10 Anne-Marie Mahfouf 2010-02-18 13:20:11 UTC
SVN commit 1092156 by annma:

backport a few changes from Aaron and Riccardo, fixes a few analog clock bugs (not painting at start, clock at 12 at start and seconds hand setting not kept)
BUG=226969


 M  +36 -21    libs/plasmaclock/clockapplet.cpp  
 M  +2 -0      libs/plasmaclock/clockapplet.h  
 M  +10 -10    plasma/generic/applets/analog-clock/clock.cpp  
 M  +33 -0     plasma/generic/applets/digital-clock/clock.cpp  
 M  +1 -0      plasma/generic/applets/digital-clock/clock.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1092156
Comment 11 Anne-Marie Mahfouf 2010-02-18 14:20:13 UTC
*** Bug 227420 has been marked as a duplicate of this bug. ***
Comment 12 Rich 2010-02-20 06:11:29 UTC
I have the same problem. It happened with the update that brought 4.4 to final.
Comment 13 Isaac 2010-02-20 21:29:32 UTC
Hi, glad to see this issue has been fixed. Thanks Anna!

Question though, will Opensuse users see this fix in the KKFD repo or will we have to wait til 4.4.1 is released?
Comment 14 Anne-Marie Mahfouf 2010-02-21 12:00:43 UTC
4.4.1. should be released very soon (by the end of the month or beginning of March).
I don't know about OpenSuse KKFD specifics.
Comment 15 Riccardo Iaconelli 2010-02-23 18:46:50 UTC
I don't know if any packager is around, but if anybody is cherry-picking, the real commit that fixed that bug in a complete way is in revision 1093103

sorry for not having cc'd this bug from my commit
Comment 16 Anne-Marie Mahfouf 2010-02-26 09:37:53 UTC
*** Bug 228581 has been marked as a duplicate of this bug. ***
Comment 17 Anne-Marie Mahfouf 2010-03-01 13:04:24 UTC
*** Bug 228259 has been marked as a duplicate of this bug. ***
Comment 18 Anne-Marie Mahfouf 2010-03-01 13:06:08 UTC
*** Bug 208478 has been marked as a duplicate of this bug. ***