Bug 226440 - amarok fails to complete copying audio tracks from cd to local collection
Summary: amarok fails to complete copying audio tracks from cd to local collection
Status: RESOLVED DUPLICATE of bug 224437
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-12 02:56 UTC by fred
Modified: 2010-02-27 13:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fred 2010-02-12 02:56:49 UTC
Version:           2.2.2 (using 4.4.00 (KDE 4.4.0), Arch Linux)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.32-ARCH


When attempting to copy files from an audio CD to my local
collection, amarok may or may not successfully copy some files
but will eventually cease to make further progress in copying the
audio files or will crash.  I've attempted to copy multiple audio
CDs to local collection using both org-vorbis and flac codecs with
similar results.

Here's some output from running amarok from konsole:

amarok(5065)/libplasma Plasma::ViewPrivate::updateSceneRect: !!!!!!!!!!!!!!!!! setting the scene rect to QRectF(0,0 238x248) associated screen is -1
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.kdercu14053.new"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.kderc.lock.o14053"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred"
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: update started in KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotUpdateResult: finished update KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileRenamed: KUrl("file:///home/fred/Public/Music/R/Richard Hell & The Voidoids/Blank Generation/09 - The Plan.flac.part") -> KUrl("file:///home/fred/Public/Music/R/Richard Hell & The Voidoids/Blank Generation/09 - The Plan.flac")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileRenamed: Item not found: KUrl("file:///home/fred/Public/Music/R/Richard Hell & The Voidoids/Blank Generation/09 - The Plan.flac.part")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.kdercv14071.new"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.kderc.lock.g14071"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred"
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: update started in KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotUpdateResult: finished update KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred"
amarok(5065)/kio (KDirListerCache) KDirListerCache::handleDirDirty: forgetting about individual update to "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: update started in KUrl("file:///storage/home/fred")
amarok(5065)/kio (Slave) KIO::Slave::createSlave: createSlave "file" for KUrl("file:///storage/home/fred")
amarok(5065)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/tmp/ksocket-fred/amarokDr5065.slave-socket"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotUpdateResult: finished update KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::processPendingUpdates: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::processPendingUpdates: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred"
amarok(5065)/kio (KDirListerCache) KDirListerCache::handleDirDirty: forgetting about individual update to "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: update started in KUrl("file:///storage/home/fred")
amarok(5065)/kio (Slave) KIO::Slave::createSlave: createSlave "file" for KUrl("file:///storage/home/fred")
amarok(5065)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/tmp/ksocket-fred/amarokog5065.slave-socket"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotUpdateResult: finished update KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/libplasma Plasma::ViewPrivate::updateSceneRect: !!!!!!!!!!!!!!!!! setting the scene rect to QRectF(0,0 238x248) associated screen is -1
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.kdercu14053.new"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.kderc.lock.o14053"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred"
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: update started in KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotUpdateResult: finished update KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileRenamed: KUrl("file:///home/fred/Public/Music/R/Richard Hell & The Voidoids/Blank Generation/09 - The Plan.flac.part") -> KUrl("file:///home/fred/Public/Music/R/Richard Hell & The Voidoids/Blank Generation/09 - The Plan.flac")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileRenamed: Item not found: KUrl("file:///home/fred/Public/Music/R/Richard Hell & The Voidoids/Blank Generation/09 - The Plan.flac.part")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.kdercv14071.new"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.kderc.lock.g14071"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred"
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: update started in KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotUpdateResult: finished update KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred"
amarok(5065)/kio (KDirListerCache) KDirListerCache::handleDirDirty: forgetting about individual update to "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: update started in KUrl("file:///storage/home/fred")
amarok(5065)/kio (Slave) KIO::Slave::createSlave: createSlave "file" for KUrl("file:///storage/home/fred")
amarok(5065)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/tmp/ksocket-fred/amarokDr5065.slave-socket"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotUpdateResult: finished update KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::processPendingUpdates: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::processPendingUpdates: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred"
amarok(5065)/kio (KDirListerCache) KDirListerCache::handleDirDirty: forgetting about individual update to "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::updateDirectory: update started in KUrl("file:///storage/home/fred")
amarok(5065)/kio (Slave) KIO::Slave::createSlave: createSlave "file" for KUrl("file:///storage/home/fred")
amarok(5065)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/tmp/ksocket-fred/amarokog5065.slave-socket"
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotUpdateResult: finished update KUrl("file:///storage/home/fred")
amarok(5065)/kio (KDirListerCache) KDirListerCache::slotFileDirty: "/storage/home/fred/.pine-debug1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::processPendingUpdates: "/storage/home/fred/.pine-debug1"
amarok(5065)/kdecore (kdelibs) KToolInvocation::invokeBrowser: Using "/usr/bin/kfmclient" to open "https://bugs.kde.org/wizard.cgi?os=Linux%20%28x86_64%29%20release%202.6.32-ARCH&compiler=gcc&kdeVersion=4.4.00%20%28KDE%204.4.0%29%2C%20Arch%20Linux&appVersion=2.2.2&package=amarok&kbugreport=1"
amarok(5065)/kio (KDirListerCache) KDirListerCache::processPendingUpdates: "/storage/home/fred/.pine-debug1"
amarok(5065)/kdecore (kdelibs) KToolInvocation::invokeBrowser: Using "/usr/bin/kfmclient" to open "https://bugs.kde.org/wizard.cgi?os=Linux%20%28x86_64%29%20release%202.6.32-ARCH&compiler=gcc&kdeVersion=4.4.00%20%28KDE%204.4.0%29%2C%20Arch%20Linux&appVersion=2.2.2&package=amarok&kbugreport=1"
Comment 1 Myriam Schweingruber 2010-02-12 09:27:05 UTC
Not sure this is an Amarok problem, looks more like the KIO slave, no?
Comment 2 Myriam Schweingruber 2010-02-24 21:48:26 UTC
might also be related to bug 224437
Comment 3 Myriam Schweingruber 2010-02-27 13:47:38 UTC

*** This bug has been marked as a duplicate of bug 224437 ***