Bug 226320 - Distribution lists not converted
Summary: Distribution lists not converted
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Migration (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Volker Krause
URL:
Keywords: akonadi-ports-regression
: 226619 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-11 14:56 UTC by Axel Braun
Modified: 2016-12-14 08:25 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Braun 2010-02-11 14:56:27 UTC
Version:           4.4 (using 4.4.00 (KDE 4.4.0) "release 222", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (i686) release 2.6.27.42-0.1-pae

Just upgraded from KDE 4.3.4 to 4.4.0 and noticed that all my mailing lists from Kaddressbook are gone!
Is there a way to get them back?
Comment 1 Tobias Koenig 2010-02-13 08:09:44 UTC
*** Bug 226619 has been marked as a duplicate of this bug. ***
Comment 2 Mark van Rossum 2010-02-28 00:38:41 UTC
I wrote this awk script to extract the list that links id-numbers with email
addresses.
(First export the old addressbook as addressbook.vcf and 
 run 'dos2unix addressbook.vcf' on it)

It should be relatively simple to use this as a substitution table
in the distribution list entries.

awk '
# Records are separated by blank lines.
# Each line is one field.
# first run dos2unix on addressbook.vcf
BEGIN { RS = "" ; FS="\n" }
/EMAIL.*UID/ {
	n=split($0,x,"\n"); # array x[i]
	for (i = 1;  i<= NF ; i++){
		if (x[i] ~ /EMAIL/) e=x[i]		 
		if (x[i] ~ /UID/) u=x[i]
	}
	n=split(e,ee,":");
	n=split(u,uu,":");
	print ee[2]," ", uu[2]  
}
'
Comment 3 Mark van Rossum 2010-05-15 20:21:14 UTC
And even if this bug is solved, lists won't work in kde4.4....
Comment 4 tony 2010-08-06 17:55:02 UTC
(In reply to comment #3)
> And even if this bug is solved, lists won't work in kde4.4....

...which is exactly the case, as I've found out to my cost since Mandriva 2010.1 "upgraded" KDE to 4.4.3.

In fact it took a lot of digging around to even find out how to get even my contacts list into kaddressbook (import the ~/.kde4/share/apps/kabc/std.vcf into it), which was totally empty and virtually non-functional.

Is kaddressbook being replaced with something that actually WORKS, or are the developers trying to encourage us to use Gnome instead? I really can't understand why a perfectly functional program has been replaced by one that doesn't work.
Comment 5 Denis Kurz 2016-09-24 20:44:43 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 6 Axel Braun 2016-12-13 07:55:24 UTC
Migration from KMail 4.14.10 to 5.3.2 worked
Comment 7 Christoph Feck 2016-12-13 13:36:42 UTC
Axel, we use CONFIRMED for bugs that are open. If this is indeed working, please set the status to RESOLVED.
Comment 8 Axel Braun 2016-12-14 08:25:56 UTC
Status corrected