Bug 226119 - Audio player runner / Amarok behave incorrectly for many commands
Summary: Audio player runner / Amarok behave incorrectly for many commands
Status: RESOLVED FIXED
Alias: None
Product: krunner
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Jan Gerrit Marker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-10 09:46 UTC by James Dent
Modified: 2011-10-21 16:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Dent 2010-02-10 09:46:28 UTC
Version:           unknown (using 4.4.00 (KDE 4.4.0), Arch Linux)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.32-ARCH

Many actions of the "Control Audio Player" runner do not function as intended with Amarok (version 2.2.2):

The following commands add the correct song to the playlist (unfortunately creating a duplicate if it is already present) and then play the last song in the playlist. However, for a sorted playlist, this is very rarely the correct song. No other actions are taken by any of these.

- "<song-title>"
- "play <song-title>"
- "append <song-title>"
- "queue <song-title>"

The following commands don't seem to match any results:

- "up"
- "down"
- "volume"

The following commands work correctly:

- "play"
- "pause"
- "prev"
- "next"
- "mute"
- "quit"
Comment 1 Jan Gerrit Marker 2010-07-14 10:00:11 UTC
Hello, sorry for replying that late.
I currently working on fixing this bug. The commands up, down and volume had slight mistakes, that's corrected in my development version.
I'll have close look at the other ones, which don't work as aspected.
Thanks for reporting.
Comment 2 Jan Gerrit Marker 2010-07-14 10:40:55 UTC
SVN commit 1149762 by jangmarker:

Fix performance issues. Change commands up, down, volume= to increase, decrease, volume. They should work now.
CCBUG:225260
CCBUG:226119


 M  +3 -0      TODO  
 M  +51 -39    audioplayercontrolrunner.cpp  
 M  +3 -3      audioplayercontrolrunner_config.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1149762
Comment 3 Jan Gerrit Marker 2010-07-14 12:19:29 UTC
>then play the last song in the playlist. However, for a sorted playlist, this is
>very rarely the correct song.
I tested the D-Bus interface of Amarok and it seems, that this is a bug of Amarok. I have reported it as bug 244595.
Comment 4 Jan Gerrit Marker 2010-07-14 14:06:16 UTC
SVN commit 1149816 by jangmarker:

Correct typos. The runner now depends on Amarok 2.3 because it uses MprisQuery instead of Query and the metadata structure was adapted.
Append and Play append a track only if the track is not already in the playlist. The search results are decreased to 5.
CCBUG:226119


 M  +42 -16    audioplayercontrolrunner.cpp  
 M  +5 -0      audioplayercontrolrunner.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1149816
Comment 5 Jan Gerrit Marker 2011-10-21 16:44:24 UTC
If I see correctly all issues but the issue about inserting and playing songs which is a bug of Amarok are fixed in KDE 4.7 so I close this bug report. If this is not the case please add a comment with some information to help me fixing this bug.