Bug 226015 - Network Manager crashes after applying changes or restart of NM
Summary: Network Manager crashes after applying changes or restart of NM
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-09 11:05 UTC by kojo1984
Modified: 2010-02-10 13:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kojo1984 2010-02-09 11:05:33 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.1 (KDE 4.3.1) "release 6"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.8-0.1-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

What I was doing when the application crashed:
When I run "service network restart" from command line, NM crashes... Also , in Yast, when open Network Settings and change HOSTNAME or something else (which is not controlled by NM), after pressing OK, it crasheso on "Activating network services"

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f245edb265a in Knm::Activatable::deviceUni() const () from /usr/lib64/libknminternals.so.4
#6  0x00007f245eb787e3 in ?? () from /usr/lib64/libknmservice.so.4
#7  0x00007f245eb78903 in ?? () from /usr/lib64/libknmservice.so.4
#8  0x00007f245eb78b5e in ?? () from /usr/lib64/libknmservice.so.4
#9  0x00007f245eb78e10 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib64/libknmservice.so.4
#10 0x00007f245eb683cb in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib64/libknmservice.so.4
#11 0x00007f245eb6bb9d in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib64/libknmservice.so.4
#12 0x00007f245eb6a140 in NetworkInterfaceActivatableProvider::init() () from /usr/lib64/libknmservice.so.4
#13 0x00007f245eb68e38 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib64/libknmservice.so.4
#14 0x00007f245eb62abd in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libknmservice.so.4
#15 0x00007f245d5f1fbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#16 0x00007f245e6e2b45 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib64/libsolidcontrol.so.4
#17 0x00007f245e6e351c in ?? () from /usr/lib64/libsolidcontrol.so.4
#18 0x00007f245d5f1fbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#19 0x00007f2454b19075 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib64/kde4/solid_networkmanager07.so
#20 0x00007f2454b1a434 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib64/kde4/solid_networkmanager07.so
#21 0x00007f2454b1d2e9 in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/kde4/solid_networkmanager07.so
#22 0x00007f245d5f1fbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#23 0x00007f2454b28932 in ?? () from /usr/lib64/kde4/solid_networkmanager07.so
#24 0x00007f2454b28d5d in ?? () from /usr/lib64/kde4/solid_networkmanager07.so
#25 0x00007f245d8f3b78 in ?? () from /usr/lib64/libQtDBus.so.4
#26 0x00007f245d8fb16f in ?? () from /usr/lib64/libQtDBus.so.4
#27 0x00007f245d5ec2d9 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#28 0x00007f245dcda2ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#29 0x00007f245dce157e in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#30 0x00007f245f3e88d6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#31 0x00007f245d5dcddc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#32 0x00007f245d5dd9ea in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#33 0x00007f245d605803 in ?? () from /usr/lib64/libQtCore.so.4
#34 0x00007f24599e4dee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#35 0x00007f24599e87b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f24599e88e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f245d6053a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#38 0x00007f245dd6d31e in ?? () from /usr/lib64/libQtGui.so.4
#39 0x00007f245d5db712 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#40 0x00007f245d5dbae4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007f245d5ddc99 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#42 0x000000000040d5af in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-10 13:25:00 UTC
Reported already at bug 210878. Regards

*** This bug has been marked as a duplicate of bug 210878 ***