Bug 225929 - Random crash when running pdflatex (alt+6)
Summary: Random crash when running pdflatex (alt+6)
Status: RESOLVED DUPLICATE of bug 208486
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-08 17:19 UTC by Magnus Johansson
Modified: 2010-02-15 10:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Johansson 2010-02-08 17:19:43 UTC
Application that crashed: kile
Version of the application: 2.0.84
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-gentoo-r6 i686

What I was doing when the application crashed:
I had just updated the paper I'm working on with "svn update" so Kile recognised it as "changed on disk" and I reloaded the file. Then I pressed alt+6 and got this crash. After restarting Kile, the crash does not happen when pressing alt+6, so it seems random.


 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#6  QBasicAtomicInt::ref (this=0x0) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#7  0xb6c9e7e1 in QList (this=0xbfa895ac, l=@0xac71e44) at /usr/include/qt4/QtCore/qlist.h:111
#8  0xb6c9e815 in QForeachContainer (this=0xbfa895ac, t=@0xac71e44) at /usr/include/qt4/QtCore/qglobal.h:2054
#9  0xb6c96b78 in KDirWatchPrivate::Entry::propagate_dirty (this=0xac71e2c) at /var/tmp/portage/kde-base/kdelibs-4.3.5/work/kdelibs-4.3.5/kio/kio/kdirwatch.cpp:399
#10 0xb6c96bcc in KDirWatchPrivate::Entry::propagate_dirty (this=0xb7fea34) at /var/tmp/portage/kde-base/kdelibs-4.3.5/work/kdelibs-4.3.5/kio/kio/kdirwatch.cpp:404
#11 0xb6c9b3b8 in KDirWatchPrivate::slotRescan (this=0xa1a4f58) at /var/tmp/portage/kde-base/kdelibs-4.3.5/work/kdelibs-4.3.5/kio/kio/kdirwatch.cpp:1275
#12 0xb6c9c7fd in KDirWatchPrivate::qt_metacall (this=0xa1a4f58, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa897a8)
    at /var/tmp/portage/kde-base/kdelibs-4.3.5/work/kdelibs-4.3.5_build/kio/kdirwatch_p.moc:73
#13 0xb642c34c in QMetaObject::activate (sender=0xa1a4fa0, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3101
#14 0xb642c895 in QMetaObject::activate (sender=0xa1a4fa0, m=0xb64c1904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3178
#15 0xb6460720 in QTimer::timeout (this=0xa1a4fa0) at .moc/release-shared/moc_qtimer.cpp:128
#16 0xb6432ddf in QTimer::timerEvent (this=0xa1a4fa0, e=0xbfa89c3c) at kernel/qtimer.cpp:261
#17 0xb6429620 in QObject::event (this=0xa1a4fa0, e=0xbfa89c3c) at kernel/qobject.cpp:1066
#18 0xb5c5abf4 in QApplicationPrivate::notify_helper (this=0xa095520, receiver=0xa1a4fa0, e=0xbfa89c3c) at kernel/qapplication.cpp:4065
#19 0xb5c62402 in QApplication::notify (this=0xbfa89f30, receiver=0xa1a4fa0, e=0xbfa89c3c) at kernel/qapplication.cpp:3605
#20 0xb68f5daa in KApplication::notify (this=0xbfa89f30, receiver=0xa1a4fa0, event=0xbfa89c3c) at /var/tmp/portage/kde-base/kdelibs-4.3.5/work/kdelibs-4.3.5/kdeui/kernel/kapplication.cpp:302
#21 0xb641b365 in QCoreApplication::notifyInternal (this=0xbfa89f30, receiver=0xa1a4fa0, event=0xbfa89c3c) at kernel/qcoreapplication.cpp:606
#22 0xb644335b in QTimerInfoList::activateTimers (this=0xa098044) at kernel/qcoreapplication.h:213
#23 0xb6440277 in timerSourceDispatch (source=0xa098010) at kernel/qeventdispatcher_glib.cpp:165
#24 0xb54b0992 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0

Reported using DrKonqi
Comment 1 Michel Ludwig 2010-02-15 10:54:19 UTC

*** This bug has been marked as a duplicate of bug 208486 ***