Bug 225335 - Crash after copying from local filesystem to smb:// in dolphin
Summary: Crash after copying from local filesystem to smb:// in dolphin
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-03 01:40 UTC by Ben Klopfenstein
Modified: 2010-02-03 01:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Klopfenstein 2010-02-03 01:40:55 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4) "release 2"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.8-0.1-pae i686

What I was doing when the application crashed:
i had just finished copying a file to a remote system. I looked away from my screen for a few moments, when I looked back dolphin had crashed.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5273700 (LWP 7686))]

Thread 2 (Thread 0xb29ffb70 (LWP 9870)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb5ba20c2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5c922d4 in pthread_cond_timedwait () from /lib/libc.so.6
#3  0xb1cd819b in metronom_sync_loop () from /usr/lib/libxine.so.1
#4  0xb5b9d6e5 in start_thread () from /lib/libpthread.so.0
#5  0xb5b9d600 in ?? () from /lib/libpthread.so.0

Thread 1 (Thread 0xb5273700 (LWP 7686)):
[KCrash Handler]
#6  0xb5f1e1f8 in QUrl::QUrl (this=0xbf92caa8, other=...) at io/qurl.cpp:3936
#7  0xb6b2dbfa in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0xb75684ef in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0xb7555d92 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0xb74298a8 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0xb742d680 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0xb742e3b0 in KFilePreviewGenerator::Private::updateIcons(QModelIndex const&, QModelIndex const&) () from /usr/lib/libkfile.so.4
#13 0xb742eb25 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0xb5f82864 in QMetaObject::activate (sender=0x836df70, from_signal_index=4, to_signal_index=4, argv=0xbf92cd94) at kernel/qobject.cpp:3113
#15 0xb5f83585 in QMetaObject::activate (sender=0x836df70, m=0xb605f4f8, local_signal_index=0, argv=0xbf92cd94) at kernel/qobject.cpp:3187
#16 0xb5fbdabd in QAbstractItemModel::dataChanged (this=0x836df70, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:126
#17 0xb755539b in ?? () from /usr/lib/libkio.so.5
#18 0xb755732e in KDirModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#19 0xb5f82864 in QMetaObject::activate (sender=0x836dea0, from_signal_index=18, to_signal_index=18, argv=0xbf92cfc8) at kernel/qobject.cpp:3113
#20 0xb5f83585 in QMetaObject::activate (sender=0x836dea0, m=0x80c2410, local_signal_index=14, argv=0xbf92cfc8) at kernel/qobject.cpp:3187
#21 0xb7538f55 in KDirLister::refreshItems(QList<QPair<KFileItem, KFileItem> > const&) () from /usr/lib/libkio.so.5
#22 0xb753a22a in KDirLister::Private::emitItems() () from /usr/lib/libkio.so.5
#23 0xb754ad76 in ?? () from /usr/lib/libkio.so.5
#24 0xb754ca4d in ?? () from /usr/lib/libkio.so.5
#25 0xb5f82864 in QMetaObject::activate (sender=0x95e81c8, from_signal_index=7, to_signal_index=7, argv=0xbf92d2b8) at kernel/qobject.cpp:3113
#26 0xb5f83585 in QMetaObject::activate (sender=0x95e81c8, m=0x80c2400, local_signal_index=3, argv=0xbf92d2b8) at kernel/qobject.cpp:3187
#27 0xb6b39695 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#28 0xb6b39ba9 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#29 0xb7518f8f in KIO::SimpleJob::slotFinished() () from /usr/lib/libkio.so.5
#30 0xb75190e7 in KIO::ListJob::slotFinished() () from /usr/lib/libkio.so.5
#31 0xb75201cd in KIO::ListJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#32 0xb5f82864 in QMetaObject::activate (sender=0x83d7498, from_signal_index=8, to_signal_index=8, argv=0x0) at kernel/qobject.cpp:3113
#33 0xb5f83585 in QMetaObject::activate (sender=0x83d7498, m=0xb7706f64, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3187
#34 0xb75eab15 in KIO::SlaveInterface::finished() () from /usr/lib/libkio.so.5
#35 0xb75eec84 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/libkio.so.5
#36 0xb75eb02a in KIO::SlaveInterface::dispatch() () from /usr/lib/libkio.so.5
#37 0xb75dc625 in KIO::Slave::gotInput() () from /usr/lib/libkio.so.5
#38 0xb75debf4 in KIO::Slave::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#39 0xb5f82864 in QMetaObject::activate (sender=0x9532518, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#40 0xb5f83585 in QMetaObject::activate (sender=0x9532518, m=0xb77038a0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#41 0xb74dd2b5 in KIO::Connection::readyRead() () from /usr/lib/libkio.so.5
#42 0xb74df19a in ?? () from /usr/lib/libkio.so.5
#43 0xb74df2e7 in KIO::Connection::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#44 0xb5f7b04a in QMetaCallEvent::placeMetaCall (this=0x99e9440, object=0x9532518) at kernel/qobject.cpp:477
#45 0xb5f7c796 in QObject::event (this=0x9532518, e=0x99e9440) at kernel/qobject.cpp:1111
#46 0xb61818fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#47 0xb618934e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#48 0xb6eb0451 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#49 0xb5f6c32e in QCoreApplication::notifyInternal (this=0xbf92dfdc, receiver=0x9532518, event=0x99e9440) at kernel/qcoreapplication.cpp:610
#50 0xb5f6cfdc in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#51 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1247
#52 0xb5f6d19c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#53 0xb5f984dd in sendPostedEvents () at kernel/qcoreapplication.h:218
#54 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:276
#55 0xb55034c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#56 0xb5506d98 in ?? () from /usr/lib/libglib-2.0.so.0
#57 0xb5506ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#58 0xb5f98011 in QEventDispatcherGlib::processEvents (this=0x80c7e40, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#59 0xb622329a in ?? () from /usr/lib/libQtGui.so.4
#60 0xb5f6a98d in QEventLoop::processEvents (this=0xbf92df34, flags=) at kernel/qeventloop.cpp:149
#61 0xb5f6add9 in QEventLoop::exec (this=0xbf92df34, flags=...) at kernel/qeventloop.cpp:201
#62 0xb5f6d270 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#63 0xb6181774 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#64 0x0807b0b5 in _start ()

This bug may be a duplicate of or related to bug 224464

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-03 01:53:59 UTC
Fixed in KDE SC 4.3.5 and 4.4.0. Regards

*** This bug has been marked as a duplicate of bug 211525 ***