Bug 225309 - Jamendo Search Crashes Amarok
Summary: Jamendo Search Crashes Amarok
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-02 21:26 UTC by James Marchant
Modified: 2010-02-03 09:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Marchant 2010-02-02 21:26:33 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-18-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Whilst searching for "John" in the Jamendo databse in Amarok the program crashed; additional tests with other words found similar behavior.

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f1aad5d97a0 (LWP 16522))]

Thread 12 (Thread 0x7f1a8f832910 (LWP 16527)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f1a94ce0da1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f1a8e2e9910 (LWP 16528)):
#0  0x00007f1aa54e66dd in __pthread_mutex_unlock_usercnt (mutex=0x1c684e8) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x1c684e8) at pthread_mutex_unlock.c:289
#2  0x00007f1aa3e1e2a8 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f1aa3e1e6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007f1aab3771fe in QEventDispatcherGlib::processEvents (this=0x1c67e10, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:329
#5  0x00007f1aab34d532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f1aab34d904 in QEventLoop::exec (this=0x7f1a8e2e8fb0, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f1aab2656cb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007f1a94f3b56e in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#9  0x00007f1aab268445 in QThreadPrivate::start (arg=0x1c67fc0) at thread/qthread_unix.cpp:188
#10 0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#11 0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 10 (Thread 0x7f1a896d6910 (LWP 16553)):
#0  0x00007f1aaac5e3c3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1a8ec1820f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f1a8ec085e6 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f1a8ec09eb9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f1a8ec09f70 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f1a8ec1812b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f1a8e9d9050 in ?? () from /usr/lib/libpulsecommon-0.9.19.so
#7  0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()
The current source language is "auto; currently c".

Thread 9 (Thread 0x7f1a8d4d1910 (LWP 16556)):
#0  __pthread_mutex_unlock_full (mutex=0x1c79de0, decr=135) at pthread_mutex_unlock.c:229
#1  0x00007f1a8e9d837e in pa_mutex_unlock () from /usr/lib/libpulsecommon-0.9.19.so
#2  0x00007f1a8d4d4d70 in ?? () from /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
#3  0x00007f1a9528b818 in snd_hctl_handle_events () from /usr/lib/libasound.so.2
#4  0x00007f1a95295589 in snd_mixer_handle_events () from /usr/lib/libasound.so.2
#5  0x00007f1a8d8e4d04 in ?? () from /usr/lib/xine/plugins/1.25/xineplug_ao_out_alsa.so
#6  0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#7  0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f1a8ccd0910 (LWP 16557)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f1a94cf1aa3 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f1a8c02c910 (LWP 16558)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f1a94cf1aa3 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 6 (Thread 0x7f1a8b82b910 (LWP 16559)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f1a94cf1aa3 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f1a84ed4910 (LWP 16618)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f1aab2694fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x255a170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x255a170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f1aa7f1c326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2849850, th=0x232bc70) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f1aa7f1e45b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cf66d0, th=0x232bc70) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f1aa7f1e474 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cf66d0, th=0x232bc70) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f1aa7f1e474 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cf66d0, th=0x232bc70) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f1aa7f1e474 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cf66d0, th=0x232bc70) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007f1aa7f1ca5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f1a84ed4000, parent=0x2849850, th=0x232bc70) at ../../../threadweaver/Weaver/Thread.cpp:87
#9  0x00007f1aa7f1ceb8 in ThreadWeaver::Thread::run (this=0x232bc70) at ../../../threadweaver/Weaver/Thread.cpp:142
#10 0x00007f1aab268445 in QThreadPrivate::start (arg=0x232bc70) at thread/qthread_unix.cpp:188
#11 0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#12 0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f1a7321c910 (LWP 16619)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f1aab2694fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x255a170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x255a170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f1aa7f1c326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2849850, th=0x307f5f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f1aa7f1e45b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cf66d0, th=0x307f5f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f1aa7f1ca5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f1a7321c000, parent=0x2849850, th=0x307f5f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f1aa7f1ceb8 in ThreadWeaver::Thread::run (this=0x307f5f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f1aab268445 in QThreadPrivate::start (arg=0x307f5f0) at thread/qthread_unix.cpp:188
#8  0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1a70b5d910 (LWP 16626)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f1aab2694fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x255a170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x255a170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f1aa7f1c326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2849850, th=0x28a8f80) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f1aa7f1e45b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cf66d0, th=0x28a8f80) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f1aa7f1ca5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f1a70b5d000, parent=0x2849850, th=0x28a8f80) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f1aa7f1ceb8 in ThreadWeaver::Thread::run (this=0x28a8f80) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f1aab268445 in QThreadPrivate::start (arg=0x28a8f80) at thread/qthread_unix.cpp:188
#8  0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f1a6dd95910 (LWP 16797)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f1aab2694fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x255a170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x255a170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f1aa7f1c326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2849850, th=0x8f13850) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f1aa7f1e45b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2cf66d0, th=0x8f13850) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f1aa7f1ca5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f1a6dd95000, parent=0x2849850, th=0x8f13850) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f1aa7f1ceb8 in ThreadWeaver::Thread::run (this=0x8f13850) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f1aab268445 in QThreadPrivate::start (arg=0x8f13850) at thread/qthread_unix.cpp:188
#8  0x00007f1aa54e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f1aaac6a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1aad5d97a0 (LWP 16522)):
[KCrash Handler]
#5  QBasicAtomicInt::ref (this=0x916a7c0) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#6  QList (this=0x916a7c0) at /usr/include/qt4/QtCore/qlist.h:111
#7  CollectionTreeItem::children (this=0x916a7c0) at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItem.cpp:425
#8  0x00007f1aac7fe79a in CollectionTreeItemModelBase::populateChildren (this=0x91c5c70, dataList=..., parent=0x916a7c0, parentIndex=...)
    at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:828
#9  0x00007f1aac803f7b in CollectionTreeItemModelBase::handleNormalQueryResult (this=0x91c5c70, qm=0x2f33f30, dataList=...)
    at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:800
#10 0x00007f1aac80435c in CollectionTreeItemModelBase::newResultReady (this=0x91c5c70, collectionId=<value optimized out>, data=)
    at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:677
#11 0x00007f1aac800160 in CollectionTreeItemModelBase::qt_metacall (this=0x91c5c70, _c=<value optimized out>, _id=<value optimized out>, _a=0x9257d90)
    at /build/buildd/amarok-2.2.0/obj-x86_64-linux-gnu/src/CollectionTreeItemModelBase.moc:87
#12 0x00007f1aab35e0f9 in QObject::event (this=0x91c5c70, e=0x9263d30) at kernel/qobject.cpp:1111
#13 0x00007f1aabc6eefc in QApplicationPrivate::notify_helper (this=0x19818a0, receiver=0x91c5c70, e=0x9263d30) at kernel/qapplication.cpp:4056
#14 0x00007f1aabc761ce in QApplication::notify (this=0x7fff728b55c0, receiver=0x91c5c70, e=0x9263d30) at kernel/qapplication.cpp:4021
#15 0x00007f1aad100ab6 in KApplication::notify (this=0x7fff728b55c0, receiver=0x91c5c70, event=0x9263d30) at ../../kdeui/kernel/kapplication.cpp:302
#16 0x00007f1aab34ec2c in QCoreApplication::notifyInternal (this=0x7fff728b55c0, receiver=0x91c5c70, event=0x9263d30) at kernel/qcoreapplication.cpp:610
#17 0x00007f1aab34f80a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1868810) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1868810) at kernel/qcoreapplication.cpp:1247
#19 0x00007f1aab377533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#20 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#21 0x00007f1aa3e1abce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00007f1aa3e1e598 in ?? () from /lib/libglib-2.0.so.0
#23 0x00007f1aa3e1e6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x00007f1aab3771a6 in QEventDispatcherGlib::processEvents (this=0x1868470, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#25 0x00007f1aabd034be in QGuiEventDispatcherGlib::processEvents (this=0x7fff728b4b40, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#26 0x00007f1aab34d532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#27 0x00007f1aab34d904 in QEventLoop::exec (this=0x7fff728b5550, flags=) at kernel/qeventloop.cpp:201
#28 0x00007f1aab34fab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#29 0x0000000000409ec6 in main (argc=<value optimized out>, argv=0x7fff728b7368) at /build/buildd/amarok-2.2.0/src/main.cpp:225
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 217403

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2010-02-03 09:44:53 UTC
Please upgrade to Amarok 2.2.2 See also http://kubuntu.org/news/amarok-2.2.2

*** This bug has been marked as a duplicate of bug 206579 ***