Bug 225102 - dolphin cash during excecution of bash script while browsing folders
Summary: dolphin cash during excecution of bash script while browsing folders
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-01 09:10 UTC by walbertr
Modified: 2010-02-01 22:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description walbertr 2010-02-01 09:10:34 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I have been using this bash script for a long time, it is for HDR processing of pictures, and it is stable. While excecuting the script in a dolphin terminal window, I was browsing the folder to check the new pictures that were just processed. When I pressed F5 to view the new files, the program crashed. I am afraid that this bug is not easy repeatable, as I have done the same many times before without crash. Hope this helps! Very impressed with Ubuntu.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x03e73829 in QUrl (this=0xbfd4fb28, other=...) at io/qurl.cpp:3936
#7  0x01b09d89 in KUrl (this=0xbfd4fb28, _u=...) at ../../kdecore/io/kurl.cpp:468
#8  0x00c5d28e in KFileItem::url (this=0xa5651f8) at ../../kio/kio/kfileitem.cpp:1271
#9  0x00c4c75f in KDirModel::indexForItem (this=0x9f5bc10, item=...) at ../../kio/kio/kdirmodel.cpp:919
#10 0x00827a36 in KFilePreviewGenerator::Private::orderItems (this=0x9fc6150, items=...) at ../../kfile/kfilepreviewgenerator.cpp:1023
#11 0x0082b6bd in KFilePreviewGenerator::Private::updateIcons (this=0x9fc6150, items=...) at ../../kfile/kfilepreviewgenerator.cpp:508
#12 0x0082b902 in KFilePreviewGenerator::Private::delayedIconUpdate (this=0x9fc6150) at ../../kfile/kfilepreviewgenerator.cpp:1088
#13 0x0082c9a6 in KFilePreviewGenerator::qt_metacall (this=0x9fc5fb0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfd4fd7c) at ./kfilepreviewgenerator.moc:95
#14 0x03ed5263 in QMetaObject::activate (sender=0x9fba5e0, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#15 0x03ed5ec2 in QMetaObject::activate (sender=0x9fba5e0, m=0x3fb0904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#16 0x03f0f667 in QTimer::timeout (this=0x9fba5e0) at .moc/release-shared/moc_qtimer.cpp:128
#17 0x03eda9ae in QTimer::timerEvent (this=0x9fba5e0, e=0xbfd50210) at kernel/qtimer.cpp:261
#18 0x03ecf3bf in QObject::event (this=0x9fba5e0, e=0xbfd50210) at kernel/qobject.cpp:1075
#19 0x0253df54 in QApplicationPrivate::notify_helper (this=0x972a330, receiver=0x9fba5e0, e=0xbfd50210) at kernel/qapplication.cpp:4056
#20 0x0254567c in QApplication::notify (this=0xbfd5057c, receiver=0x9fba5e0, e=0xbfd50210) at kernel/qapplication.cpp:3603
#21 0x00f9ebfa in KApplication::notify (this=0xbfd5057c, receiver=0x9fba5e0, event=0xbfd50210) at ../../kdeui/kernel/kapplication.cpp:302
#22 0x03ebf6cb in QCoreApplication::notifyInternal (this=0xbfd5057c, receiver=0x9fba5e0, event=0xbfd50210) at kernel/qcoreapplication.cpp:610
#23 0x03eec7ce in QCoreApplication::sendEvent (this=0x972cb34) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QTimerInfoList::activateTimers (this=0x972cb34) at kernel/qeventdispatcher_unix.cpp:572
#25 0x03eea0e0 in timerSourceDispatch (source=0x972cb00) at kernel/qeventdispatcher_glib.cpp:165
#26 0x08138e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x0813c730 in ?? () from /lib/libglib-2.0.so.0
#28 0x0813c863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x03eea02c in QEventDispatcherGlib::processEvents (this=0x970ba30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#30 0x025debe5 in QGuiEventDispatcherGlib::processEvents (this=0x970ba30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#31 0x03ebdc79 in QEventLoop::processEvents (this=0xbfd504d4, flags=) at kernel/qeventloop.cpp:149
#32 0x03ebe0ca in QEventLoop::exec (this=0xbfd504d4, flags=...) at kernel/qeventloop.cpp:201
#33 0x03ec053f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#34 0x0253ddd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#35 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-01 22:35:36 UTC
Fixed in the last 4.3.5 and 4.4.0 versions. Regards

*** This bug has been marked as a duplicate of bug 211525 ***