Bug 224939 - When desktop effects are enabled, SMPlayer and VLC flicker in full screen while the controls appear/disappear
Summary: When desktop effects are enabled, SMPlayer and VLC flicker in full screen whi...
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-31 00:26 UTC by Victor Gavrish
Modified: 2010-01-31 00:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Gavrish 2010-01-31 00:26:58 UTC
Version:           4.3.95 (using Devel)
Compiler:          gcc (GCC) 4.4.3 
OS:                Linux
Installed from:    Compiled sources

This seems to happen whenever anything appears over the video, like volume control or other notifications.

I also saw this happen with Compiz.

I'm running an Intel i915 video card with these drivers:
xf86-video-intel 2.9.1
intel-dri 7.7
libdrm 2.4.17
linux-kernel 2.6.32.7

There is supposedly a workaround for SMPlayer, but I wasn't able to test it because I don't have osd_cat installed (and it isn't in Arch's repos):
http://smplayer.berlios.de/forums/viewtopic.php?id=1436

GNOME's mutter and metacity in compositing mode work as expected.
Comment 1 Thomas Lübking 2010-01-31 00:33:28 UTC
this is because the unredirection state toggles.

see bug #177495, comment #2 for a workaround, the osd_cat thing is cumbersome ;-)

*** This bug has been marked as a duplicate of bug 177495 ***
Comment 2 Victor Gavrish 2010-01-31 00:38:27 UTC
I'm constantly amazed at how quickly the KDE team responds to bug reports. I'm frankly not used to it. :)

Thanks, I'll look into it.