Bug 224851 - Amarok crash when searching through Jamendo database
Summary: Amarok crash when searching through Jamendo database
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-30 09:57 UTC by Artem Vorotnikov
Modified: 2010-01-30 10:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Vorotnikov 2010-01-30 09:57:49 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Amarok crashed while searching through Jamendo database.

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f75a43e17a0 (LWP 1948))]

Thread 10 (Thread 0x7f758d1ba910 (LWP 1949)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f7592e6fc91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f759c2e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f75a1a6b80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f758bc71910 (LWP 1950)):
#0  0x00007f75a1a5f3c3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f759ac1c37c in g_main_context_poll (context=0x1659f90, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2904
#2  g_main_context_iterate (context=0x1659f90, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2586
#3  0x00007f759ac1c6c0 in IA__g_main_context_iteration (context=0x1659f90, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#4  0x00007f75a21781fe in QEventDispatcherGlib::processEvents (this=0x1659980, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:329
#5  0x00007f75a214e532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f75a214e904 in QEventLoop::exec (this=0x7f758bc70fb0, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f75a20666cb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007f75930ca56e in Phonon::Xine::XineThread::run (this=0x1659940) at ../../xine/xinethread.cpp:143
#9  0x00007f75a2069445 in QThreadPrivate::start (arg=0x1659940) at thread/qthread_unix.cpp:188
#10 0x00007f759c2e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#11 0x00007f75a1a6b80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 8 (Thread 0x7f758b266910 (LWP 1953)):
#0  0x00007f75a1a5f3c3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=333) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f758b26ccbe in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#2  0x00007f759c2e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f75a1a6b80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()
The current source language is "auto; currently c".

Thread 7 (Thread 0x7f758aa65910 (LWP 1954)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f7592e80983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f759c2e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f75a1a6b80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f7589e59910 (LWP 1955)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f7592e80983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f759c2e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f75a1a6b80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 5 (Thread 0x7f7583fff910 (LWP 1958)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f75a206a4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1da99d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1da99d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f759ed1c326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1f42720, th=0x1841cb0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f759ed1e45b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1969140, th=0x1841cb0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f759ed1e474 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1969140, th=0x1841cb0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f759ed1ca5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7583fff000, parent=0x1f42720, th=0x1841cb0) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f759ed1ceb8 in ThreadWeaver::Thread::run (this=0x1841cb0) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f75a2069445 in QThreadPrivate::start (arg=0x1841cb0) at thread/qthread_unix.cpp:188
#9  0x00007f759c2e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f75a1a6b80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f7579897910 (LWP 1959)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f75a206a4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1da99d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1da99d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f759ed1c326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1f42720, th=0x1ca6480) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f759ed1e45b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1969140, th=0x1ca6480) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f759ed1ca5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7579897000, parent=0x1f42720, th=0x1ca6480) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f759ed1ceb8 in ThreadWeaver::Thread::run (this=0x1ca6480) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f75a2069445 in QThreadPrivate::start (arg=0x1ca6480) at thread/qthread_unix.cpp:188
#8  0x00007f759c2e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f75a1a6b80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f7579096910 (LWP 1963)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f75a206a4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1da99d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1da99d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f759ed1c326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1f42720, th=0x20770c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f759ed1e45b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1969140, th=0x20770c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f759ed1ca5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7579096000, parent=0x1f42720, th=0x20770c0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f759ed1ceb8 in ThreadWeaver::Thread::run (this=0x20770c0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f75a2069445 in QThreadPrivate::start (arg=0x20770c0) at thread/qthread_unix.cpp:188
#8  0x00007f759c2e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f75a1a6b80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7578895910 (LWP 1964)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f75a206a4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1da99d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1da99d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f759ed1c326 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1f42720, th=0x7f75841681f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f759ed1e45b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1969140, th=0x7f75841681f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f759ed1e474 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1969140, th=0x7f75841681f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f759ed1e474 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1969140, th=0x7f75841681f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f759ed1ca5f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7578895000, parent=0x1f42720, th=0x7f75841681f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007f759ed1ceb8 in ThreadWeaver::Thread::run (this=0x7f75841681f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007f75a2069445 in QThreadPrivate::start (arg=0x7f75841681f0) at thread/qthread_unix.cpp:188
#10 0x00007f759c2e2a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#11 0x00007f75a1a6b80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f75a43e17a0 (LWP 1948)):
[KCrash Handler]
#5  0x00007f75a35fb0ff in QListData::size (this=0x348ed10) at /usr/include/qt4/QtCore/qlist.h:87
#6  QList<CollectionTreeItem*>::indexOf (this=0x348ed10) at /usr/include/qt4/QtCore/qlist.h:633
#7  CollectionTreeItem::row (this=0x348ed10) at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItem.cpp:292
#8  0x00007f75a3608f46 in CollectionTreeItemModelBase::handleNormalQueryResult (this=0x3dc09f0, qm=0x3ec0020, dataList=...)
    at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:798
#9  0x00007f75a360935c in CollectionTreeItemModelBase::newResultReady (this=0x3dc09f0, collectionId=<value optimized out>, data=)
    at /build/buildd/amarok-2.2.0/src/browsers/CollectionTreeItemModelBase.cpp:677
#10 0x00007f75a3605160 in CollectionTreeItemModelBase::qt_metacall (this=0x3dc09f0, _c=<value optimized out>, _id=<value optimized out>, _a=0x7f756c03d7e0)
    at /build/buildd/amarok-2.2.0/obj-x86_64-linux-gnu/src/CollectionTreeItemModelBase.moc:87
#11 0x00007f75a215f0f9 in QObject::event (this=0x3dc09f0, e=0x7f756c040110) at kernel/qobject.cpp:1111
#12 0x00007f75a2a73efc in QApplicationPrivate::notify_helper (this=0x14b8190, receiver=0x3dc09f0, e=0x7f756c040110) at kernel/qapplication.cpp:4056
#13 0x00007f75a2a7b1ce in QApplication::notify (this=0x7fff4e8f96a0, receiver=0x3dc09f0, e=0x7f756c040110) at kernel/qapplication.cpp:4021
#14 0x00007f75a3f05f46 in KApplication::notify (this=0x7fff4e8f96a0, receiver=0x3dc09f0, event=0x7f756c040110) at ../../kdeui/kernel/kapplication.cpp:302
#15 0x00007f75a214fc2c in QCoreApplication::notifyInternal (this=0x7fff4e8f96a0, receiver=0x3dc09f0, event=0x7f756c040110) at kernel/qcoreapplication.cpp:610
#16 0x00007f75a215080a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x13a2800) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x13a2800) at kernel/qcoreapplication.cpp:1247
#18 0x00007f75a2178533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#19 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#20 0x00007f759ac18bce in g_main_dispatch (context=0x14bc920) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#21 IA__g_main_context_dispatch (context=0x14bc920) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#22 0x00007f759ac1c598 in g_main_context_iterate (context=0x14bc920, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#23 0x00007f759ac1c6c0 in IA__g_main_context_iteration (context=0x14bc920, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#24 0x00007f75a21781a6 in QEventDispatcherGlib::processEvents (this=0x13a2460, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#25 0x00007f75a2b084be in QGuiEventDispatcherGlib::processEvents (this=0x348ed10, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#26 0x00007f75a214e532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#27 0x00007f75a214e904 in QEventLoop::exec (this=0x7fff4e8f9630, flags=) at kernel/qeventloop.cpp:201
#28 0x00007f75a2150ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#29 0x0000000000409ec6 in main (argc=<value optimized out>, argv=0x7fff4e8fb448) at /build/buildd/amarok-2.2.0/src/main.cpp:225
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2010-01-30 10:12:24 UTC
Please upgrade to Amarok 2.2.2, see also http://kubuntu.org/news/amarok-2.2.2

*** This bug has been marked as a duplicate of bug 206579 ***