Bug 224669 - Copying files via smb with Dolphin
Summary: Copying files via smb with Dolphin
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-28 21:45 UTC by G.Willems
Modified: 2010-01-28 22:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description G.Willems 2010-01-28 21:45:17 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.30-2-686 i686
Distribution: Debian GNU/Linux testing (squeeze)

What I was doing when the application crashed:
Copying files via smb with Dolphin

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0xb6970019 in QUrl (this=0xbfcb0b28, other=...) at io/qurl.cpp:3936
#7  0xb75adc79 in KUrl (this=0xbfcb0b28, _u=...) at ../../kdecore/io/kurl.cpp:468
#8  0xb7f0d88e in KFileItem::url (this=0xbfcb0b34) at ../../kio/kio/kfileitem.cpp:1271
#9  0xb7ddbc12 in KFilePreviewGenerator::Private::updateIcons (this=0x99e3b98, topLeft=..., bottomRight=...) at ../../kfile/kfilepreviewgenerator.cpp:541
#10 0xb7ddc4b4 in KFilePreviewGenerator::qt_metacall (this=0x99e3a80, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfcb0c38) at ./kfilepreviewgenerator.moc:86
#11 0xb69d0303 in QMetaObject::activate (sender=0x99db710, from_signal_index=4, to_signal_index=4, argv=0xbfcb0c38) at kernel/qobject.cpp:3112
#12 0xb69d0f42 in QMetaObject::activate (sender=0x99db710, m=0xb6aac978, local_signal_index=0, argv=0xbfcb0c38) at kernel/qobject.cpp:3186
#13 0xb6a0af39 in QAbstractItemModel::dataChanged (this=0x99db710, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:126
#14 0xb7efacba in KDirModelPrivate::_k_slotRefreshItems (this=0x99daf48, items=...) at ../../kio/kio/kdirmodel.cpp:571
#15 0xb7efcb7d in KDirModel::qt_metacall (this=0x99db710, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfcb0e4c) at ./kdirmodel.moc:84
#16 0xb69d0303 in QMetaObject::activate (sender=0x99db640, from_signal_index=18, to_signal_index=18, argv=0xbfcb0e4c) at kernel/qobject.cpp:3112
#17 0xb69d0f42 in QMetaObject::activate (sender=0x99db640, m=0x80b5590, local_signal_index=14, argv=0xbfcb0e4c) at kernel/qobject.cpp:3186
#18 0xb7edf713 in KDirLister::refreshItems (this=0x99db640, _t1=...) at ./kdirlister.moc:296
#19 0xb7ee0829 in KDirLister::Private::emitItems (this=0x99db650) at ../../kio/kio/kdirlister.cpp:2317
#20 0xb7eed715 in KDirListerCache::slotUpdateResult (this=0x98b4d68, j=0x9d13910) at ../../kio/kio/kdirlister.cpp:1630
#21 0xb7ef2cd4 in KDirListerCache::qt_metacall (this=0x98b4d68, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfcb112c) at ./kdirlister_p.moc:102
#22 0xb69d0303 in QMetaObject::activate (sender=0x9d13910, from_signal_index=7, to_signal_index=7, argv=0xbfcb112c) at kernel/qobject.cpp:3112
#23 0xb69d0f42 in QMetaObject::activate (sender=0x9d13910, m=0x80b5580, local_signal_index=3, argv=0xbfcb112c) at kernel/qobject.cpp:3186
#24 0xb75b8a33 in KJob::result (this=0x9d13910, _t1=0x9d13910) at ./kjob.moc:188
#25 0xb75b8ed9 in KJob::emitResult (this=0x9d13910) at ../../kdecore/jobs/kjob.cpp:304
#26 0xb7ec3b15 in KIO::SimpleJob::slotFinished (this=0x9d13910) at ../../kio/kio/job.cpp:477
#27 0xb7ec40d4 in KIO::ListJob::slotFinished (this=0x9d13910) at ../../kio/kio/job.cpp:2408
#28 0xb7ec5b13 in KIO::ListJob::qt_metacall (this=0x9d13910, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfcb1318) at ./jobclasses.moc:764
#29 0xb69d0303 in QMetaObject::activate (sender=0x9db8fc8, from_signal_index=8, to_signal_index=8, argv=0x0) at kernel/qobject.cpp:3112
#30 0xb69d0f42 in QMetaObject::activate (sender=0x9db8fc8, m=0xb806ab84, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3186
#31 0xb7f89707 in KIO::SlaveInterface::finished (this=0x9db8fc8) at ./slaveinterface.moc:165
#32 0xb7f8d4b7 in KIO::SlaveInterface::dispatch (this=0x9db8fc8, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#33 0xb7f89be7 in KIO::SlaveInterface::dispatch (this=0x9db8fc8) at ../../kio/kio/slaveinterface.cpp:91
#34 0xb7f7bbcd in KIO::Slave::gotInput (this=0x9db8fc8) at ../../kio/kio/slave.cpp:322
#35 0xb7f7e0b3 in KIO::Slave::qt_metacall (this=0x9db8fc8, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfcb15e8) at ./slave.moc:76
#36 0xb69d0303 in QMetaObject::activate (sender=0x9db0068, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3112
#37 0xb69d0f42 in QMetaObject::activate (sender=0x9db0068, m=0xb80674c0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3186
#38 0xb7e87c07 in KIO::Connection::readyRead (this=0x9db0068) at ./connection.moc:86
#39 0xb7e89513 in KIO::ConnectionPrivate::dequeue (this=0x9c13c60) at ../../kio/kio/connection.cpp:82
#40 0xb7e898f6 in KIO::Connection::qt_metacall (this=0x9db0068, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x9cd16f0) at ./connection.moc:73
#41 0xb69c9b0b in QMetaCallEvent::placeMetaCall (this=0x97b0d60, object=0x9db0068) at kernel/qobject.cpp:477
#42 0xb69cb5e0 in QObject::event (this=0x9db0068, e=0x97b0d60) at kernel/qobject.cpp:1110
#43 0xb6bf2a94 in QApplicationPrivate::notify_helper (this=0x96c9fd8, receiver=0x9db0068, e=0x97b0d60) at kernel/qapplication.cpp:4065
#44 0xb6bfabee in QApplication::notify (this=0xbfcb1de4, receiver=0x9db0068, e=0x97b0d60) at kernel/qapplication.cpp:3605
#45 0xb78f462d in KApplication::notify (this=0xbfcb1de4, receiver=0x9db0068, event=0x97b0d60) at ../../kdeui/kernel/kapplication.cpp:302
#46 0xb69bb1eb in QCoreApplication::notifyInternal (this=0xbfcb1de4, receiver=0x9db0068, event=0x97b0d60) at kernel/qcoreapplication.cpp:610
#47 0xb69bbe2e in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x96ac1e8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#48 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x96ac1e8) at kernel/qcoreapplication.cpp:1247
#49 0xb69bc00d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#50 0xb69e64cf in QCoreApplication::sendPostedEvents (s=0x96cc110) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#51 postEventSourceDispatch (s=0x96cc110) at kernel/qeventdispatcher_glib.cpp:276
#52 0xb5feab38 in g_main_dispatch (context=0x96cc090) at /build/buildd-glib2.0_2.22.4-1-i386-jRfNZE/glib2.0-2.22.4/glib/gmain.c:1960
#53 IA__g_main_context_dispatch (context=0x96cc090) at /build/buildd-glib2.0_2.22.4-1-i386-jRfNZE/glib2.0-2.22.4/glib/gmain.c:2513
#54 0xb5fee3d0 in g_main_context_iterate (context=0x96cc090, block=<value optimized out>, dispatch=1, self=0x96c9298) at /build/buildd-glib2.0_2.22.4-1-i386-jRfNZE/glib2.0-2.22.4/glib/gmain.c:2591
#55 0xb5fee503 in IA__g_main_context_iteration (context=0x96cc090, may_block=1) at /build/buildd-glib2.0_2.22.4-1-i386-jRfNZE/glib2.0-2.22.4/glib/gmain.c:2654
#56 0xb69e6041 in QEventDispatcherGlib::processEvents (this=0x96abd28, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#57 0xb6c92305 in QGuiEventDispatcherGlib::processEvents (this=0x96abd28, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#58 0xb69b983a in QEventLoop::processEvents (this=0xbfcb1d70, flags=...) at kernel/qeventloop.cpp:149
#59 0xb69b9c82 in QEventLoop::exec (this=0xbfcb1d70, flags=...) at kernel/qeventloop.cpp:201
#60 0xb69bc0d9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#61 0xb6bf2917 in QApplication::exec () at kernel/qapplication.cpp:3525
#62 0x0807a945 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-28 22:02:26 UTC
Reported at bug 211525, fixed in KDE SC 4.4 and 4.3.5
Regards

*** This bug has been marked as a duplicate of bug 211525 ***