Bug 224657 - crash reported when usb memory connected to the computer
Summary: crash reported when usb memory connected to the computer
Status: RESOLVED DUPLICATE of bug 211401
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-28 20:28 UTC by Osman Kemal Kadiroglu
Modified: 2010-01-28 20:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Osman Kemal Kadiroglu 2010-01-28 20:28:31 UTC
Application that crashed: kded4
Version of the application: $Id: kded.cpp 944898 2009-03-26 13:01:25Z dfaure $
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I inserted usb memory stick and waited for Dolphine to start and I got a crash reportç

 -- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  QDataStream::operator>> (this=0x0, i=@0x7fff034ca8cc) at io/qdatastream.cpp:661
#6  0x00007f38b3b96fbf in KServiceFactory (this=0x17dc720) at ../../kdecore/services/kservicefactory.cpp:44
#7  0x00007f38b3b9729a in KSycocaFactorySingleton<KServiceFactory>::self () at ../../kdecore/sycoca/ksycocafactory.h:200
#8  KServiceFactory::self () at ../../kdecore/services/kservicefactory.cpp:75
#9  0x00007f38b3b8d1e9 in KService::serviceByDesktopPath (_name=...) at ../../kdecore/services/kservice.cpp:582
#10 0x00007f38a90d4130 in Kded::loadModule (this=0x1427100, obj=<value optimized out>, onDemand=true) at ../../kded/kded.cpp:333
#11 0x00007f38a90d43af in Kded::messageFilter (message=<value optimized out>) at ../../kded/kded.cpp:195
#12 0x00007f38b00ac15c in QDBusConnectionPrivate::handleMessage (this=<value optimized out>, amsg=...) at qdbusintegrator.cpp:526
#13 0x00007f38b00af8a8 in qDBusSignalFilter (connection=<value optimized out>, message=<value optimized out>, data=<value optimized out>) at qdbusintegrator.cpp:517
#14 0x00007f38a8e9b396 in dbus_connection_dispatch () from /lib/libdbus-1.so.3
#15 0x00007f38b009f3b5 in q_dbus_connection_dispatch (this=0x1438a50) at ./qdbus_symbols_p.h:113
#16 QDBusConnectionPrivate::doDispatch (this=0x1438a50) at qdbusintegrator.cpp:1067
#17 0x00007f38b009f4dd in QDBusConnectionPrivate::socketRead (this=0x1438a50, fd=5) at qdbusintegrator.cpp:1087
#18 0x00007f38b00df59b in QDBusConnectionPrivate::qt_metacall (this=0x1438a50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff034cae00)
    at .moc/release-shared/moc_qdbusconnection_p.cpp:89
#19 0x00007f38b403bddc in QMetaObject::activate (sender=0x15e7e60, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1608460) at kernel/qobject.cpp:3113
#20 0x00007f38b4071e9e in QSocketNotifier::activated (this=0x0, _t1=5) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#21 0x00007f38b4040773 in QSocketNotifier::event (this=0x15e7e60, e=0x7fff034cb340) at kernel/qsocketnotifier.cpp:316
#22 0x00007f38b1fd6efc in QApplicationPrivate::notify_helper (this=0x1427df0, receiver=0x15e7e60, e=0x7fff034cb340) at kernel/qapplication.cpp:4056
#23 0x00007f38b1fde1ce in QApplication::notify (this=0x7fff034cb650, receiver=0x15e7e60, e=0x7fff034cb340) at kernel/qapplication.cpp:4021
#24 0x00007f38b2c0dab6 in KApplication::notify (this=0x7fff034cb650, receiver=0x15e7e60, event=0x7fff034cb340) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f38b4026c2c in QCoreApplication::notifyInternal (this=0x7fff034cb650, receiver=0x15e7e60, event=0x7fff034cb340) at kernel/qcoreapplication.cpp:610
#26 0x00007f38b404f42a in QCoreApplication::sendEvent (source=0x1441fd0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 socketNotifierSourceDispatch (source=0x1441fd0) at kernel/qeventdispatcher_glib.cpp:110
#28 0x00007f38b0f07bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#29 0x00007f38b0f0b598 in ?? () from /lib/libglib-2.0.so.0
#30 0x00007f38b0f0b6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#31 0x00007f38b404f1a6 in QEventDispatcherGlib::processEvents (this=0x139e040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#32 0x00007f38b206b4be in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#33 0x00007f38b4025532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#34 0x00007f38b4025904 in QEventLoop::exec (this=0x7fff034cb5a0, flags=) at kernel/qeventloop.cpp:201
#35 0x00007f38b4027ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#36 0x00007f38a90d5ceb in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kded/kded.cpp:938
#37 0x0000000000406da8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a299 "0") at ../../kinit/kinit.cpp:677
#38 0x0000000000408cc0 in main (argc=<value optimized out>, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1740

Reported using DrKonqi
Comment 1 Christoph Feck 2010-01-28 20:57:27 UTC

*** This bug has been marked as a duplicate of bug 211401 ***