Bug 224191 - okular crashed when pressing "highlight" shortcuts ("5") on pdf file
Summary: okular crashed when pressing "highlight" shortcuts ("5") on pdf file
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 224357 225910 225915 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-25 18:11 UTC by Giacomo Poderi
Modified: 2010-02-20 18:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
pdf I was using during the crash (58.57 KB, application/force-download)
2010-01-26 18:41 UTC, Giacomo Poderi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giacomo Poderi 2010-01-25 18:11:48 UTC
Application that crashed: okular
Version of the application: 0.9.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I was reading, reviewing and 'editing' a pdf file.

I entered several edits (inline notes, notes, green pen, highlight) and refreshed/reloaded (F5) the document.
At a certain point, I tried to enter a new highlight and at the moment I pressed "5" (shortcut for highlight) okular crashed.

Regards,
gp

 -- Backtrace:
Application: Okular (okular), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f4e855208f6 in Okular::Annotation::Window::text() const () from /usr/lib/libokularcore.so.1
#6  0x00007f4e85818d08 in ?? () from /usr/lib/kde4/okularpart.so
#7  0x00007f4e85818e0c in ?? () from /usr/lib/kde4/okularpart.so
#8  0x00007f4e98044ddc in QMetaObject::activate (sender=0x142fcf0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x11fe526) at kernel/qobject.cpp:3113
#9  0x00007f4e978fbe57 in QTextEdit::qt_metacall (this=0x142fcf0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdc7e23e0) at .moc/release-shared/moc_qtextedit.cpp:189
#10 0x00007f4e98d3ad80 in KTextEdit::qt_metacall (this=0x7fffdc7e2100, _c=22106584, _id=65, _a=0x11fe526) at ./ktextedit.moc:106
#11 0x00007f4e98044ddc in QMetaObject::activate (sender=0x11d4ef0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x11fe526) at kernel/qobject.cpp:3113
#12 0x00007f4e976d45a2 in QTextControl::qt_metacall (this=0x11d4ef0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdc7e2550) at .moc/release-shared/moc_qtextcontrol_p.cpp:144
#13 0x00007f4e98044ddc in QMetaObject::activate (sender=0x11d4f10, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x11fe526) at kernel/qobject.cpp:3113
#14 0x00007f4e9770bdd1 in QTextDocumentPrivate::endEditBlock (this=0x12b1c20) at text/qtextdocument_p.cpp:1126
#15 0x00007f4e97733b31 in QTextCursor::insertText (this=0x142e900, text=<value optimized out>, _format=...) at text/qtextcursor.cpp:1336
#16 0x00007f4e97733d0f in QTextCursor::insertText (this=0x142e900, text=...) at text/qtextcursor.cpp:1275
#17 0x00007f4e976d67dd in QTextControlPrivate::keyPressEvent (this=0x142e870, e=0x7fffdc7e32a0) at text/qtextcontrol.cpp:1256
#18 0x00007f4e976d9fc8 in QTextControl::processEvent (this=0x11d4ef0, e=0x7fffdc7e32a0, matrix=..., contextWidget=0x148fd20) at text/qtextcontrol.cpp:904
#19 0x00007f4e976d01ca in QTextControl::processEvent (this=0x11d4ef0, e=0x7fffdc7e32a0, coordinateOffset=..., contextWidget=0x148fd20) at text/qtextcontrol.cpp:866
#20 0x00007f4e978fdbdc in QTextEditPrivate::sendControlEvent (this=0x1504aa0, e=0x7fffdc7e32a0) at widgets/qtextedit_p.h:100
#21 0x00007f4e978fd3c5 in QTextEdit::keyPressEvent (this=<value optimized out>, e=0x7fffdc7e32a0) at widgets/qtextedit.cpp:1278
#22 0x00007f4e97526872 in QWidget::event (this=0x142fcf0, event=0x7fffdc7e32a0) at kernel/qwidget.cpp:7584
#23 0x00007f4e978822a6 in QFrame::event (this=0x142fcf0, e=0x7fffdc7e32a0) at widgets/qframe.cpp:559
#24 0x00007f4e97911bc9 in QAbstractScrollArea::event (this=0x142fcf0, e=0x7fffdc7e32a0) at widgets/qabstractscrollarea.cpp:918
#25 0x00007f4e978fd4f5 in QTextEdit::event (this=0x142fcf0, e=0x7fffdc7e32a0) at widgets/qtextedit.cpp:1058
#26 0x00007f4e974d7efc in QApplicationPrivate::notify_helper (this=0xc7e1d0, receiver=0x142fcf0, e=0x7fffdc7e32a0) at kernel/qapplication.cpp:4056
#27 0x00007f4e974dfce3 in QApplication::notify (this=<value optimized out>, receiver=0x142fcf0, e=0x7fffdc7e32a0) at kernel/qapplication.cpp:3662
#28 0x00007f4e98c43ab6 in KApplication::notify (this=0x7fffdc7e5460, receiver=0x142fcf0, event=0x7fffdc7e32a0) at ../../kdeui/kernel/kapplication.cpp:302
#29 0x00007f4e9802fc2c in QCoreApplication::notifyInternal (this=0x7fffdc7e5460, receiver=0x142fcf0, event=0x7fffdc7e32a0) at kernel/qcoreapplication.cpp:610
#30 0x00007f4e97568dfa in QKeyMapper::sendKeyEvent (keyWidget=0x142fcf0, grab=<value optimized out>, type=QEvent::KeyPress, code=53, modifiers=<value optimized out>, text=..., autorepeat=false, 
    count=1, nativeScanCode=14, nativeVirtualKey=53, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#31 0x00007f4e9756b370 in QKeyMapperPrivate::translateKeyEvent (this=0xcb8d10, keyWidget=0x142fcf0, event=<value optimized out>, grab=216) at kernel/qkeymapper_x11.cpp:1831
#32 0x00007f4e97543493 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffdc7e5080) at kernel/qapplication_x11.cpp:3443
#33 0x00007f4e9756cd0c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#34 0x00007f4e938f4bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f4e938f8598 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f4e938f86c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f4e980581a6 in QEventDispatcherGlib::processEvents (this=0xc64d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#38 0x00007f4e9756c4be in QGuiEventDispatcherGlib::processEvents (this=0x7fffdc7e2100, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#39 0x00007f4e9802e532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f4e9802e904 in QEventLoop::exec (this=0x7fffdc7e53b0, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f4e98030ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#42 0x000000000040881c in _start ()

Reported using DrKonqi
Comment 1 Pino Toscano 2010-01-26 18:22:51 UTC
*** Bug 224357 has been marked as a duplicate of this bug. ***
Comment 2 Pino Toscano 2010-01-26 18:26:10 UTC
Please install the okular/kdegraphics debug symbols from your distro packages, so we can get clearer backtraces.
Also, does it happen with any PDF document, or just with some (related somehow?)?
Can you please the attach, if public, any of the "faulty" documents?
Comment 3 Giacomo Poderi 2010-01-26 18:41:59 UTC
Created attachment 40265 [details]
pdf I was using during the crash
Comment 4 Giacomo Poderi 2010-01-26 18:43:44 UTC
I attached the pdf I was working when I had the first crash. The one I was using during the second crash (in the duplicate bug) is not public.

I installed kdegraphics-dbg. Next time it happens I should have better information

Thanks,
gp
Comment 5 Pino Toscano 2010-02-08 15:09:37 UTC
*** Bug 225910 has been marked as a duplicate of this bug. ***
Comment 6 Pino Toscano 2010-02-08 15:09:53 UTC
*** Bug 225915 has been marked as a duplicate of this bug. ***
Comment 7 Albert Astals Cid 2010-02-20 18:08:21 UTC
SVN commit 1093331 by aacid:

Close annotation windows on document change/reload
BUGS: 224191


 M  +2 -0      pageview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1093331