Bug 223681 - Plasma Workspace crashed while renaming directory
Summary: Plasma Workspace crashed while renaming directory
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-21 15:09 UTC by Leonardo Pelisoli
Modified: 2010-01-21 22:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leonardo Pelisoli 2010-01-21 15:09:47 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I tried to rename a directory in my desktop and Plasma Workspace crashed. The directory was renamed correctly, though.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7fe3d0371750 (LWP 1775))]

Thread 2 (Thread 0x7fe3af287910 (LWP 1777)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007fe3cfdb14fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1fc14b8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1fc14b8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fe3cc1e878c in QHostInfoAgent::run (this=0x1fc14a0) at kernel/qhostinfo.cpp:260
#4  0x00007fe3cfdb0445 in QThreadPrivate::start (arg=0x1fc14a0) at thread/qthread_unix.cpp:188
#5  0x00007fe3ccb26a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007fe3cd70680d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe3d0371750 (LWP 1775)):
[KCrash Handler]
#5  0x00007fe3cefb9d03 in KFileItem::isDir (this=0x20637a0) at ../../kio/kio/kfileitem.cpp:969
#6  0x00007fe3cefa9198 in KDirModelPrivate::removeFromNodeHash (this=0x1dde380, node=0x20637a0, url=...) at ../../kio/kio/kdirmodel.cpp:200
#7  0x00007fe3cefaa0ab in KDirModelPrivate::_k_slotDeleteItems (this=0x1dde380, items=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:487
#8  0x00007fe3cefabb82 in KDirModel::qt_metacall (this=0x2eb0ca0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff807cbbf0) at ./kdirmodel.moc:83
#9  0x00007fe3cfeabddc in QMetaObject::activate (sender=0x2e382f0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#10 0x00007fe3cef8f895 in KDirLister::itemsDeleted (this=0x20637a0, _t1=<value optimized out>) at ./kdirlister.moc:289
#11 0x00007fe3cef905d1 in KDirLister::Private::emitItemsDeleted (this=0x2c456c0, _items=<value optimized out>) at ../../kio/kio/kdirlister.cpp:2351
#12 0x00007fe3cef9f57e in KDirListerCache::itemsDeleted (this=0x1e4c140, listers=<value optimized out>, deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#13 0x00007fe3cefa0fca in KDirListerCache::slotFilesRemoved (this=0x1e4c140, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:808
#14 0x00007fe3cefa1454 in KDirListerCache::slotFilesRemoved (this=0x1e4c140, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:763
#15 0x00007fe3cefa1db0 in KDirListerCache::qt_metacall (this=0x1e4c140, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff807cc070) at ./kdirlister_p.moc:92
#16 0x00007fe3cfeabddc in QMetaObject::activate (sender=0x1e6fb80, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#17 0x00007fe3cefad115 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x20637a0, _t1=<value optimized out>) at ./kdirnotify.moc:125
#18 0x00007fe3cefad290 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x1e6fb80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff807cc330) at ./kdirnotify.moc:83
#19 0x00007fe3cbf19ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#20 0x00007fe3cbf20def in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#21 0x00007fe3cfea60f9 in QObject::event (this=0x1e6fb80, e=0x2e51570) at kernel/qobject.cpp:1111
#22 0x00007fe3cde46efc in QApplicationPrivate::notify_helper (this=0x182bd50, receiver=0x1e6fb80, e=0x2e51570) at kernel/qapplication.cpp:4056
#23 0x00007fe3cde4e1ce in QApplication::notify (this=0x1822780, receiver=0x1e6fb80, e=0x2e51570) at kernel/qapplication.cpp:4021
#24 0x00007fe3cea7dab6 in KApplication::notify (this=0x1822780, receiver=0x1e6fb80, event=0x2e51570) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007fe3cfe96c2c in QCoreApplication::notifyInternal (this=0x1822780, receiver=0x1e6fb80, event=0x2e51570) at kernel/qcoreapplication.cpp:610
#26 0x00007fe3cfe9780a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x179c4d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x179c4d0) at kernel/qcoreapplication.cpp:1247
#28 0x00007fe3cfebf533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#30 0x00007fe3ccd77bce in g_main_dispatch (context=0x182e520) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#31 IA__g_main_context_dispatch (context=0x182e520) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#32 0x00007fe3ccd7b598 in g_main_context_iterate (context=0x182e520, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#33 0x00007fe3ccd7b6c0 in IA__g_main_context_iteration (context=0x182e520, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#34 0x00007fe3cfebf1a6 in QEventDispatcherGlib::processEvents (this=0x179f040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#35 0x00007fe3cdedb4be in QGuiEventDispatcherGlib::processEvents (this=0x20637a0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#36 0x00007fe3cfe95532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#37 0x00007fe3cfe95904 in QEventLoop::exec (this=0x7fff807ccc20, flags=) at kernel/qeventloop.cpp:201
#38 0x00007fe3cfe97ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0x00007fe3c42184cf in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#40 0x0000000000406da8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a299 "0") at ../../kinit/kinit.cpp:677
#41 0x0000000000407aa0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#42 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#43 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 213851

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-21 22:35:16 UTC
This is being tracked at bug 196695. Thanks

*** This bug has been marked as a duplicate of bug 196695 ***