Bug 223618 - digikam should display images in full resolution on light table or when zooming in
Summary: digikam should display images in full resolution on light table or when zoomi...
Status: RESOLVED DUPLICATE of bug 146260
Alias: None
Product: digikam
Classification: Unclassified
Component: LightTable-Canvas (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-20 20:40 UTC by Simon
Modified: 2022-02-01 09:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Example image. Image Editor and Light Table. Same zoom rate. (188.53 KB, image/jpeg)
2010-01-20 20:40 UTC, Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon 2010-01-20 20:40:13 UTC
Version:           1.1.0 (rev.: 1066990) (using 4.3.4 (KDE 4.3.4), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.32-4.slh.2-sidux-686

Especially for big files. I was just a little bit confused when zooming in to the image on the light table after, amongst other things, sharpening it with GIMP: The difference was that it was even less sharp. Until I realized that this was because the image wasn't displayed in full resolution.

Isn't it possible to load the full resolution images when zooming in? I can live with the fact that images don't look sharp in the viewer, but when zooming I'd like to see every detail.

Simon
Comment 1 Simon 2010-01-20 20:40:53 UTC
Created attachment 40079 [details]
Example image. Image Editor and Light Table. Same zoom rate.
Comment 2 Johannes Wienke 2010-01-20 20:48:12 UTC
Did you enable "Load full-sized" image in the light table options?
Comment 3 Simon 2010-01-20 21:50:16 UTC
Ah, indeed. Better now. (But do you expect an average user to find that?)

How about loading the full sized image in background after the not-full-sized image has been loaded, and display it as soon as available? 

Could perhaps even be made smart. Like don't load it as long as more than 2 different files have been displayed in the past 3 seconds. To avoid too high traffic.
Comment 4 Johannes Wienke 2010-01-20 22:00:41 UTC
I'm merging this with an older bug requesting the same behaviour.

*** This bug has been marked as a duplicate of bug 146260 ***