Bug 223552 - Kontact crashes when Akregator is selected
Summary: Kontact crashes when Akregator is selected
Status: RESOLVED DUPLICATE of bug 116482
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-20 11:12 UTC by FranJPR
Modified: 2010-03-28 03:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FranJPR 2010-01-20 11:12:11 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When Kontact is opened, I turn from kmail to akregator and kontact crashes generating the following backtrace. However, kontact crashes when kubuntu is shutting down or starting up, since a few days ago. I do not know whether it depends on the number of feeds akregator was handling.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00d50071 in memcpy () from /lib/tls/i686/cmov/libc.so.6
#7  0x032379c6 in ?? () from /usr/lib/kde4/akregator_mk4storage_plugin.so
#8  0x0322e590 in ?? () from /usr/lib/kde4/akregator_mk4storage_plugin.so
#9  0x03231f0e in ?? () from /usr/lib/kde4/akregator_mk4storage_plugin.so
#10 0x03236f2a in ?? () from /usr/lib/kde4/akregator_mk4storage_plugin.so
#11 0x032428e5 in ?? () from /usr/lib/kde4/akregator_mk4storage_plugin.so
#12 0x0324558e in ?? () from /usr/lib/kde4/akregator_mk4storage_plugin.so
#13 0x03245b9b in ?? () from /usr/lib/kde4/akregator_mk4storage_plugin.so
#14 0x031598c8 in Akregator::Feed::loadArticles() () from /usr/lib/kde4/akregatorpart.so
#15 0x0315d743 in Akregator::Feed::fromOPML(QDomElement, Akregator::Backend::Storage*) () from /usr/lib/kde4/akregatorpart.so
#16 0x03168b1d in Akregator::FeedList::parseChildNodes(QDomNode&, Akregator::Folder*) () from /usr/lib/kde4/akregatorpart.so
#17 0x03168d2e in Akregator::FeedList::parseChildNodes(QDomNode&, Akregator::Folder*) () from /usr/lib/kde4/akregatorpart.so
#18 0x0316a51c in Akregator::FeedList::readFromOpml(QDomDocument const&) () from /usr/lib/kde4/akregatorpart.so
#19 0x031aed08 in ?? () from /usr/lib/kde4/akregatorpart.so
#20 0x031af84a in ?? () from /usr/lib/kde4/akregatorpart.so
#21 0x031afc83 in ?? () from /usr/lib/kde4/akregatorpart.so
#22 0x005c6263 in QMetaObject::activate (sender=0x9a69098, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#23 0x005c6ec2 in QMetaObject::activate (sender=0x9a69098, m=0x6a0908, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#24 0x005cb387 in QSingleShotTimer::timeout (this=0x9a69098) at .moc/release-shared/qtimer.moc:76
#25 0x005cb49c in QSingleShotTimer::timerEvent (this=0x9a69098) at kernel/qtimer.cpp:298
#26 0x005c03bf in QObject::event (this=0x9a69098, e=0xbfd3afa0) at kernel/qobject.cpp:1075
#27 0x010aaf54 in QApplicationPrivate::notify_helper (this=0x8b4a620, receiver=0x9a69098, e=0xbfd3afa0) at kernel/qapplication.cpp:4056
#28 0x010b267c in QApplication::notify (this=0xbfd3b304, receiver=0x9a69098, e=0xbfd3afa0) at kernel/qapplication.cpp:3603
#29 0x00b1bbfa in KApplication::notify (this=0xbfd3b304, receiver=0x9a69098, event=0xbfd3afa0) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x005b06cb in QCoreApplication::notifyInternal (this=0xbfd3b304, receiver=0x9a69098, event=0xbfd3afa0) at kernel/qcoreapplication.cpp:610
#31 0x005dd7ce in QCoreApplication::sendEvent (this=0x8b416a4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#32 QTimerInfoList::activateTimers (this=0x8b416a4) at kernel/qeventdispatcher_unix.cpp:572
#33 0x005db0e0 in timerSourceDispatch (source=0x8b41670) at kernel/qeventdispatcher_glib.cpp:165
#34 0x058dfe88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x058e3730 in ?? () from /lib/libglib-2.0.so.0
#36 0x058e3863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x005db02c in QEventDispatcherGlib::processEvents (this=0x8b209f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#38 0x0114bbe5 in QGuiEventDispatcherGlib::processEvents (this=0x8b209f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#39 0x005aec79 in QEventLoop::processEvents (this=0xbfd3b264, flags=) at kernel/qeventloop.cpp:149
#40 0x005af0ca in QEventLoop::exec (this=0xbfd3b264, flags=...) at kernel/qeventloop.cpp:201
#41 0x005b153f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#42 0x010aadd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#43 0x0804b4e6 in _start ()

Reported using DrKonqi
Comment 1 Christophe Marin 2010-03-28 03:01:17 UTC

*** This bug has been marked as a duplicate of bug 116482 ***