Bug 223376 - Holding down shift and selecting works for only two items
Summary: Holding down shift and selecting works for only two items
Status: RESOLVED DUPLICATE of bug 217447
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-19 06:03 UTC by Joe Biden
Modified: 2010-01-19 13:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Biden 2010-01-19 06:03:44 UTC
Version:           1.4 (using 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1)), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.32.2

Either I am doing something wrong, or this is a simple regression because this would show up under any testing at all, and I am sure that I have selected files this way before in other version.

To reproduce:
Click on any file in details mode
Shift-select (with arrow key) any adjacent file, then continue holding down the arrow key. Only two files will remain selected as the arrow moves you down the list. Obviously, it should keep the first selection and add to it. I've twice-checked that this is happening. Long live Dolphin.
Comment 1 Jakob Lehmann 2010-01-19 06:09:49 UTC
Works fine for me, using KDE SC 4.3.90 too.
Comment 2 Joe Biden 2010-01-19 06:28:44 UTC
Make sure they are files, in details mode, not directories.

I have previews turned on.

Interesting, I have two dolphin tabs open, and it has the bug in one, but not the other....

Facts:
If I start holding down shift and down-arrow selecting and I start on a directory, it doesn't trigger the bug in the tab that shows the bug.

This is driving me insane. It only seems to happen under certain circumstances. Shift-down-select on the M's shows the bug, but not on directories or the A's in a directory with a thousand files.
Comment 3 Jakob Lehmann 2010-01-19 06:41:34 UTC
I'm sorry I'm still unable to reproduce this.
Comment 4 Frank Reininghaus 2010-01-19 13:42:32 UTC
This has been fixed recently.

(In reply to comment #2)
> This is driving me insane. It only seems to happen under certain circumstances.
> Shift-down-select on the M's shows the bug, but not on directories or the A's
> in a directory with a thousand files.

The width of the item name determines if the issue occurs or not.

*** This bug has been marked as a duplicate of bug 217447 ***