Bug 223342 - Re-Mounting Drive Does Not Refresh File Listing
Summary: Re-Mounting Drive Does Not Refresh File Listing
Status: RESOLVED DUPLICATE of bug 161385
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-18 23:24 UTC by d.account
Modified: 2010-01-19 13:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description d.account 2010-01-18 23:24:53 UTC
Version:           1.3 (using KDE 4.3.1)
OS:                Linux
Installed from:    openSUSE RPMs

Repeatability: Always

When re-mounting a removable drive using the drive icon, the file listing panel does not refresh.

Dolphin setup with Places panel and Details file listing.

Steps to reproduce (using USB flash drive):

1) Click on USB icon in Places panel to mount.  File listing is shown.

2) Click on USB icon in Places panel and unmount.  File listing becomes blank. Keep focus on USB icon.

3) Click on USB icon in Places panel and re-mount.  File listing remains blank. 

Clicking Reload or selecting a different place then re-selecting USB icon will bring up proper file listing.

This also occurs when removing the flash drive (USB icon disappears) and inserting flash drive (USB icon reappears and resumes focus).  Probably will occur when inserting second (different) flash drive.

Expected Action:

The file listing panel should automatically refresh when mounting drive.
Comment 1 Frank Reininghaus 2010-01-19 13:46:48 UTC
Thanks for the bug report! This issue is known already.

*** This bug has been marked as a duplicate of bug 161385 ***