Bug 223239 - crash dolphin pendrive unmount
Summary: crash dolphin pendrive unmount
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-18 05:17 UTC by Pasto
Modified: 2010-01-18 12:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pasto 2010-01-18 05:17:00 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-18-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I had just copyed some file to my usb memory and then I unpluged it after unmounting it when dolphin just crashed

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f51f17ea750 (LWP 3166))]

Thread 2 (Thread 0x7f51d967b910 (LWP 3175)):
#0  0x00007f51e9a9682d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f51ddc23da1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f51e9a91a04 in start_thread () from /lib/libpthread.so.0
#3  0x00007f51edae080d in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f51f17ea750 (LWP 3166)):
[KCrash Handler]
#5  0x00007f51ee17b720 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#6  0x00007f51ef3ca339 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#7  0x00007f51f1276ec0 in KFileItem::url() const () from /usr/lib/libkio.so.5
#8  0x00007f51f12676e4 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#9  0x00007f51f0f0b960 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#10 0x00007f51f0f0f662 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#11 0x00007f51f0f0f8bf in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#12 0x00007f51f0f10935 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#13 0x00007f51ee1d9ddc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#14 0x00007f51ee1d3d83 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x00007f51ee657efc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007f51ee65f1ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007f51ef990e56 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0x00007f51ee1c4c2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x00007f51ee1ef862 in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007f51ee1ed25d in ?? () from /usr/lib/libQtCore.so.4
#21 0x00007f51e9ce2bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00007f51e9ce6598 in ?? () from /lib/libglib-2.0.so.0
#23 0x00007f51e9ce66c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x00007f51ee1ed1a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x00007f51ee6ec4be in ?? () from /usr/lib/libQtGui.so.4
#26 0x00007f51ee1c3532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007f51ee1c3904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007f51ee1c5ab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0x00000000004394e5 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-18 12:27:33 UTC
This fixed in KDE SC 4.3.5 and 4.4.0. Regards

*** This bug has been marked as a duplicate of bug 211525 ***