Bug 222854 - add stop/pause buttons to kget job in plasma notification area
Summary: add stop/pause buttons to kget job in plasma notification area
Status: RESOLVED FIXED
Alias: None
Product: kget
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KGet authors
URL:
Keywords:
: 242092 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-15 15:49 UTC by anton
Modified: 2011-02-09 22:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description anton 2010-01-15 15:49:16 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

For kget plasma notification area integration - add stop/pause/resume buttons to kget job in plasma notification area - like dolphin file copy has.

For "overall progress" option enabled this pause/resume would affect all downloads, for "show every single dowload" this would control each download separately.
Comment 1 Matthias Fuchs 2010-06-20 02:44:45 UTC
*** Bug 242092 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Fuchs 2011-02-09 22:48:45 UTC
SVN commit 1219638 by mfuchs:

Adds a pause/stop button to singe job trackers. The global job tracker has only the stop button.
BUG:222854

 M  +1 -1      kgetglobaljob.cpp  
 M  +17 -0     kgetkjobadapter.cpp  
 M  +4 -0      kgetkjobadapter.h  
 M  +27 -4     kuiserverjobs.cpp  
 M  +3 -0      kuiserverjobs.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1219638