Bug 222687 - Nepomuk search in Dolphin doesn't work
Summary: Nepomuk search in Dolphin doesn't work
Status: RESOLVED DUPLICATE of bug 220072
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 221540 222685 226549 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-14 12:12 UTC by Tom Kijas
Modified: 2010-03-22 20:19 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Kijas 2010-01-14 12:12:38 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

When I put some name of file I wanna to search in dolphin, it shows me just "Didn't find any files" in the bottom of Dolphin window. In Adress bar in Dolphin I have then 

nepomuksearch:/?sparql=select distinct ?r  where { { { ?r ?v1 ?v2 . ?v2 bif:contains "'banik*'" . } UNION { ?r ?v1 ?v3 . ?v3 ?v4 ?v2 . ?v4 <http://www.w3.org/2000/01/rdf-schema#subPropertyOf> <http://www.w3.org/2000/01/rdf-schema#label> . ?v2 bif:contains "'banik*'" . } . { ?r a ?v5 . ?v5 <http://www.w3.org/2000/01/rdf-schema#subClassOf> <http://www.semanticdesktop.org/ontologies/2007/03/22/nfo#FileDataObject> . } UNION { ?r a ?v6 . ?v6 <http://www.w3.org/2000/01/rdf-schema#subClassOf> <http://www.semanticdesktop.org/ontologies/2007/03/22/nfo#Folder> . } . } .    }

(I searched term Banik (filename)). When I try to delete this adress and have just nepomuksearch:/banik it works.
The problem I think is in the outrageously long adress, when is there just this short-one, it works perfectely. Please correct me if I am wrong.
Thanks
Comment 1 Mathieu Tournier 2010-01-17 13:53:11 UTC
I have exactly the same problem with kde 4.4 RC1 using kubuntu packages
Comment 2 Peter Penz 2010-01-18 14:40:31 UTC
Thanks for the report, but I cannot reproduce the issue: No matter whether I use nepomuksearch:/xxx or type xxx into the search field, I get exactly the same number of results....

I've added Sebastian Trüg (= nepomuk maintainer) to CC, maybe he has a hint.
Comment 3 Peter Penz 2010-01-18 14:41:37 UTC
*** Bug 222685 has been marked as a duplicate of this bug. ***
Comment 4 Marcus Harrison 2010-01-18 15:41:32 UTC
Is there a particular reason the short URL won't suffice for that search bar?
Comment 5 Sebastian Trueg 2010-01-18 15:55:21 UTC
Internally it does the exact same thing. RC1 still has some issues I fixed last week. Now queries should work properly using both sparql directly or the simple plain queries.
Any chance you could confirm that with a recent snapshot?
Comment 6 Sebastian Trueg 2010-01-25 21:57:46 UTC
Any problems left with RC2?
Comment 7 Marcus Harrison 2010-01-25 22:09:19 UTC
Sorry, no dice with Kubuntu. Should I try clearing Nepomuk's store?
Comment 8 Alexander 2010-01-26 10:39:03 UTC
I have no success with it too in Kubuntu 9.10. Just upgraded it to 4.3.95.
Comment 9 Sebastian Trueg 2010-01-26 10:48:32 UTC
Please issue
sopranocmd --model main --dbus org.kde.NepomukStorage list "rdfs:label"
and rell me the output.
Also please check which version of redland (aka librdf) you have installed.
Comment 10 Alvaro Manuel Recio Perez 2010-01-26 12:27:53 UTC
I'm not the original reporter but I experience the same bug, also with KDE SC RC2 from Kubuntu.

The output of the command Sebastian suggested is *really* long. I'm dumping it to a file and it's already over 50 MBs. I think the versión of redland is 1.0.9 (1.0.9-2 in the package manager).

Hope it helps. Can I provide any additional information?

P.S.: The output of the previous command is now over 200 Mbs...
Comment 11 Alvaro Manuel Recio Perez 2010-01-26 12:29:57 UTC
Well, the output size was finally 212,8 Mb.s and it wrote this at the end:

Total results: 211644
Execution time: 00:00:00.3
Comment 12 Sebastian Trueg 2010-01-26 13:19:49 UTC
Right. That means that importing the ontologies fails. This is due to the buggy redland 1.0.9. Please update to 1.0.10 or downgrade to 1.0.8, restart Nepomuk. and see if that solves the problem.
Comment 13 Alvaro Manuel Recio Perez 2010-01-26 13:51:06 UTC
I (think I) updated to redland 1.0.10 by installing the following packages from the Lucid repository (I'm using Karmic):

libdb4.8_4.8.24-1ubuntu1_amd64.deb  librdf0_1.0.10-1_amd64.deb
librasqal2_0.9.17-1_amd64.deb       redland-utils_1.0.10-1_amd64.deb

I've restarted my computer and tried to use the Dolphin search again but still I'm not getting results. I'll see if I can downgrade to 1.0.8 and I'll try again.

Anyway, is there any way to know if the ontologies have been imported correctly? Should I delete the Nepomuk repository and try again?
Comment 14 Sebastian Trueg 2010-01-26 14:37:14 UTC
actually I think i just found the bug. A patch can be found here to test: http://pastebin.ca/1766503
it needs to be applied in kdebase/runtime/nepomuk/services/ontologyloader
Comment 15 Sebastian Trueg 2010-01-26 14:38:41 UTC
*** Bug 221540 has been marked as a duplicate of this bug. ***
Comment 16 Sebastian Trueg 2010-01-26 14:43:08 UTC
These query problems all seem to be related to the same bug in the nepomuk ontologyloader.

*** This bug has been marked as a duplicate of bug 220072 ***
Comment 17 Marco Carrai 2010-01-26 18:44:23 UTC
I see the patch has been provided on the 26 so it wasn't included into RC2, will it be included in Final?
Comment 18 Sebastian Trueg 2010-01-27 09:41:57 UTC
@Mar91: Yes, the patch will be in KDE 4.4 SC final.
Comment 19 Alvaro Manuel Recio Perez 2010-02-11 14:02:40 UTC
Sorry to bring this bug back to life but I still get no results from searches in Dolphin, with the same symptoms as originally reported. I'm now using the final Kubuntu KDE SC 4.4 packages with a freshly created Nepomuk database.

Strangely, KRunner SOMETIMES does offer search results from Nepomuk but trying to opening them shows an error. Could this be a Kubuntu only problem?
Comment 20 Marco Carrai 2010-02-11 14:50:17 UTC
Ask kubuntu packager if they've updated shared-desktop-ontologies. The bug was located tehre :)
Comment 21 Alvaro Manuel Recio Perez 2010-02-11 20:18:40 UTC
Just in case someone finds this useful: shared-desktop-ontologies is NOT installed by default by Kubuntu. At least, I didn't have it installed.

After manually installing the package (and playing around with the config directories of Nepomuk, but that may not be necessary) Nepomuk search in Dolphin works.

Thanks for your tip, Mar91!
Comment 22 joker77753 2010-02-12 10:32:53 UTC
Hello Alvaro

What kind of playing did you with the config directories of Nepomuk?
I installed the package shared-desktop-ontologies and the only change was that the progressbar in dolphin doesn't stop immediately in fact it continous "progressing" and doesn't stop at all but no search search result is shown.
Comment 23 Alvaro Manuel Recio Perez 2010-02-12 10:55:16 UTC
I was having other problems so I'm not totally sure of all I did. I think I renamed my .kde directory and started with a fresh configuration. Then I followed this instructions: http://socceroosd.blogspot.com/2010/02/kubuntu-karmic-kde-44-and-nepomuk.html. And finally, I think I returned to my old configuration but deleted my Nepomuk repostitory (~/.kde/share/apps/nepomuk/repository) and Akonadi configuration(~/.local/share/akonadi).

Anyway, I tried in other machine and I only needed to install shared-destkop-ontologies to get it to work. I think the fact you can see the progress bar is a sign that it's working. Make sure you have activated Nepomuk and Strigi in System Settings and that some files have been scanned. You can also try searching for "Title:<filename>" to try to locate some known file.

Good luck!.
Comment 24 Dario Andres 2010-03-20 16:01:22 UTC
@Sebastian: should this bug be reopened ? bug 226549 is about KDE SC 4.4.0 (or was the bug in a different place/library ?) 
Regards
Comment 25 Sebastian Trueg 2010-03-22 12:31:43 UTC
@Dario: why should it be reopened? Wasn't it just a Kubuntu installation problem?
Comment 26 Sebastian Trueg 2010-03-22 12:32:35 UTC
*** Bug 226549 has been marked as a duplicate of this bug. ***
Comment 27 Dario Andres 2010-03-22 18:47:45 UTC
*** Bug 231799 has been marked as a duplicate of this bug. ***
Comment 28 Ferdinand Thommes 2010-03-22 20:19:06 UTC
Hi, 
i just reopened  231799 as i believe it is a new bug.
unfortulately i did the exclude CCs the wrong way around, so you got excluded 
instead the others. sorry, this didnt happen on purpose. just wanted to let you 
know.

regards
ferdi


Am Montag 22 März 2010 18:47:46 schrieb Dario Andres:
> https://bugs.kde.org/show_bug.cgi?id=222687
> 
> 
> Dario Andres <andresbajotierra@gmail.com> changed:
> 
>            What    |Removed                     |Added
> ---------------------------------------------------------------------------
> - CC|                            |devil@sidux.com
> 
> 
> 
> 
> --- Comment #27 from Dario Andres <andresbajotierra gmail com>  2010-03-22
> 18:47:45 --- *** Bug 231799 has been marked as a duplicate of this bug.
> ***