Bug 222307 - sellecting files/folders on samba share - crash
Summary: sellecting files/folders on samba share - crash
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-12 00:09 UTC by Landis
Modified: 2010-01-12 18:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Landis 2010-01-12 00:09:58 UTC
Application that crashed: konqueror
Version of the application: 4.3.4 (KDE 4.3.4) "release 2"
KDE Version: 4.3.4 (KDE 4.3.4) "release 2"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.8-0.1-default i686
Distribution: "openSUSE 11.2 (i586)"

What I was doing when the application crashed:
it crashed while sellecting mulitipul folders / files on a ms winxp share. I had been back and forth between directories on the share and local..

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0xb76051f8 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0xb733bbfa in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0xb6f544ef in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0xb6f41d92 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0xb1c708a8 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0xb1c74680 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0xb1c748e7 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0xb1c75a9f in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0xb7669864 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0xb766a585 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0xb76a5715 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0xb766f196 in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0xb766351b in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb61f18fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb61f934e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb6c30451 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb765332e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb7682356 in ?? () from /usr/lib/libQtCore.so.4
#24 0xb767f325 in ?? () from /usr/lib/libQtCore.so.4
#25 0xb5dcc4c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0xb5dcfd98 in ?? () from /usr/lib/libglib-2.0.so.0
#27 0xb5dcfebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#28 0xb767f011 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0xb629329a in ?? () from /usr/lib/libQtGui.so.4
#30 0xb765198d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0xb7651dd9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0xb7654270 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0xb61f1774 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0xb4164b63 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#35 0x0804e147 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-01-12 18:35:27 UTC
Thanks for the bug report! This crash is be fixed in KDE SC 4.4.

*** This bug has been marked as a duplicate of bug 211525 ***