Bug 222295 - KPluginSelector in Amaron config dialog visually broken and causing 100% CPU usage
Summary: KPluginSelector in Amaron config dialog visually broken and causing 100% CPU ...
Status: RESOLVED DUPLICATE of bug 213068
Alias: None
Product: Oxygen
Classification: Plasma
Component: style (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-11 22:26 UTC by Eike Hein
Modified: 2010-01-12 01:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Broken KPluginSelector (36.02 KB, image/jpeg)
2010-01-11 22:26 UTC, Eike Hein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eike Hein 2010-01-11 22:26:55 UTC
Created attachment 39789 [details]
Broken KPluginSelector

When opening the "Internet Services" page of Amarok's configuration dialog, which prominently displays a KPluginSelector widget, the visual result is completely borked (see attached screenshot) and the app goes into a 100% CPU usage loop and stops reacting to clicks.

The Amarok version used is current git, which should be equivalent to the current Amarok 2.2.2. KDE is 4.4rc1.

The problem goes away when Amarok is run with "--style plastique".

At the same time, the KPluginSelector in the Desktop Effects KCM is fine, however.
Comment 1 Eike Hein 2010-01-11 22:28:17 UTC
Oh, and: Qt is 4.6.0.
Comment 2 Eike Hein 2010-01-11 22:46:29 UTC
The same happens with QtCurve. Maybe KStyle is the culprit?
Comment 3 Christoph Feck 2010-01-12 01:20:09 UTC

*** This bug has been marked as a duplicate of bug 213068 ***