Bug 222222 - UTF-8 email texts are not sent as UTF-8
Summary: UTF-8 email texts are not sent as UTF-8
Status: CLOSED FIXED
Alias: None
Product: kalarm
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Jarvie
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-11 14:55 UTC by David Jarvie
Modified: 2011-05-17 16:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: KDE 4.3.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Jarvie 2010-01-11 14:55:35 UTC
Version:            (using Devel)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Compiled sources

KAlarm should send email messages with
Content-Type: text/plain; charset=UTF-8?

The problem is, KAlarm's email comes in illegible form, like this:
теÑÑ‚ Ñ Ñ…ÐŸÑ‚ÐµÐ» пПпрПбПвать

See http://forum.kde.org/viewtopic.php?f=20&t=84406&p=140550&hilit=kalarm#p140550

This would apply to both subject and message body.
Comment 1 David Jarvie 2010-01-21 02:46:57 UTC
Fixed for transmission via KMail, for KDE 4.3.5 and KDE 4.4 (SVN commits 1077865, 1077870). I'm still looking into a fix for transmission via sendmail.
Comment 2 David Jarvie 2010-01-22 01:23:39 UTC
Now fixed also for sendmail, and for copying emails into KMail's sent-mail folder (SVN commits 1078244, 1078258, 1078260, 1078263). The full fix is in KDE 4.3.5 and KDE 4.4.