Bug 222170 - kmail freezes when displaying mails where my address is in the "from" header
Summary: kmail freezes when displaying mails where my address is in the "from" header
Status: RESOLVED DUPLICATE of bug 219687
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-11 05:07 UTC by Skander Morgenthaler
Modified: 2010-01-11 19:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Skander Morgenthaler 2010-01-11 05:07:32 UTC
Version:           1.13.0 (KDE SC 4.4rc1) (using Devel)
Compiler:          gcc 4.4.2 (Gentoo 4.4.2 p1.0) Target: x86_64-pc-linux-gnu
OS:                Linux
Installed from:    Compiled sources

I do not know if this bug relates to kmail, akonadi or nepomuk - since it is triggered from and freezes kmail, I filed it under kmail.

When clicking on a mail which has one of my mail addresses in the from header, kmail (at least parts of it) freeze and nepomuk runs amok.

This is a regression from KDE SC 4.3.4, kmail was working as expected before. It was even worse with 4.4beta2 though.

Reproducible: always 
Steps to reproduce:
- click on a mail that has one of your mail addresses in the from header (e.g. in the draft folder, sent-mail folder or in a folder containing a mailing list)
- stare at kmail or htop or something else ;)

What happens:
- the kmail (or kontact) window does not react to mouse and keyboard input anymore (for a while at least), mails are still collected and filtered, the unread count for folders still updated (the windowmanager-parts of the window also respond)
- nepomuk runs amok (requesting more memory fast (about 9MB per second, rising to 500MB if not killed), using about 60-70% of a phenomII-940 core while doing so)
- with kde sc 4.4beta2 kmail / kontact had to be killed & restarted in order to be used again, now it usually responds again after a while

what should happen:
-kmail displays the mail instantly
-kmail ui does not freeze
-nepomuk does not increase memory usage and cpu utilization

used software:
qt: 4.6.0
kde sc: 4.4rc1 (with 4.4beta2 it was even worse)
os: gentoo linux (~amd64)

unaffected:
kde sc 4.3.4 (with same version of qt)

If there is more information / testing that I can provide, please let me know.
Comment 1 Thomas McGuire 2010-01-11 17:00:12 UTC
Same basic problem as bug 219687.
However, in your case, I suspect a misconfigured Akoandi/Nepomuk, check that "akonadictl status" says it is using Virtuoso as backend.

*** This bug has been marked as a duplicate of bug 219687 ***
Comment 2 René Krell 2010-01-11 19:22:50 UTC
akonadictl status shows for me:
Akonadi Control: running
Akonadi Server: running
Akonadi Server Search Support: available (backend: Virtuoso)

I'm at KDE 4.4 RC1 now. Sending a single small mail takes minimum 20 - 30 seconds.

My hardware:
Processor (CPU): Intel(R) Pentium(R) D CPU 3.00GHz
Speed:  3,000.00 MHz
Cores:  2
Total memory (RAM): 1.8 GiB
This is not a hardware I would expect such a delay from.

In KDE 4.3.X this problem didn't exist.
I have done a straight upgrade on them using the OpenSUSE 11.2 KDE4 Desktop Factory packages.