Bug 221873 - Problem with KDE programs over gnome
Summary: Problem with KDE programs over gnome
Status: RESOLVED DUPLICATE of bug 202871
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-09 03:30 UTC by Víctor Nieto
Modified: 2010-01-09 14:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Víctor Nieto 2010-01-09 03:30:01 UTC
Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When I open a kde programs (kolourPaint, Amarok) over gnome at start (amarok) make this error or before close (kolourPaint) also make it

 -- Backtrace:
Application: KBuildSycoca (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KSycocaEntry::offset (this=0x0) at ../../kdecore/sycoca/ksycocaentry.cpp:133
#6  0x00007fae8c8ba5dd in KBuildMimeTypeFactory::savePatternLists (this=0x10754a0, str=<value optimized out>) at ../../kded/kbuildmimetypefactory.cpp:361
#7  0x00007fae8c8baa93 in KBuildMimeTypeFactory::save (this=0x10754a0, str=...) at ../../kded/kbuildmimetypefactory.cpp:307
#8  0x00007fae8c8b3da9 in KBuildSycoca::save (this=0x1406e60, str=0x10aceb0) at ../../kded/kbuildsycoca.cpp:525
#9  0x00007fae8c8b6ab3 in KBuildSycoca::recreate (this=0x1406e60) at ../../kded/kbuildsycoca.cpp:433
#10 0x00007fae8c8b7ee6 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kded/kbuildsycoca.cpp:829
#11 0x0000000000406da8 in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=16, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0xff19ca "vnieto-laptop;1263003827;95530;5750_TIME0") at ../../kinit/kinit.cpp:677
#12 0x0000000000407aa0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#13 0x0000000000407f51 in handle_requests (waitForPid=5776) at ../../kinit/kinit.cpp:1362
#14 0x0000000000408ccd in main (argc=<value optimized out>, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1745

Reported using DrKonqi
Comment 1 Christoph Feck 2010-01-09 14:25:52 UTC

*** This bug has been marked as a duplicate of bug 202871 ***