Bug 221408 - Disabling netbook mode does not re-enable borders on maximized windows
Summary: Disabling netbook mode does not re-enable borders on maximized windows
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: plasma-netbook (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
: 231762 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-05 15:39 UTC by Grissiom
Modified: 2013-04-04 20:56 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grissiom 2010-01-05 15:39:54 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

KDE SC version:KDE 4.3.85 (KDE 4.4 Beta2)

It's strange that if I maximize the window, it's title bar will disappeared. Here is some hardware info:

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]

(Actually it should be RS485, xorg(1.6.3) have something wrong with probing the hardware)
Comment 1 Thomas Lübking 2010-01-05 15:59:39 UTC
- using compositing (desktop FX)?
- using oxygen deco?
- does "maximized" mean "maximized" or "fullscreen" ;-)
- "disappeared" means: 
   ° "titlebar is transparent/invisible" or
   ° "titlebar is gone" (you cannot click it either)?
- is there a gap instead of the titlebar or is it rather as if the titlebar shrinked away?
Comment 2 Grissiom 2010-01-05 16:13:43 UTC
(In reply to comment #1)
> - using compositing (desktop FX)?

Both with and without desktopFX, the bug exits.

> - using oxygen deco?

Yes.

> - does "maximized" mean "maximized" or "fullscreen" ;-)

Surely maximize ;-)

> - "disappeared" means: 
>    ° "titlebar is transparent/invisible" or
>    ° "titlebar is gone" (you cannot click it either)?

Totally gone. It is the window's tool bar being placed at the top of the screen.

> - is there a gap instead of the titlebar or is it rather as if the titlebar
> shrinked away?

It's disappeared. A screen shot:

http://imagebin.org/78403
Comment 3 Thomas Lübking 2010-01-05 16:24:49 UTC
- does this happen only with the oxygen deco?
- do other windows have titlebars? (and/or can you switch using alt+tab?)
Comment 4 Grissiom 2010-01-06 01:15:08 UTC
(In reply to comment #3)
> - does this happen only with the oxygen deco?

Not only oxygen, I tried BII or other things like that. All have the same problem...

> - do other windows have titlebars? (and/or can you switch using alt+tab?)

Yes, I can always switch between the windows with alt+tab. But the ones maximized will lose their title bar, the ones aren't maximized will have their title bar.

More screen shot:

http://imagebin.org/78477
Comment 5 lucas 2010-01-06 04:43:08 UTC
Are you running Plasma in Netbook mode?
Comment 6 Grissiom 2010-01-06 12:43:19 UTC
(In reply to comment #5)
> Are you running Plasma in Netbook mode?

No. Netbook hangs on my box...
Comment 7 Martin Flöser 2010-01-06 13:02:00 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Are you running Plasma in Netbook mode?
> 
> No. Netbook hangs on my box...
But you activated it once?
Comment 8 Grissiom 2010-01-06 13:36:40 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > Are you running Plasma in Netbook mode?
> > 
> > No. Netbook hangs on my box...
> But you activated it once?

Yes. This time I logged into a fresh new ~/.kde and I can confirm this bug if I enabled it once. No matter which plasma I currently use, the title bar will disappear for maximized window. I think enabling the Netbook mode is the cause of problem.

Besides, the time I enable the Netbook mode, kwin will crash(at least crashed once). I use a release version of KDE but not a debug one. So there is no useful trace-back, sorry.
Comment 9 Grissiom 2010-01-07 01:09:43 UTC
Finally I find where the "bug" is. After change BorderlessMaximizedWindows=ture to false in ~/.kde/share/config/kwinrc, all things went back to normal.

However, I think it will horrify users if they see the title bar "disappeared". At least there should be an option that could be seen in system-settings. What do you think of it?

At least, when user switch plasma from Netbook to Desktop, this option should be removed automatically.
Comment 10 Marco Martin 2010-01-07 19:19:51 UTC
@Grissiom: yes, it should be removed authomatically. i can't reproduce the problem (of that setting not being updated)
Comment 11 Grissiom 2010-01-31 12:35:10 UTC
I'd like to say that this bug was fixed in KDE 4.3.95 (KDE 4.4 RC2). Maybe the reason is Netbook mode no longer crashes anymore. Anyway, you can mark it as FIXED ;)
Comment 12 Nicolas L. 2010-02-03 18:37:31 UTC
this bug is still valid for me in kde 4.4Rc3
Comment 13 Grissiom 2010-02-03 18:44:19 UTC
What is the symptom? Does your Netbook mode crashes or lost response?
Comment 14 Thomas Leineweber 2010-02-03 20:49:45 UTC
I think I can reproduce the problem (please correct me, if I am wrong):

Preconditions (on my system):
- kde 4.4rc3 with patch for 221868
- oxygen window decoration
- plasma-desktop is running

1. open a konsole window, make it fullscreen
2. open systemsettings, make it fullscreen
3. change the plasma formfactor to netbook

result: both fullscreen windows loose their kwin-window-decoration (correct)

4. change the formfactor back to desktop

result: both fullscreen windows are still without kwin-window-decoration (reported as incorrect in this bug)
Comment 15 Eric Hameleers 2010-03-19 11:28:56 UTC
I can confirm this bug still exists in KDE 4.4.1.
When I change from plasma to plasma-netbook and back to plasma workspace, initially all windows that were full-screen are missing their window decorations.

When rebooted, the windows get back their window decorations, _except_ the "minimize" button. I have to re-add the minimizer button to the window decorations manually, through "system settings > appearance > windows > buttons"

Eric
Comment 16 Martin Flöser 2010-03-22 13:52:10 UTC
*** Bug 231762 has been marked as a duplicate of this bug. ***
Comment 17 Mark 2010-03-22 14:49:18 UTC
hello, i probably experience the same bug under 4.4.1, the thing is, that in my case not only maximized windows miss border, all do miss it. 
/oxygen theme, effects&compositing on,happens after switch from netbook mode back to desktop/
Regards,
Comment 18 Thomas Lübking 2010-03-22 17:58:55 UTC
can you still change the window focus by e.g. clicking it and use alt+lmb/rmb to move/resize it?
Comment 19 Mark 2010-03-22 18:21:38 UTC
yes, I can switch windows by using alt+tab or clicking on them, move them, 
close with alt+f4... 
a remark: for me/see duplicate bug above/ this is for all windows, not only 
maximized. 
Thank you
Comment 20 Nicolas L. 2010-04-20 08:54:15 UTC
still valid on kde 4.4.2 for me
Comment 21 Gregor Tätzner 2011-11-21 16:04:00 UTC
For me, on KDE 4.7.3 the window borders are re-enabled when switching from netbook to desktop.
Comment 22 Thijs 2011-12-06 18:14:16 UTC
Works for me too. Let's close it.
Comment 23 Thomas Sisson 2013-04-04 20:56:04 UTC
This bug is back in Kubuntu 12.10.