Bug 220971 - Plasma crash when dragging menu item into panel cossing the pager
Summary: Plasma crash when dragging menu item into panel cossing the pager
Status: RESOLVED DUPLICATE of bug 210941
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-02 13:04 UTC by g111
Modified: 2010-01-03 13:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description g111 2010-01-02 13:04:05 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-2.slh.3-sidux-686 i686
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
I have tried to drag the konsole icon from the menu (Favorites) into the panel. While dragging the icon the mouse cursor did cross the pager that is included in this panel. The pager did switch from desktop 1 to desktop 2 and further to desktop 3. (I have a 3x2 desktop layout.) While still dragging the icon plasma did crash. I tried it once again and could reproduce the crash.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb571b700 (LWP 3032))]

Thread 2 (Thread 0xa783bb70 (LWP 3035)):
#0  0xb773c424 in __kernel_vsyscall ()
#1  0xb5e5f0a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb602282d in pthread_cond_wait () from /lib/i686/cmov/libc.so.6
#3  0xb75315c2 in QWaitConditionPrivate::wait (this=0x93f28d0, mutex=0x93f28cc, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x93f28d0, mutex=0x93f28cc, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0xb5d72a9a in QHostInfoAgent::run (this=0x93f28c0) at kernel/qhostinfo.cpp:260
#6  0xb75305e2 in QThreadPrivate::start (arg=0x93f28c0) at thread/qthread_unix.cpp:188
#7  0xb5e5b585 in start_thread () from /lib/i686/cmov/libpthread.so.0
#8  0xb60152be in clone () from /lib/i686/cmov/libc.so.6

Thread 1 (Thread 0xb571b700 (LWP 3032)):
[KCrash Handler]
#6  QGraphicsItem::sceneTransform (this=0x1) at graphicsview/qgraphicsitem.cpp:2517
#7  0xb68bd735 in QGraphicsItem::mapFromScene (this=0x1, point=...) at graphicsview/qgraphicsitem.cpp:4579
#8  0xb68c0884 in QGraphicsItemPrivate::genericMapFromScene (this=0x9bdaeb8, pos=..., viewport=0x935cda0) at graphicsview/qgraphicsitem.cpp:747
#9  0xb68e5c40 in QGraphicsScenePrivate::sendDragDropEvent (this=0x8cd3268, item=0x978f910, dragDropEvent=0xbffebc60) at graphicsview/qgraphicsscene.cpp:1187
#10 0xb68f0311 in QGraphicsScene::dragMoveEvent (this=0x8ccc140, event=0xbffec0ec) at graphicsview/qgraphicsscene.cpp:4035
#11 0xb52a6dd4 in Plasma::Corona::dragMoveEvent (this=0x8ccc140, event=0xbffec0ec) at ../../plasma/corona.cpp:621
#12 0xb68f14aa in QGraphicsScene::event (this=0x8ccc140, event=0xbffec0ec) at graphicsview/qgraphicsscene.cpp:3757
#13 0xb62c0a94 in QApplicationPrivate::notify_helper (this=0x8c9b238, receiver=0x8ccc140, e=0xbffec0ec) at kernel/qapplication.cpp:4065
#14 0xb62c8bee in QApplication::notify (this=0x8c742b0, receiver=0x8ccc140, e=0xbffec0ec) at kernel/qapplication.cpp:3605
#15 0xb6d0b62d in KApplication::notify (this=0x8c742b0, receiver=0x8ccc140, event=0xbffec0ec) at ../../kdeui/kernel/kapplication.cpp:302
#16 0xb76211eb in QCoreApplication::notifyInternal (this=0x8c742b0, receiver=0x8ccc140, event=0xbffec0ec) at kernel/qcoreapplication.cpp:610
#17 0xb68fe15b in QCoreApplication::sendEvent (this=0x9545d58, event=0xbffec6bc) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#18 QGraphicsView::dragMoveEvent (this=0x9545d58, event=0xbffec6bc) at graphicsview/qgraphicsview.cpp:3071
#19 0xb6316fbd in QWidget::event (this=0x9545d58, event=0xbffec6bc) at kernel/qwidget.cpp:7744
#20 0xb66bc543 in QFrame::event (this=0x9545d58, e=0xbffec6bc) at widgets/qframe.cpp:559
#21 0xb675a59f in QAbstractScrollArea::viewportEvent (this=0x9545d58, e=0x1) at widgets/qabstractscrollarea.cpp:962
#22 0xb6903d62 in QGraphicsView::viewportEvent (this=0x9545d58, event=0xbffec6bc) at graphicsview/qgraphicsview.cpp:2919
#23 0xb675cb75 in QAbstractScrollAreaPrivate::viewportEvent (this=0x935d388, o=0x935cda0, e=0xbffec6bc) at widgets/qabstractscrollarea_p.h:100
#24 QAbstractScrollAreaFilter::eventFilter (this=0x935d388, o=0x935cda0, e=0xbffec6bc) at widgets/qabstractscrollarea_p.h:111
#25 0xb762041a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8c9b238, receiver=0x935cda0, event=0xbffec6bc) at kernel/qcoreapplication.cpp:726
#26 0xb62c0a6c in QApplicationPrivate::notify_helper (this=0x8c9b238, receiver=0x935cda0, e=0xbffec6bc) at kernel/qapplication.cpp:4061
#27 0xb62c91f1 in QApplication::notify (this=0x8c742b0, receiver=0x935cda0, e=0xbffec6bc) at kernel/qapplication.cpp:4018
#28 0xb6d0b62d in KApplication::notify (this=0x8c742b0, receiver=0x935cda0, event=0xbffec6bc) at ../../kdeui/kernel/kapplication.cpp:302
#29 0xb76211eb in QCoreApplication::notifyInternal (this=0x8c742b0, receiver=0x935cda0, event=0xbffec6bc) at kernel/qcoreapplication.cpp:610
#30 0xb7638e0e in QCoreApplication::sendEvent(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#31 0xb6344428 in handle_xdnd_position (w=0x9545d58, xe=0xbffec83c, passive=false) at kernel/qdnd_x11.cpp:940
#32 0xb6348794 in QDragManager::move (this=0x9b9b618, globalPos=...) at kernel/qdnd_x11.cpp:1653
#33 0xb63497f1 in QDragManager::eventFilter (this=0x9b9b618, o=0x95ba550, e=0xbffece1c) at kernel/qdnd_x11.cpp:1297
#34 0xb76204dc in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x8c9b238, receiver=0x95ba550, event=0xbffece1c) at kernel/qcoreapplication.cpp:707
#35 0xb62c0a13 in QApplicationPrivate::notify_helper (this=0x8c9b238, receiver=0x95ba550, e=0xbffece1c) at kernel/qapplication.cpp:4040
#36 0xb62c9551 in QApplication::notify (this=0x8c742b0, receiver=0x95ba550, e=0xbffece1c) at kernel/qapplication.cpp:3767
#37 0xb6d0b62d in KApplication::notify (this=0x8c742b0, receiver=0x95ba550, event=0xbffece1c) at ../../kdeui/kernel/kapplication.cpp:302
#38 0xb76211eb in QCoreApplication::notifyInternal (this=0x8c742b0, receiver=0x95ba550, event=0xbffece1c) at kernel/qcoreapplication.cpp:610
#39 0xb62c85de in QCoreApplication::sendSpontaneousEvent (receiver=0x95ba550, event=0xbffece1c, alienWidget=0x0, nativeWidget=0x95ba550, buttonDown=0xb6b37580, lastMouseReceiver=...)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#40 QApplicationPrivate::sendMouseEvent (receiver=0x95ba550, event=0xbffece1c, alienWidget=0x0, nativeWidget=0x95ba550, buttonDown=0xb6b37580, lastMouseReceiver=...) at kernel/qapplication.cpp:2924
#41 0xb6337175 in QETWidget::translateMouseEvent (this=0x95ba550, event=0xbffee3cc) at kernel/qapplication_x11.cpp:4411
#42 0xb6336646 in QApplication::x11ProcessEvent (this=0x8c742b0, event=0xbffee3cc) at kernel/qapplication_x11.cpp:3430
#43 0xb6360bc2 in x11EventSourceDispatch (s=0x8c9df70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#44 0xb5ea6b38 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#45 0xb5eaa3d0 in ?? () from /lib/libglib-2.0.so.0
#46 0xb5eaa503 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#47 0xb764c041 in QEventDispatcherGlib::processEvents (this=0x8c9ae68, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#48 0xb6360305 in QGuiEventDispatcherGlib::processEvents (this=0x8c9ae68, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#49 0xb761f83a in QEventLoop::processEvents (this=0x8da0968, flags=...) at kernel/qeventloop.cpp:149
#50 0xb761fc82 in QEventLoop::exec (this=0x8da0968, flags=...) at kernel/qeventloop.cpp:201
#51 0xb6348ff6 in QDragManager::drag (this=0x9b9b618, o=0x8f5d9d0) at kernel/qdnd_x11.cpp:1970
#52 0xb62d3e9a in QDrag::exec (this=0x8f5d9d0, supportedActions=..., defaultDropAction=Qt::IgnoreAction) at kernel/qdrag.cpp:282
#53 0xb62d3f44 in QDrag::exec (this=0x8f5d9d0, supportedActions=...) at kernel/qdrag.cpp:239
#54 0xa7a1a23b in Kickoff::UrlItemView::startDrag (this=0x9262a58, supportedActions=...) at ../../../../plasma/applets/kickoff/ui/urlitemview.cpp:625
#55 0xb6806d85 in QAbstractItemView::mouseMoveEvent (this=0x9262a58, event=0xbffef21c) at itemviews/qabstractitemview.cpp:1552
#56 0xa7a1b14c in Kickoff::UrlItemView::mouseMoveEvent (this=0x9262a58, event=0xbffef21c) at ../../../../plasma/applets/kickoff/ui/urlitemview.cpp:524
#57 0xb6316865 in QWidget::event (this=0x9262a58, event=0xbffef21c) at kernel/qwidget.cpp:7539
#58 0xb66bc543 in QFrame::event (this=0x9262a58, e=0xbffef21c) at widgets/qframe.cpp:559
#59 0xb675a59f in QAbstractScrollArea::viewportEvent (this=0x9262a58, e=0x1) at widgets/qabstractscrollarea.cpp:962
#60 0xb680b887 in QAbstractItemView::viewportEvent (this=0x9262a58, event=0xbffef21c) at itemviews/qabstractitemview.cpp:1476
#61 0xb675cb75 in QAbstractScrollAreaPrivate::viewportEvent (this=0x92410a0, o=0x925e0b0, e=0xbffef21c) at widgets/qabstractscrollarea_p.h:100
#62 QAbstractScrollAreaFilter::eventFilter (this=0x92410a0, o=0x925e0b0, e=0xbffef21c) at widgets/qabstractscrollarea_p.h:111
#63 0xb762041a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8c9b238, receiver=0x925e0b0, event=0xbffef21c) at kernel/qcoreapplication.cpp:726
#64 0xb62c0a6c in QApplicationPrivate::notify_helper (this=0x8c9b238, receiver=0x925e0b0, e=0xbffef21c) at kernel/qapplication.cpp:4061
#65 0xb62c9551 in QApplication::notify (this=0x8c742b0, receiver=0x925e0b0, e=0xbffef21c) at kernel/qapplication.cpp:3767
#66 0xb6d0b62d in KApplication::notify (this=0x8c742b0, receiver=0x925e0b0, event=0xbffef21c) at ../../kdeui/kernel/kapplication.cpp:302
#67 0xb76211eb in QCoreApplication::notifyInternal (this=0x8c742b0, receiver=0x925e0b0, event=0xbffef21c) at kernel/qcoreapplication.cpp:610
#68 0xb62c85de in QCoreApplication::sendSpontaneousEvent (receiver=0x925e0b0, event=0xbffef21c, alienWidget=0x925e0b0, nativeWidget=0x92494f0, buttonDown=0xb6b37580, lastMouseReceiver=...)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#69 QApplicationPrivate::sendMouseEvent (receiver=0x925e0b0, event=0xbffef21c, alienWidget=0x925e0b0, nativeWidget=0x92494f0, buttonDown=0xb6b37580, lastMouseReceiver=...)
    at kernel/qapplication.cpp:2924
#70 0xb6337175 in QETWidget::translateMouseEvent (this=0x92494f0, event=0xbfff07cc) at kernel/qapplication_x11.cpp:4411
#71 0xb6336646 in QApplication::x11ProcessEvent (this=0x8c742b0, event=0xbfff07cc) at kernel/qapplication_x11.cpp:3430
#72 0xb6360bc2 in x11EventSourceDispatch (s=0x8c9df70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#73 0xb5ea6b38 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#74 0xb5eaa3d0 in ?? () from /lib/libglib-2.0.so.0
#75 0xb5eaa503 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#76 0xb764c041 in QEventDispatcherGlib::processEvents (this=0x8c9ae68, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#77 0xb6360305 in QGuiEventDispatcherGlib::processEvents (this=0x8c9ae68, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#78 0xb761f83a in QEventLoop::processEvents (this=0xbfff0a80, flags=...) at kernel/qeventloop.cpp:149
#79 0xb761fc82 in QEventLoop::exec (this=0xbfff0a80, flags=...) at kernel/qeventloop.cpp:201
#80 0xb76220d9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#81 0xb62c0917 in QApplication::exec () at kernel/qapplication.cpp:3525
#82 0xb30185cd in kdemain (argc=1, argv=0x8c5e518) at ../../../../plasma/shells/desktop/main.cpp:50
#83 0x0804e291 in launch (argc=1, _name=0x8c61274 "/usr/bin/plasma-desktop", args=0x8c6128c "", cwd=0x0, envc=0, envs=0x8c61290 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x805105f "0") at ../../kinit/kinit.cpp:677
#84 0x0804ea15 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#85 0x0804ee5b in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#86 0x0804f689 in main (argc=2, argv=0xbfff12f4, envp=0xbfff1300) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 215506

Reported using DrKonqi
Comment 1 Beat Wolf 2010-01-02 18:39:32 UTC

*** This bug has been marked as a duplicate of bug 196695 ***
Comment 2 Beat Wolf 2010-01-03 13:14:13 UTC

*** This bug has been marked as a duplicate of bug 210941 ***