Bug 220835 - Random crash while I was using a different application
Summary: Random crash while I was using a different application
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-31 18:58 UTC by David
Modified: 2009-12-31 22:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David 2009-12-31 18:58:36 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f1dff7b6750 (LWP 3525))]

Thread 2 (Thread 0x7f1de5db0910 (LWP 5361)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f1deb8acc91 in metronom_sync_loop (this=0x386fbe0) at metronom.c:870
#2  0x00007f1df7a72a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f1dfbac17bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1dff7b6750 (LWP 3525)):
[KCrash Handler]
#5  QUrl (this=0x7fff3d8997c0, other=...) at io/qurl.cpp:3936
#6  0x00007f1dfd3aaff9 in KUrl (this=0x7fff3d8997c0, _u=...) at ../../kdecore/io/kurl.cpp:468
#7  0x00007f1dff253f60 in KFileItem::url (this=<value optimized out>) at ../../kio/kio/kfileitem.cpp:1271
#8  0x00007f1dff244784 in KDirModel::indexForItem (this=0x4aa98f0, item=...) at ../../kio/kio/kdirmodel.cpp:919
#9  0x00007f1dfeee8950 in KFilePreviewGenerator::Private::orderItems (this=0x4ae2640, items=...) at ../../kfile/kfilepreviewgenerator.cpp:1023
#10 0x00007f1dfeeec652 in KFilePreviewGenerator::Private::updateIcons (this=0x4ae2640, items=...) at ../../kfile/kfilepreviewgenerator.cpp:508
#11 0x00007f1dfeeec8af in KFilePreviewGenerator::Private::delayedIconUpdate (this=0x4ae2640) at ../../kfile/kfilepreviewgenerator.cpp:1088
#12 0x00007f1dfeeed925 in KFilePreviewGenerator::qt_metacall (this=0x4ae2440, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff3d899aa0) at ./kfilepreviewgenerator.moc:95
#13 0x00007f1dfc1baddc in QMetaObject::activate (sender=0x4ae2610, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x3c1) at kernel/qobject.cpp:3113
#14 0x00007f1dfc1b4d83 in QObject::event (this=0x4ae2610, e=0x10) at kernel/qobject.cpp:1075
#15 0x00007f1dfc638efc in QApplicationPrivate::notify_helper (this=0x25b8670, receiver=0x4ae2610, e=0x7fff3d89a0a0) at kernel/qapplication.cpp:4056
#16 0x00007f1dfc6401ce in QApplication::notify (this=0x7fff3d89a3f0, receiver=0x4ae2610, e=0x7fff3d89a0a0) at kernel/qapplication.cpp:4021
#17 0x00007f1dfd96de56 in KApplication::notify (this=0x7fff3d89a3f0, receiver=0x4ae2610, event=0x7fff3d89a0a0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f1dfc1a5c2c in QCoreApplication::notifyInternal (this=0x7fff3d89a3f0, receiver=0x4ae2610, event=0x7fff3d89a0a0) at kernel/qcoreapplication.cpp:610
#19 0x00007f1dfc1d0862 in QCoreApplication::sendEvent (this=0x25bb7d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QTimerInfoList::activateTimers (this=0x25bb7d0) at kernel/qeventdispatcher_unix.cpp:572
#21 0x00007f1dfc1ce25d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#22 0x00007f1df7cc3bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f1df7cc7598 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f1df7cc76c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f1dfc1ce1a6 in QEventDispatcherGlib::processEvents (this=0x257bd20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007f1dfc6cd4be in QGuiEventDispatcherGlib::processEvents (this=0x7fff3d8997c0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007f1dfc1a4532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f1dfc1a4904 in QEventLoop::exec (this=0x7fff3d89a340, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f1dfc1a6ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x00000000004394e5 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../../apps/dolphin/src/main.cpp:94
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-31 22:38:31 UTC
Fixed in KDE SC 4.4. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***