Bug 220525 - introduce digikam's collection management (multiple collections)
Summary: introduce digikam's collection management (multiple collections)
Status: RESOLVED DUPLICATE of bug 171213
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-29 14:10 UTC by S. Burmeister
Modified: 2010-01-03 18:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2009-12-29 14:10:32 UTC
Version:           2.2 (using KDE 4.3.4)
OS:                Linux
Installed from:    openSUSE RPMs

Currently amarok's collection management suffers from not being able to distinguish between different sources, e.g. it considers a mounted samba share as local as files that are really on the local harddisk.

The dynamic collection fails to handle these kind of sources as soon as amarok was started once without the share being mounted even if the samba share is part of the fstab. Most network harddisks come with samba thus ignoring samba is not an option.

Also, amarok cannot distinguish between several local collections there is just one big collection.

Digikam has a well established collection management thus the wheel does not need to be re-invented.

What it does is simple, it offers the user three categories of collections: 1. local 2. removable media 3. network shares.

The user can just add different locations to each of these categories and thus enables digikam to reliably handle those, i.e. distinguish between network and local.

As a very welcome side-effect it enables the user to have several (local) collections and thus enable/disable them or perform searches/playback or whatever on only one/some or all of them.

You can try digikam's collection management via settings > digikam settings > collections
Comment 1 Mikko C. 2010-01-03 18:38:50 UTC

*** This bug has been marked as a duplicate of bug 171213 ***