Bug 220411 - crash -amarok- since ten minute listening
Summary: crash -amarok- since ten minute listening
Status: RESOLVED DUPLICATE of bug 210477
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-28 16:25 UTC by gre
Modified: 2009-12-28 16:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gre 2009-12-28 16:25:58 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
i umount an external harddrive wich amarok didnt use.amarok wasn't connected with the harddrive, but its the only action i did when amarok crashed

 -- Backtrace:
Application: Amarok (amarok), signal: Aborted
[Current thread is 1 (Thread 0xb340e710 (LWP 3408))]

Thread 14 (Thread 0xb02d9b70 (LWP 3409)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb3eb5142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e8b7e4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb0f9f9ff in ?? () from /usr/lib/libxine.so.1
#4  0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 13 (Thread 0xaf97bb70 (LWP 3410)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb3eb7829 in __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb3eb2f3b in _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
#3  0xb3eb2d51 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#4  0xb5e8b956 in pthread_mutex_lock () from /lib/tls/i686/cmov/libc.so.6
#5  0xb3a54d29 in g_main_context_wakeup () from /lib/libglib-2.0.so.0
#6  0xb6151d5d in QEventDispatcherGlib::wakeUp() () from /usr/lib/libQtCore.so.4
#7  0xb6127472 in QCoreApplication::postEvent(QObject*, QEvent*, int) () from /usr/lib/libQtCore.so.4
#8  0xb612763c in QCoreApplication::postEvent(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#9  0xb61385b5 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb613d187 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#11 0xb613dec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#12 0xb1002def in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#13 0xb100a3b3 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#14 0xb100b733 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#15 0xb613d263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#16 0xb613dec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#17 0xb6177667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#18 0xb61429ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb61373bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#20 0xb6583f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb658b67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#22 0xb7592bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#23 0xb61276cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#24 0xb61547ce in ?? () from /usr/lib/libQtCore.so.4
#25 0xb61520e0 in ?? () from /usr/lib/libQtCore.so.4
#26 0xb3a53e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0xb3a57730 in ?? () from /lib/libglib-2.0.so.0
#28 0xb3a57863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0xb615202c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#30 0xb6125c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0xb61260ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0xb6033b73 in QThread::exec() () from /usr/lib/libQtCore.so.4
#33 0xb0fff20a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#34 0xb6036e32 in ?? () from /usr/lib/libQtCore.so.4
#35 0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#36 0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 12 (Thread 0xab172b70 (LWP 3416)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb5e70ba6 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0xafad3c3b in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#3  0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#4  0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 11 (Thread 0xaf16db70 (LWP 3417)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb3eb4e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e8b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb0fb05ee in ?? () from /usr/lib/libxine.so.1
#4  0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 10 (Thread 0xae96cb70 (LWP 3418)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb3eb7829 in __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb3eb2f3b in _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
#3  0xb3eb2d51 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#4  0xb5e8b956 in pthread_mutex_lock () from /lib/tls/i686/cmov/libc.so.6
#5  0xb603637c in ?? () from /usr/lib/libQtCore.so.4
#6  0xb6031b82 in QMutex::lock() () from /usr/lib/libQtCore.so.4
#7  0xb60326b2 in QReadWriteLock::lockForRead() () from /usr/lib/libQtCore.so.4
#8  0xb7149f35 in MemoryQueryMaker::runQuery() () from /usr/lib/libamaroklib.so.1
#9  0xb714ce65 in ?? () from /usr/lib/libamaroklib.so.1
#10 0xb529a37d in ?? () from /usr/lib/libthreadweaver.so.4
#11 0xb529a6e1 in ThreadWeaver::Job::execute(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#12 0xb529938a in ?? () from /usr/lib/libthreadweaver.so.4
#13 0xb52999db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#14 0xb6036e32 in ?? () from /usr/lib/libQtCore.so.4
#15 0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 9 (Thread 0xaceffb70 (LWP 3419)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb3eb7829 in __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb3eb2f3b in _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
#3  0xb3eb2d51 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#4  0xb5e8b956 in pthread_mutex_lock () from /lib/tls/i686/cmov/libc.so.6
#5  0xb603637c in ?? () from /usr/lib/libQtCore.so.4
#6  0xb6031b82 in QMutex::lock() () from /usr/lib/libQtCore.so.4
#7  0xb60326b2 in QReadWriteLock::lockForRead() () from /usr/lib/libQtCore.so.4
#8  0xb7149f35 in MemoryQueryMaker::runQuery() () from /usr/lib/libamaroklib.so.1
#9  0xb714ce65 in ?? () from /usr/lib/libamaroklib.so.1
#10 0xb529a37d in ?? () from /usr/lib/libthreadweaver.so.4
#11 0xb529a6e1 in ThreadWeaver::Job::execute(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#12 0xb529938a in ?? () from /usr/lib/libthreadweaver.so.4
#13 0xb52999db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#14 0xb6036e32 in ?? () from /usr/lib/libQtCore.so.4
#15 0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 8 (Thread 0xac6feb70 (LWP 3423)):
[KCrash Handler]
#6  0xb776b422 in __kernel_vsyscall ()
#7  0xb5ddc4d1 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb5ddf932 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb5e12ee5 in ?? () from /lib/tls/i686/cmov/libc.so.6
#10 0xb5e1cff1 in ?? () from /lib/tls/i686/cmov/libc.so.6
#11 0xb5e1d23a in ?? () from /lib/tls/i686/cmov/libc.so.6
#12 0xb5e1f4b2 in ?? () from /lib/tls/i686/cmov/libc.so.6
#13 0xb5e22319 in ?? () from /lib/tls/i686/cmov/libc.so.6
#14 0xb5e2282d in realloc () from /lib/tls/i686/cmov/libc.so.6
#15 0xb6031664 in qRealloc(void*, unsigned int) () from /usr/lib/libQtCore.so.4
#16 0xb607cd87 in QString::realloc(int) () from /usr/lib/libQtCore.so.4
#17 0xb607d217 in QString::append(QString const&) () from /usr/lib/libQtCore.so.4
#18 0xadfa4815 in ?? () from /usr/lib/kde4/amarok_collection-mysqlservercollection.so
#19 0xadfa4b97 in ?? () from /usr/lib/kde4/amarok_collection-mysqlservercollection.so
#20 0xadfa61df in ?? () from /usr/lib/kde4/amarok_collection-mysqlservercollection.so
#21 0xb529a37d in ?? () from /usr/lib/libthreadweaver.so.4
#22 0xb529a6e1 in ThreadWeaver::Job::execute(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#23 0xb529938a in ?? () from /usr/lib/libthreadweaver.so.4
#24 0xb52999db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#25 0xb6036e32 in ?? () from /usr/lib/libQtCore.so.4
#26 0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#27 0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 7 (Thread 0xabefdb70 (LWP 3424)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb5e8bae3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0xb5e22f07 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 6 (Thread 0x9f0bab70 (LWP 3429)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb5e77981 in select () from /lib/tls/i686/cmov/libc.so.6
#2  0xb0fc8be0 in xine_usec_sleep () from /usr/lib/libxine.so.1
#3  0xb0fad011 in ?? () from /usr/lib/libxine.so.1
#4  0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0x9e4d0b70 (LWP 3430)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb3eb4e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e8b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb0fa2fc2 in ?? () from /usr/lib/libxine.so.1
#4  0xb0fa8d36 in ?? () from /usr/lib/libxine.so.1
#5  0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0x9db02b70 (LWP 3431)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb3eb4e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e8b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb0fa2fc2 in ?? () from /usr/lib/libxine.so.1
#4  0xb0fa9d46 in ?? () from /usr/lib/libxine.so.1
#5  0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0x9d301b70 (LWP 3432)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb3eb4e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb5e8b78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb0fb351a in xine_event_wait () from /usr/lib/libxine.so.1
#4  0xb0fb35a2 in ?? () from /usr/lib/libxine.so.1
#5  0xb3eb080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0xb5e7e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0x9c18db70 (LWP 3572)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb5e8bae3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0xb5e22f07 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0xb340e710 (LWP 3408)):
#0  0xb776b422 in __kernel_vsyscall ()
#1  0xb5e6eecb in read () from /lib/tls/i686/cmov/libc.so.6
#2  0xb3a56c20 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0xb3a5747c in ?? () from /lib/libglib-2.0.so.0
#4  0xb3a57863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb615202c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6624be5 in ?? () from /usr/lib/libQtGui.so.4
#7  0xb6125c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb61260ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0xb612853f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#10 0xb6583dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#11 0x08051e49 in _start ()

Reported using DrKonqi
Comment 1 Mikko C. 2009-12-28 16:30:11 UTC

*** This bug has been marked as a duplicate of bug 210477 ***