Bug 220285 - Translation and display mistake (German) with Admins and Owner
Summary: Translation and display mistake (German) with Admins and Owner
Status: RESOLVED DUPLICATE of bug 153580
Alias: None
Product: konversation
Classification: Unclassified
Component: general (show other bugs)
Version: 1.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konversation Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-27 16:53 UTC by OldShatterhand
Modified: 2009-12-27 17:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description OldShatterhand 2009-12-27 16:53:49 UTC
Version:           1.2 (using 4.3.4 (KDE 4.3.4) "release 2", KDE:KDE4:STABLE:Desktop / openSUSE_11.2)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.31.5-0.1-desktop

In the German version of Konversation there is a little translation and display mistake. The Channel owners are named as Administratoren (Administrators) and the Administrators are named as Kanalbesitzer(Channel-Owners). Also they are displayed in the wrong order when you choose "ordering by user status" in the options of Userlist.
Under the following URl you could see a screen of the bug (red are Administrators and purple is Channel-Owner, also there is a whois of the owner and a administrator viewable if you could read German): 
http://i17.servimg.com/u/f17/12/57/51/80/bildsc10.png

Greets OldShatterhand

P.S.: I hope my english is understandable and you can fix the bug ;)
Comment 1 Eike Hein 2009-12-27 17:20:34 UTC
The German translator can't find a problem like that in his work, so this is likely a dupe of bug 153580.

*** This bug has been marked as a duplicate of bug 153580 ***
Comment 2 Frederik Schwarzer 2009-12-27 17:26:52 UTC
Hi,

I just checked the translation and it seems fine (I found an unrelated switched status, so thanks for the report anyway :)).
Can you check if the status is still wrong when running Konversation in English language?
You can run it with "KDE_LANG=en_US konversation" from a terminal to achieve that.

Regards
Comment 3 Frederik Schwarzer 2009-12-27 17:27:38 UTC
meh ...

*** This bug has been marked as a duplicate of bug 153580 ***
Comment 4 OldShatterhand 2009-12-27 17:35:31 UTC
(In reply to comment #2)
> Hi,
> 
> I just checked the translation and it seems fine (I found an unrelated switched
> status, so thanks for the report anyway :)).
> Can you check if the status is still wrong when running Konversation in English
> language?
> You can run it with "KDE_LANG=en_US konversation" from a terminal to achieve
> that.
> 
> Regards

hi, 
i have checked the same with Konversation in English. There is the same bug, owners are declared as admins and admins are named as owners. It seems that it isn't an Translation bug but an bug in the programm byself.

Regards OldShatterhand
Comment 5 Eike Hein 2009-12-27 17:38:53 UTC
Technically it's not a bug in the program either -- the problem stems from the fact that the meaning of the mode chars differs between various networks.
Comment 6 OldShatterhand 2009-12-27 17:50:08 UTC
yes and no... on the one Hand i admit with you, that it is a problem, that the different networks use different mode chars (maybe it would be a possibility to change the way, konversation should interpret the mode chars, manually in the options?)

but on the other hand i have now further recognized, that konversation interprets the  mode chars in the right way, when i'm logging in into an channel at the server:

http://i17.servimg.com/u/f17/12/57/51/80/bildsc11.png

Regards
OldShatterhand
Comment 7 Eike Hein 2009-12-27 17:52:53 UTC
Please attach those screenshots to the bug report, btw (those links will eventually be dead).