Bug 220249 - Copying file, update KDE
Summary: Copying file, update KDE
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-27 11:39 UTC by Patryk
Modified: 2009-12-28 18:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patryk 2009-12-27 11:39:48 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When i copying files and updating KDE to 4.4 i have this error.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x00d15829 in QUrl (this=0xbfe74038, other=...) at io/qurl.cpp:3936
#7  0x009a0d89 in KUrl (this=0xbfe74038, _u=...) at ../../kdecore/io/kurl.cpp:468
#8  0x0076328e in KFileItem::url (this=0x8aaf918) at ../../kio/kio/kfileitem.cpp:1271
#9  0x0075275f in KDirModel::indexForItem (this=0x891f968, item=...) at ../../kio/kio/kdirmodel.cpp:919
#10 0x00c00a36 in KFilePreviewGenerator::Private::orderItems (this=0x88ff410, items=...) at ../../kfile/kfilepreviewgenerator.cpp:1023
#11 0x00c046bd in KFilePreviewGenerator::Private::updateIcons (this=0x88ff410, items=...) at ../../kfile/kfilepreviewgenerator.cpp:508
#12 0x00c04902 in KFilePreviewGenerator::Private::delayedIconUpdate (this=0x88ff410) at ../../kfile/kfilepreviewgenerator.cpp:1088
#13 0x00c059a6 in KFilePreviewGenerator::qt_metacall (this=0x890c490, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfe7428c) at ./kfilepreviewgenerator.moc:95
#14 0x00d77263 in QMetaObject::activate (sender=0x897c148, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#15 0x00d77ec2 in QMetaObject::activate (sender=0x897c148, m=0xe52904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#16 0x00db1667 in QTimer::timeout (this=0x897c148) at .moc/release-shared/moc_qtimer.cpp:128
#17 0x00d7c9ae in QTimer::timerEvent (this=0x897c148, e=0xbfe74720) at kernel/qtimer.cpp:261
#18 0x00d713bf in QObject::event (this=0x897c148, e=0xbfe74720) at kernel/qobject.cpp:1075
#19 0x0237df54 in QApplicationPrivate::notify_helper (this=0x814cfe0, receiver=0x897c148, e=0xbfe74720) at kernel/qapplication.cpp:4056
#20 0x0238567c in QApplication::notify (this=0xbfe75cbc, receiver=0x897c148, e=0xbfe74720) at kernel/qapplication.cpp:3603
#21 0x011bbbfa in KApplication::notify (this=0xbfe75cbc, receiver=0x897c148, event=0xbfe74720) at ../../kdeui/kernel/kapplication.cpp:302
#22 0x00d616cb in QCoreApplication::notifyInternal (this=0xbfe75cbc, receiver=0x897c148, event=0xbfe74720) at kernel/qcoreapplication.cpp:610
#23 0x00d8e7ce in QCoreApplication::sendEvent (this=0x814a634) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QTimerInfoList::activateTimers (this=0x814a634) at kernel/qeventdispatcher_unix.cpp:572
#25 0x00d8c0e0 in timerSourceDispatch (source=0x814a600) at kernel/qeventdispatcher_glib.cpp:165
#26 0x03b35e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x03b39730 in ?? () from /lib/libglib-2.0.so.0
#28 0x03b39863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x00d8c02c in QEventDispatcherGlib::processEvents (this=0x8129a30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#30 0x0241ebe5 in QGuiEventDispatcherGlib::processEvents (this=0x8129a30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#31 0x00d5fc79 in QEventLoop::processEvents (this=0xbfe749e0, flags=) at kernel/qeventloop.cpp:149
#32 0x00d600ca in QEventLoop::exec (this=0xbfe749e0, flags=...) at kernel/qeventloop.cpp:201
#33 0x0286ad53 in QDialog::exec (this=0xbfe74a24) at dialogs/qdialog.cpp:498
#34 0x00722471 in KIO::JobUiDelegate::askSkip (this=0x8b345d8, multi=<value optimized out>, error_text=...) at ../../kio/kio/jobuidelegate.cpp:93
#35 0x006e7c40 in KIO::CopyJobPrivate::slotResultConflictCopyingFiles (this=0x8b09298, job=0x8b22ac0) at ../../kio/kio/copyjob.cpp:1254
#36 0x006e8aed in KIO::CopyJobPrivate::slotResultCopyingFiles (this=0x8b09298, job=0x8b22ac0) at ../../kio/kio/copyjob.cpp:1133
#37 0x006e3172 in KIO::CopyJob::qt_metacall (this=0x8a14368, _c=QMetaObject::InvokeMetaMethod, _id=43, _a=0xbfe74da8) at ./copyjob.moc:115
#38 0x00d77263 in QMetaObject::activate (sender=0x8b22ac0, from_signal_index=7, to_signal_index=7, argv=0xbfe74da8) at kernel/qobject.cpp:3113
#39 0x00d77ec2 in QMetaObject::activate (sender=0x8b22ac0, m=0x80b7400, local_signal_index=3, argv=0xbfe74da8) at kernel/qobject.cpp:3187
#40 0x009abfe3 in KJob::result (this=0x8b22ac0, _t1=0x8b22ac0) at ./kjob.moc:188
#41 0x009ac469 in KJob::emitResult (this=0x8b22ac0) at ../../kdecore/jobs/kjob.cpp:304
#42 0x0071fdba in KIO::FileCopyJob::slotResult (this=0x8b22ac0, job=0x85c0b60) at ../../kio/kio/job.cpp:2137
#43 0x0071f052 in KIO::FileCopyJob::qt_metacall (this=0x8b22ac0, _c=QMetaObject::InvokeMetaMethod, _id=32, _a=0xbfe74f28) at ./jobclasses.moc:673
#44 0x00d77263 in QMetaObject::activate (sender=0x85c0b60, from_signal_index=7, to_signal_index=7, argv=0xbfe74f28) at kernel/qobject.cpp:3113
#45 0x00d77ec2 in QMetaObject::activate (sender=0x85c0b60, m=0x80b7400, local_signal_index=3, argv=0xbfe74f28) at kernel/qobject.cpp:3187
#46 0x009abfe3 in KJob::result (this=0x85c0b60, _t1=0x85c0b60) at ./kjob.moc:188
#47 0x009ac469 in KJob::emitResult (this=0x85c0b60) at ../../kdecore/jobs/kjob.cpp:304
#48 0x00717660 in KIO::SimpleJob::slotFinished (this=0x85c0b60) at ../../kio/kio/job.cpp:477
#49 0x00715403 in KIO::SimpleJob::slotError (this=0x85c0b60, err=129, errorText=...) at ../../kio/kio/job.cpp:489
#50 0x0071554e in KIO::SimpleJob::qt_metacall (this=0x85c0b60, _c=QMetaObject::InvokeMetaMethod, _id=31, _a=0xbfe75184) at ./jobclasses.moc:158
#51 0x0071565a in KIO::DirectCopyJob::qt_metacall (this=0x85c0b60, _c=QMetaObject::InvokeMetaMethod, _id=31, _a=0xbfe75184) at ./job_p.moc:145
#52 0x00d77263 in QMetaObject::activate (sender=0x88f5690, from_signal_index=6, to_signal_index=6, argv=0xbfe75184) at kernel/qobject.cpp:3113
#53 0x00d77ec2 in QMetaObject::activate (sender=0x88f5690, m=0x8c9f64, local_signal_index=2, argv=0xbfe75184) at kernel/qobject.cpp:3187
#54 0x007e15e9 in KIO::SlaveInterface::error (this=0x88f5690, _t1=129, _t2=...) at ./slaveinterface.moc:153
#55 0x007e559c in KIO::SlaveInterface::dispatch (this=0x88f5690, _cmd=102, rawdata=...) at ../../kio/kio/slaveinterface.cpp:208
#56 0x007e1a13 in KIO::SlaveInterface::dispatch (this=0x88f5690) at ../../kio/kio/slaveinterface.cpp:91
#57 0x007d3aea in KIO::Slave::gotInput (this=0x88f5690) at ../../kio/kio/slave.cpp:322
#58 0x007d5ee3 in KIO::Slave::qt_metacall (this=0x88f5690, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfe7541c) at ./slave.moc:76
#59 0x00d77263 in QMetaObject::activate (sender=0x892df30, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#60 0x00d77ec2 in QMetaObject::activate (sender=0x892df30, m=0x8c68a0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#61 0x006ddf97 in KIO::Connection::readyRead (this=0x892df30) at ./connection.moc:86
#62 0x006dfd5e in KIO::ConnectionPrivate::dequeue (this=0x852d5a8) at ../../kio/kio/connection.cpp:82
#63 0x006dfe8e in KIO::Connection::qt_metacall (this=0x892df30, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x895caf0) at ./connection.moc:73
#64 0x00d6ff0b in QMetaCallEvent::placeMetaCall (this=0x8a14d78, object=0x892df30) at kernel/qobject.cpp:477
#65 0x00d715fe in QObject::event (this=0x892df30, e=0x8a14d78) at kernel/qobject.cpp:1111
#66 0x0237df54 in QApplicationPrivate::notify_helper (this=0x814cfe0, receiver=0x892df30, e=0x8a14d78) at kernel/qapplication.cpp:4056
#67 0x0238567c in QApplication::notify (this=0xbfe75cbc, receiver=0x892df30, e=0x8a14d78) at kernel/qapplication.cpp:3603
#68 0x011bbbfa in KApplication::notify (this=0xbfe75cbc, receiver=0x892df30, event=0x8a14d78) at ../../kdeui/kernel/kapplication.cpp:302
#69 0x00d616cb in QCoreApplication::notifyInternal (this=0xbfe75cbc, receiver=0x892df30, event=0x8a14d78) at kernel/qcoreapplication.cpp:610
#70 0x00d622b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8129e48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#71 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8129e48) at kernel/qcoreapplication.cpp:1247
#72 0x00d6247d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#73 0x00d8c3ff in QCoreApplication::sendPostedEvents (s=0x8149910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#74 postEventSourceDispatch (s=0x8149910) at kernel/qeventdispatcher_glib.cpp:210
#75 0x03b35e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#76 0x03b39730 in ?? () from /lib/libglib-2.0.so.0
#77 0x03b39863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#78 0x00d8c02c in QEventDispatcherGlib::processEvents (this=0x8129a30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#79 0x0241ebe5 in QGuiEventDispatcherGlib::processEvents (this=0x8129a30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#80 0x00d5fc79 in QEventLoop::processEvents (this=0xbfe75c14, flags=) at kernel/qeventloop.cpp:149
#81 0x00d600ca in QEventLoop::exec (this=0xbfe75c14, flags=...) at kernel/qeventloop.cpp:201
#82 0x00d6253f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#83 0x0237ddd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#84 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-28 18:43:57 UTC
The issue was fixed in KDE SC 4.4
Thanks

*** This bug has been marked as a duplicate of bug 211525 ***